diff mbox series

[1/1] package/linknx: add lua as optional dependency

Message ID 20171201190957.25699-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/1] package/linknx: add lua as optional dependency | expand

Commit Message

Bernd Kuhls Dec. 1, 2017, 7:09 p.m. UTC
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/linknx/linknx.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Dec. 1, 2017, 9:39 p.m. UTC | #1
Hello,

On Fri,  1 Dec 2017 20:09:57 +0100, Bernd Kuhls wrote:
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/linknx/linknx.mk | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/linknx/linknx.mk b/package/linknx/linknx.mk
index 7965ce4e16..dfabef550e 100644
--- a/package/linknx/linknx.mk
+++ b/package/linknx/linknx.mk
@@ -9,7 +9,6 @@  LINKNX_SITE = $(call github,linknx,linknx,$(LINKNX_VERSION))
 LINKNX_LICENSE = GPL-2.0+
 LINKNX_INSTALL_STAGING = YES
 LINKNX_CONF_OPTS = \
-	--without-lua \
 	--without-log4cpp \
 	--without-pth-test \
 	--with-pth=$(STAGING_DIR)/usr \
@@ -25,6 +24,13 @@  else
 LINKNX_CONF_OPTS += --without-libcurl
 endif
 
+ifeq ($(BR2_PACKAGE_LUA),y)
+LINKNX_CONF_OPTS += --with-lua
+LINKNX_DEPENDENCIES += lua
+else
+LINKNX_CONF_OPTS += --without-lua
+endif
+
 ifeq ($(BR2_PACKAGE_MYSQL),y)
 LINKNX_CONF_OPTS += --with-mysql=$(STAGING_DIR)/usr
 LINKNX_DEPENDENCIES += mysql