diff mbox series

[v3,1/1] package/pinentry: added optional support for qt5

Message ID 20170917170958.5725-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [v3,1/1] package/pinentry: added optional support for qt5 | expand

Commit Message

Bernd Kuhls Sept. 17, 2017, 5:09 p.m. UTC
Upstream added support for qt5:
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=pinentry.git;a=commit;h=abb59f50abf698ff1e56490fb39bcc98c26ab44b

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
v3: added qt5 to backend dependencies, fixed qt comment in pinentry.mk
    (Thomas)
v2: Moved rename of configure option -pinentry-qt4 to -pinentry-qt to
    the patch bumping the package version.

 package/pinentry/Config.in   | 23 ++++++++++++++++++++++-
 package/pinentry/pinentry.mk |  6 ++++--
 2 files changed, 26 insertions(+), 3 deletions(-)

Comments

Arnout Vandecappelle Sept. 24, 2017, 1:40 p.m. UTC | #1
On 17-09-17 19:09, Bernd Kuhls wrote:
> Upstream added support for qt5:
> https://git.gnupg.org/cgi-bin/gitweb.cgi?p=pinentry.git;a=commit;h=abb59f50abf698ff1e56490fb39bcc98c26ab44b
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>


 Applied to master, thanks.

 Unfortunately, I messed up the commit message a bit. I though that the way you
handled the qt4/qt5 difference in the .mk file could be simplified and had
already said so in the commit message, but in the end my idea didn't work so I
reverted it, but I forgot to also revert the commit message. So, even though the
commit message says "completely separate qt4 and qt5 in the .mk file instead of
   making a complicated mix", I didn't actually do that.

 Regards,
 Arnout
diff mbox series

Patch

diff --git a/package/pinentry/Config.in b/package/pinentry/Config.in
index a92cd82a22..781901bbaf 100644
--- a/package/pinentry/Config.in
+++ b/package/pinentry/Config.in
@@ -5,7 +5,10 @@  menuconfig BR2_PACKAGE_PINENTRY
 	select BR2_PACKAGE_LIBASSUAN
 	select BR2_PACKAGE_LIBGPG_ERROR
 	# At least one backend is needed to avoid build breakage
-	select BR2_PACKAGE_PINENTRY_NCURSES if !BR2_PACKAGE_PINENTRY_GTK2 && !BR2_PACKAGE_PINENTRY_QT4
+	select BR2_PACKAGE_PINENTRY_NCURSES if \
+		!BR2_PACKAGE_PINENTRY_GTK2 && \
+		!BR2_PACKAGE_PINENTRY_QT4 && \
+		!BR2_PACKAGE_PINENTRY_QT5
 	help
 	  A collection of simple PIN or pass-phrase entry dialogs
 
@@ -53,4 +56,22 @@  comment "pinentry-qt4 needs a toolchain w/ C++, threads"
 	depends on BR2_USE_MMU
 	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
 
+config BR2_PACKAGE_PINENTRY_QT5
+	bool "pinentry-qt5"
+	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_USE_WCHAR
+	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
+	depends on !BR2_STATIC_LIBS
+	depends on !BR2_PACKAGE_PINENTRY_QT4
+	select BR2_PACKAGE_QT5
+	select BR2_PACKAGE_QT5BASE_GUI
+	select BR2_PACKAGE_QT5BASE_WIDGETS
+	help
+	  The pinentry-qt5 tool
+
+comment "pinentry-qt5 needs a toolchain w/ wchar, NPTL, C++, dynamic library"
+	depends on !BR2_PACKAGE_PINENTRY_QT4
+	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+		!BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS
+
 endif
diff --git a/package/pinentry/pinentry.mk b/package/pinentry/pinentry.mk
index 3f3b24c682..4081a8a5d6 100644
--- a/package/pinentry/pinentry.mk
+++ b/package/pinentry/pinentry.mk
@@ -48,13 +48,15 @@  else
 PINENTRY_CONF_OPTS += --disable-pinentry-gtk2
 endif
 
-# pinentry-qt4 backend
+# pinentry-qt4/5 backend
+ifeq ($(BR2_PACKAGE_PINENTRY_QT4)$(BR2_PACKAGE_PINENTRY_QT5),y)
 ifeq ($(BR2_PACKAGE_PINENTRY_QT4),y)
 # -pthread needs to be passed for certain toolchains
 # http://autobuild.buildroot.net/results/6be/6be109ccedec603a67cebdb31b55865dcce0e128/
 PINENTRY_CONF_OPTS += LIBS=-pthread MOC=$(HOST_DIR)/bin/moc
+endif
 PINENTRY_CONF_OPTS += --enable-pinentry-qt
-PINENTRY_DEPENDENCIES += qt
+PINENTRY_DEPENDENCIES += $(if $(BR2_PACKAGE_PINENTRY_QT4),qt,qt5base)
 else
 PINENTRY_CONF_OPTS += --disable-pinentry-qt
 endif