diff mbox

Makefile: generate wrapper makefile when running make without a .config

Message ID 20170703102405.25977-1-peter@korsgaard.com
State Accepted
Commit 51825df3a184cad0f5bccb6a18b9d6197855cab6
Headers show

Commit Message

Peter Korsgaard July 3, 2017, 10:24 a.m. UTC
The recent change to error out instead of running menuconfig when no .config
is available broke an existing use case:

make O=output-foo; cd output-foo; br-init-conf (or similar to get a sensible .config); make

As there is no wrapper makefile in output-foo.

Fix it by ensuring the wrapper gets created if needed.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle July 3, 2017, 12:25 p.m. UTC | #1
On 03-07-17 12:24, Peter Korsgaard wrote:
> The recent change to error out instead of running menuconfig when no .config
> is available broke an existing use case:
> 
> make O=output-foo; cd output-foo; br-init-conf (or similar to get a sensible .config); make
> 
> As there is no wrapper makefile in output-foo.
> 
> Fix it by ensuring the wrapper gets created if needed.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 However, the br-init-conf script doesn't exist in utils/. Perhaps someone
should add it? :-P

 Regards,
 Arnout

> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/Makefile b/Makefile
> index 36231fa9d6..bfe6fa3e07 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -816,7 +816,7 @@ else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
>  # rule for it.
>  # Also for 'all' we error out and ask the user to configure first.
>  .PHONY: linux toolchain
> -linux toolchain all:
> +linux toolchain all: outputmakefile
>  	$(error Please configure Buildroot first (e.g. "make menuconfig"))
>  	@exit 1
>  
>
Peter Korsgaard July 3, 2017, 1:01 p.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle <arnout@mind.be> writes:

 > On 03-07-17 12:24, Peter Korsgaard wrote:
 >> The recent change to error out instead of running menuconfig when no .config
 >> is available broke an existing use case:
 >> 
 >> make O=output-foo; cd output-foo; br-init-conf (or similar to get a sensible .config); make
 >> 
 >> As there is no wrapper makefile in output-foo.
 >> 
 >> Fix it by ensuring the wrapper gets created if needed.
 >> 
 >> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

 > Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Committed, thanks.

 >  However, the br-init-conf script doesn't exist in utils/. Perhaps someone
 > should add it? :-P

True. Thomas wrote the script, but it very much depends on the
autobuilder toolchains, so probably it needs to be updated with the
changes we're doing now.
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 36231fa9d6..bfe6fa3e07 100644
--- a/Makefile
+++ b/Makefile
@@ -816,7 +816,7 @@  else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 # rule for it.
 # Also for 'all' we error out and ask the user to configure first.
 .PHONY: linux toolchain
-linux toolchain all:
+linux toolchain all: outputmakefile
 	$(error Please configure Buildroot first (e.g. "make menuconfig"))
 	@exit 1