diff mbox

python-web2py: security bump to version 2.14.6

Message ID 20170425134423.3313-1-peter@korsgaard.com
State Accepted
Commit a534030c6e67ff0319f8af2b55fe977a06f17dfd
Headers show

Commit Message

Peter Korsgaard April 25, 2017, 1:44 p.m. UTC
CVE-2016-4806 - Web2py versions 2.14.5 and below was affected by Local File
Inclusion vulnerability, which allows a malicious intended user to
read/access web server sensitive files.

CVE-2016-4807 - Web2py versions 2.14.5 and below was affected by Reflected
XSS vulnerability, which allows an attacker to perform an XSS attack on
logged in user (admin).

CVE-2016-4808 - Web2py versions 2.14.5 and below was affected by CSRF (Cross
Site Request Forgery) vulnerability, which allows an attacker to trick a
logged in user to perform some unwanted actions i.e An attacker can trick an
victim to disable the installed application just by sending a URL to victim.

CVE-2016-10321 - web2py before 2.14.6 does not properly check if a host is
denied before verifying passwords, allowing a remote attacker to perform
brute-force attacks.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/python-web2py/python-web2py.hash | 2 +-
 package/python-web2py/python-web2py.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard April 26, 2017, 7:11 a.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > CVE-2016-4806 - Web2py versions 2.14.5 and below was affected by Local File
 > Inclusion vulnerability, which allows a malicious intended user to
 > read/access web server sensitive files.

 > CVE-2016-4807 - Web2py versions 2.14.5 and below was affected by Reflected
 > XSS vulnerability, which allows an attacker to perform an XSS attack on
 > logged in user (admin).

 > CVE-2016-4808 - Web2py versions 2.14.5 and below was affected by CSRF (Cross
 > Site Request Forgery) vulnerability, which allows an attacker to trick a
 > logged in user to perform some unwanted actions i.e An attacker can trick an
 > victim to disable the installed application just by sending a URL to victim.

 > CVE-2016-10321 - web2py before 2.14.6 does not properly check if a host is
 > denied before verifying passwords, allowing a remote attacker to perform
 > brute-force attacks.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
Peter Korsgaard April 28, 2017, 12:26 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > CVE-2016-4806 - Web2py versions 2.14.5 and below was affected by Local File
 > Inclusion vulnerability, which allows a malicious intended user to
 > read/access web server sensitive files.

 > CVE-2016-4807 - Web2py versions 2.14.5 and below was affected by Reflected
 > XSS vulnerability, which allows an attacker to perform an XSS attack on
 > logged in user (admin).

 > CVE-2016-4808 - Web2py versions 2.14.5 and below was affected by CSRF (Cross
 > Site Request Forgery) vulnerability, which allows an attacker to trick a
 > logged in user to perform some unwanted actions i.e An attacker can trick an
 > victim to disable the installed application just by sending a URL to victim.

 > CVE-2016-10321 - web2py before 2.14.6 does not properly check if a host is
 > denied before verifying passwords, allowing a remote attacker to perform
 > brute-force attacks.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2017.02.x, thanks.
diff mbox

Patch

diff --git a/package/python-web2py/python-web2py.hash b/package/python-web2py/python-web2py.hash
index 3de8dbf4d..9c1de904c 100644
--- a/package/python-web2py/python-web2py.hash
+++ b/package/python-web2py/python-web2py.hash
@@ -1,2 +1,2 @@ 
 # sha256 locally computed
-sha256 7e22a5624d8d2909e165110f0bec6b43ee36ff6834d689f4027e06dece662031   python-web2py-R-2.12.3.tar.gz
+sha256 6079aeaa352ec51e0da5e6abc71fa74cdb3a781e06a311b5826618624362a7b2   python-web2py-R-2.14.6.tar.gz
diff --git a/package/python-web2py/python-web2py.mk b/package/python-web2py/python-web2py.mk
index 7fe9f82f8..9aadb3027 100644
--- a/package/python-web2py/python-web2py.mk
+++ b/package/python-web2py/python-web2py.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-PYTHON_WEB2PY_VERSION = R-2.12.3
+PYTHON_WEB2PY_VERSION = R-2.14.6
 PYTHON_WEB2PY_SITE = $(call github,web2py,web2py,$(PYTHON_WEB2PY_VERSION))
 PYTHON_WEB2PY_LICENSE = LGPL-3.0
 PYTHON_WEB2PY_LICENSE_FILES = LICENSE