diff mbox

libbson: new package

Message ID 20170410145915.22814-1-arnout@mind.be
State Accepted
Headers show

Commit Message

Arnout Vandecappelle April 10, 2017, 2:59 p.m. UTC
From: Sam <semenak94@mail.ru>

Signed-off-by: Semyon Kolganov <semenak94@mail.ru>
[Arnout: remove _SOURCE, fix spelling in comment]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/Config.in            |  1 +
 package/libbson/Config.in    |  6 ++++++
 package/libbson/libbson.hash |  2 ++
 package/libbson/libbson.mk   | 21 +++++++++++++++++++++
 4 files changed, 30 insertions(+)
 create mode 100644 package/libbson/Config.in
 create mode 100644 package/libbson/libbson.hash
 create mode 100644 package/libbson/libbson.mk

Comments

Arnout Vandecappelle April 10, 2017, 3:01 p.m. UTC | #1
On 10-04-17 16:59, Arnout Vandecappelle (Essensium/Mind) wrote:
> From: Sam <semenak94@mail.ru>

 Darn, patchwork screwed up the From. Thomas, can you fix while applying? Needs
to be done anyway...

> 
> Signed-off-by: Semyon Kolganov <semenak94@mail.ru>
> [Arnout: remove _SOURCE, fix spelling in comment]
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  package/Config.in            |  1 +
>  package/libbson/Config.in    |  6 ++++++
>  package/libbson/libbson.hash |  2 ++
>  package/libbson/libbson.mk   | 21 +++++++++++++++++++++
>  4 files changed, 30 insertions(+)
>  create mode 100644 package/libbson/Config.in
>  create mode 100644 package/libbson/libbson.hash
>  create mode 100644 package/libbson/libbson.mk
> 
> diff --git a/package/Config.in b/package/Config.in
> index c12e5b56f9..3683578f1e 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -1159,6 +1159,7 @@ menu "JSON/XML"
>  	source "package/json-c/Config.in"
>  	source "package/json-glib/Config.in"
>  	source "package/jsoncpp/Config.in"
> +	source "package/libbson/Config.in"
>  	source "package/libfastjson/Config.in"
>  	source "package/libjson/Config.in"
>  	source "package/libroxml/Config.in"
> diff --git a/package/libbson/Config.in b/package/libbson/Config.in
> new file mode 100644
> index 0000000000..719271c732
> --- /dev/null
> +++ b/package/libbson/Config.in
> @@ -0,0 +1,6 @@
> +config BR2_PACKAGE_LIBBSON
> +	bool "libbson"
> +	depends on BR2_TOOLCHAIN_HAS_THREADS
> +	help
> +	  libbson is a library providing useful routines related to
> +	  building, parsing, and iterating BSON documents.
> diff --git a/package/libbson/libbson.hash b/package/libbson/libbson.hash
> new file mode 100644
> index 0000000000..27abe90bfd
> --- /dev/null
> +++ b/package/libbson/libbson.hash
> @@ -0,0 +1,2 @@
> +# Locally calculated
> +sha256	aad410123e4bd8a9804c3c3d79e03344e2df104872594dc2cf19605d492944ba libbson-1.6.2.tar.gz
> diff --git a/package/libbson/libbson.mk b/package/libbson/libbson.mk
> new file mode 100644
> index 0000000000..8a71fc394c
> --- /dev/null
> +++ b/package/libbson/libbson.mk
> @@ -0,0 +1,21 @@
> +################################################################################
> +#
> +# libbson
> +#
> +################################################################################
> +
> +LIBBSON_VERSION = 1.6.2
> +LIBBSON_SITE = https://github.com/mongodb/libbson/releases/download/$(LIBBSON_VERSION)
> +LIBBSON_LICENSE = Apache-2.0, MIT (jsonl), ISC (b64), Zlib (md5)
> +LIBBSON_LICENSE_FILES = COPYING THIRD_PARTY_NOTICES
> +LIBBSON_CONF_OPTS = \
> +	--disable-tests \
> +	--disable-examples \
> +	--disable-man-pages \
> +	--disable-html-docs
> +
> +LIBBSON_INSTALL_STAGING = YES
> +
> +# Also has CMake support, but that forces shared+static libs and static
> +# lib has a different name.
> +$(eval $(autotools-package))
>
Thomas Petazzoni April 12, 2017, 7:52 p.m. UTC | #2
Hello,

On Mon, 10 Apr 2017 16:59:15 +0200, Arnout Vandecappelle

>  package/Config.in            |  1 +
>  package/libbson/Config.in    |  6 ++++++
>  package/libbson/libbson.hash |  2 ++
>  package/libbson/libbson.mk   | 21 +++++++++++++++++++++

This lacked an updated to the DEVELOPERS file, so I've fixed this up
when applying.

> diff --git a/package/libbson/Config.in b/package/libbson/Config.in
> new file mode 100644
> index 0000000000..719271c732
> --- /dev/null
> +++ b/package/libbson/Config.in
> @@ -0,0 +1,6 @@
> +config BR2_PACKAGE_LIBBSON
> +	bool "libbson"
> +	depends on BR2_TOOLCHAIN_HAS_THREADS
> +	help
> +	  libbson is a library providing useful routines related to
> +	  building, parsing, and iterating BSON documents.

Thread dependency, but no Config.in comment? I've also fixed this up.

Applied with these two issues fixed. Thanks!

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index c12e5b56f9..3683578f1e 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1159,6 +1159,7 @@  menu "JSON/XML"
 	source "package/json-c/Config.in"
 	source "package/json-glib/Config.in"
 	source "package/jsoncpp/Config.in"
+	source "package/libbson/Config.in"
 	source "package/libfastjson/Config.in"
 	source "package/libjson/Config.in"
 	source "package/libroxml/Config.in"
diff --git a/package/libbson/Config.in b/package/libbson/Config.in
new file mode 100644
index 0000000000..719271c732
--- /dev/null
+++ b/package/libbson/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_LIBBSON
+	bool "libbson"
+	depends on BR2_TOOLCHAIN_HAS_THREADS
+	help
+	  libbson is a library providing useful routines related to
+	  building, parsing, and iterating BSON documents.
diff --git a/package/libbson/libbson.hash b/package/libbson/libbson.hash
new file mode 100644
index 0000000000..27abe90bfd
--- /dev/null
+++ b/package/libbson/libbson.hash
@@ -0,0 +1,2 @@ 
+# Locally calculated
+sha256	aad410123e4bd8a9804c3c3d79e03344e2df104872594dc2cf19605d492944ba libbson-1.6.2.tar.gz
diff --git a/package/libbson/libbson.mk b/package/libbson/libbson.mk
new file mode 100644
index 0000000000..8a71fc394c
--- /dev/null
+++ b/package/libbson/libbson.mk
@@ -0,0 +1,21 @@ 
+################################################################################
+#
+# libbson
+#
+################################################################################
+
+LIBBSON_VERSION = 1.6.2
+LIBBSON_SITE = https://github.com/mongodb/libbson/releases/download/$(LIBBSON_VERSION)
+LIBBSON_LICENSE = Apache-2.0, MIT (jsonl), ISC (b64), Zlib (md5)
+LIBBSON_LICENSE_FILES = COPYING THIRD_PARTY_NOTICES
+LIBBSON_CONF_OPTS = \
+	--disable-tests \
+	--disable-examples \
+	--disable-man-pages \
+	--disable-html-docs
+
+LIBBSON_INSTALL_STAGING = YES
+
+# Also has CMake support, but that forces shared+static libs and static
+# lib has a different name.
+$(eval $(autotools-package))