diff mbox

xapp_xload: fix musl build

Message ID 20161120222858.10102-1-arnout@mind.be
State Accepted
Headers show

Commit Message

Arnout Vandecappelle Nov. 20, 2016, 10:28 p.m. UTC
xapp_xload tries to include protocols/rwhod.h, which isn't available on
musl. Fortunately, the package also has stub code that can be enabled
with -DRLOADSTUB (this is done e.g. on Cygwin).

This should probably be detected in configure, but that's a lot more
work.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/x11r7/xapp_xload/xapp_xload.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni Nov. 21, 2016, 8:22 p.m. UTC | #1
Hello,

On Sun, 20 Nov 2016 23:28:58 +0100, Arnout Vandecappelle
(Essensium/Mind) wrote:
> xapp_xload tries to include protocols/rwhod.h, which isn't available on
> musl. Fortunately, the package also has stub code that can be enabled
> with -DRLOADSTUB (this is done e.g. on Cygwin).
> 
> This should probably be detected in configure, but that's a lot more
> work.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  package/x11r7/xapp_xload/xapp_xload.mk | 5 +++++
>  1 file changed, 5 insertions(+)

You forgot a reference to the autobuilder failure, and I forgot as well
before pushing :/

Applied to master anyway, thanks!

Thomas
diff mbox

Patch

diff --git a/package/x11r7/xapp_xload/xapp_xload.mk b/package/x11r7/xapp_xload/xapp_xload.mk
index 1db0db5..364d247 100644
--- a/package/x11r7/xapp_xload/xapp_xload.mk
+++ b/package/x11r7/xapp_xload/xapp_xload.mk
@@ -11,4 +11,9 @@  XAPP_XLOAD_LICENSE = MIT
 XAPP_XLOAD_LICENSE_FILES = COPYING
 XAPP_XLOAD_DEPENDENCIES = xlib_libXaw
 
+ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
+# musl doesn't have rwhod.h, but xload can replace it with stubs
+XAPP_XLOAD_CONF_OPTS += CFLAGS="$(TARGET_CFLAGS) -DRLOADSTUB"
+endif
+
 $(eval $(autotools-package))