diff mbox

fakeroot: bump version to 1.21-2

Message ID 20161004115320.647-1-maxime.hadjinlian@gmail.com
State Changes Requested
Headers show

Commit Message

Maxime Hadjinlian Oct. 4, 2016, 11:53 a.m. UTC
Since the glibc 2.24-3, and this commit:
https://sourceware.org/git/?p=glibc.git;a=commit;h=80f87443eed17838fe453f1f5406ccf5d3698c25
fakeroot will print spurious message about symbols not being found.

[...]
dlsym(acl_get_fd): /usr/lib/libfakeroot/libfakeroot.so: undefined symbol: acl_get_fd
dlsym(acl_get_file): /usr/lib/libfakeroot/libfakeroot.so: undefined symbol: acl_get_file
dlsym(acl_set_fd): /usr/lib/libfakeroot/libfakeroot.so: undefined symbol: acl_set_fd
dlsym(acl_set_file): /usr/lib/libfakeroot/libfakeroot.so: undefined symbol: acl_set_file
dlsym(acl_get_fd): /usr/lib/libfakeroot/libfakeroot.so: undefined symbol: acl_get_fd
dlsym(acl_get_file): /usr/lib/libfakeroot/libfakeroot.so: undefined symbol: acl_get_file
[...]

It doesn't seem to impair the behavior of fakeroot, it's simply annoying
for the user.

Debian (which is the creator of fakeroot) has a patch which is a
workaround: simply don't display the message.

Since Debian has other patch that may be of interests to Buildroot and
we certainly don't want to maintain our own copies, we now download the
debian tarball to apply all of their patches.

In this version, the configure and Makefile are not provided so we need
to generate them using the 'bootstrap' script included in the source.

Finally, the added patch remove the 'doc' subdirectory from being built.
Without it, the build ends up in error because the install process is
unable to find the manpages files (it looks in the  wrong directory) but
we don't really care about manpages so it's easier to simply disable
building them, gaining a few seconds.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
 .../0001-Makefile.am-remove-doc-subdir.patch       | 27 ++++++++++++++++++++++
 package/fakeroot/fakeroot.hash                     |  8 ++++---
 package/fakeroot/fakeroot.mk                       | 13 ++++++++---
 3 files changed, 42 insertions(+), 6 deletions(-)
 create mode 100644 package/fakeroot/0001-Makefile.am-remove-doc-subdir.patch

Comments

Thomas Petazzoni Oct. 4, 2016, 2:35 p.m. UTC | #1
Hello,

On Tue,  4 Oct 2016 13:53:20 +0200, Maxime Hadjinlian wrote:

> In this version, the configure and Makefile are not provided so we need
> to generate them using the 'bootstrap' script included in the source.

This is super annoying.

First, your patch is wrong because the bootstrap script most likely
needs autoconf and automake, possibly libtool as well, and you haven't
added these to the fakeroot dependencies.

But above all, it means that you would now be adding the build of
autoconf and automake to *every* Buildroot build (since essentially
host-fakeroot is always built). This is really annoying.

So I'd prefer if we just took the Debian patch that works around the
original problem.

Best regards,

Thomas
Maxime Hadjinlian Oct. 4, 2016, 2:39 p.m. UTC | #2
On Tue, Oct 4, 2016 at 4:35 PM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> Hello,
>
> On Tue,  4 Oct 2016 13:53:20 +0200, Maxime Hadjinlian wrote:
>
>> In this version, the configure and Makefile are not provided so we need
>> to generate them using the 'bootstrap' script included in the source.
>
> This is super annoying.
>
> First, your patch is wrong because the bootstrap script most likely
> needs autoconf and automake, possibly libtool as well, and you haven't
> added these to the fakeroot dependencies.
>
> But above all, it means that you would now be adding the build of
> autoconf and automake to *every* Buildroot build (since essentially
> host-fakeroot is always built). This is really annoying.
>
> So I'd prefer if we just took the Debian patch that works around the
> original problem.
OK, will resend.
>
> Best regards,
>
> Thomas
> --
> Thomas Petazzoni, CTO, Free Electrons
> Embedded Linux and Kernel engineering
> http://free-electrons.com
Andreas Naumann March 13, 2017, 10:43 a.m. UTC | #3
Hi,

I have another reason to bump to 1.21, but experience the same 
difficulties in getting the configure step right. What would be a 
sensible way to avoid depending on autoconf/automake?

Background: I experience file ownership issues when doing a 'cp -a' 
inside fakeroot 1.20.2. I tracked it down to the bump commit (from 
1.18.4). Not sure what is causing it, but I just tried 1.21 and all is 
well again.


regards,
Andreas

Am 04.10.2016 um 16:39 schrieb Maxime Hadjinlian:
> On Tue, Oct 4, 2016 at 4:35 PM, Thomas Petazzoni
> <thomas.petazzoni@free-electrons.com> wrote:
>> Hello,
>>
>> On Tue,  4 Oct 2016 13:53:20 +0200, Maxime Hadjinlian wrote:
>>
>>> In this version, the configure and Makefile are not provided so we need
>>> to generate them using the 'bootstrap' script included in the source.
>>
>> This is super annoying.
>>
>> First, your patch is wrong because the bootstrap script most likely
>> needs autoconf and automake, possibly libtool as well, and you haven't
>> added these to the fakeroot dependencies.
>>
>> But above all, it means that you would now be adding the build of
>> autoconf and automake to *every* Buildroot build (since essentially
>> host-fakeroot is always built). This is really annoying.
>>
>> So I'd prefer if we just took the Debian patch that works around the
>> original problem.
> OK, will resend.
>>
>> Best regards,
>>
>> Thomas
>> --
>> Thomas Petazzoni, CTO, Free Electrons
>> Embedded Linux and Kernel engineering
>> http://free-electrons.com
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
Thomas Petazzoni March 13, 2017, 12:32 p.m. UTC | #4
Hello,

On Mon, 13 Mar 2017 11:43:49 +0100, Andreas Naumann wrote:

> I have another reason to bump to 1.21, but experience the same 
> difficulties in getting the configure step right. What would be a 
> sensible way to avoid depending on autoconf/automake?

Is your reason to depend on automake/autoconf still the same as what it
was in Maxime's patch? If so, then we can patch Makefile.in instead of
Makefile.am. We normally don't like that very much, but I personally
prefer this solution over having fakeroot depending on
automake/autoconf.

Best regards,

Thomas
Andreas Naumann March 13, 2017, 3:23 p.m. UTC | #5
Hi,

Am 13.03.2017 um 13:32 schrieb Thomas Petazzoni:
> Hello,
>
> On Mon, 13 Mar 2017 11:43:49 +0100, Andreas Naumann wrote:
>
>> I have another reason to bump to 1.21, but experience the same
>> difficulties in getting the configure step right. What would be a
>> sensible way to avoid depending on autoconf/automake?
>
> Is your reason to depend on automake/autoconf still the same as what it
> was in Maxime's patch?
I think so, but in order test it I used FAKEROOT_AUTORECONF instead of 
running the bootstrap script. However, that does create the same 
dependency on automake/autoconf right?

  If so, then we can patch Makefile.in instead of
> Makefile.am. We normally don't like that very much, but I personally
> prefer this solution over having fakeroot depending on
> automake/autoconf.
There is no Makefile.in, only .am and a configure.ac. Wouldnt a patch 
need to add configure + the contents of build-aux as well? Can you point 
out a package that I can use as an example?


regards,
Andreas


>
> Best regards,
>
> Thomas
>
Yann E. MORIN March 13, 2017, 4:33 p.m. UTC | #6
Andreas, All,

On 2017-03-13 16:23 +0100, Andreas Naumann spake thusly:
> Am 13.03.2017 um 13:32 schrieb Thomas Petazzoni:
> >Hello,
> >
> >On Mon, 13 Mar 2017 11:43:49 +0100, Andreas Naumann wrote:
> >
> >>I have another reason to bump to 1.21, but experience the same
> >>difficulties in getting the configure step right. What would be a
> >>sensible way to avoid depending on autoconf/automake?
> >
> >Is your reason to depend on automake/autoconf still the same as what it
> >was in Maxime's patch?
> I think so, but in order test it I used FAKEROOT_AUTORECONF instead of
> running the bootstrap script. However, that does create the same dependency
> on automake/autoconf right?

I had a look at the diff between 1.20.2 (which we have right now) and
1.21, and the only noticeable delta is the change of a bufgfer size in
mesage.h, the rest of the delta being the removal of the generated
autostuff.

So we can quite safely backport that single change.

I'll send a patch in a moment.

Regards,
Yann E. MORIN.

>  If so, then we can patch Makefile.in instead of
> >Makefile.am. We normally don't like that very much, but I personally
> >prefer this solution over having fakeroot depending on
> >automake/autoconf.
> There is no Makefile.in, only .am and a configure.ac. Wouldnt a patch need
> to add configure + the contents of build-aux as well? Can you point out a
> package that I can use as an example?
> 
> 
> regards,
> Andreas
> 
> 
> >
> >Best regards,
> >
> >Thomas
> >
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni March 14, 2017, 8:16 a.m. UTC | #7
Hello,

On Mon, 13 Mar 2017 17:33:06 +0100, Yann E. MORIN wrote:

> I had a look at the diff between 1.20.2 (which we have right now) and
> 1.21, and the only noticeable delta is the change of a bufgfer size in
> mesage.h, the rest of the delta being the removal of the generated
> autostuff.
> 
> So we can quite safely backport that single change.

Andreas, could you test Yann's patch? Does it fix your problem?

Thanks,

Thomas
Andreas Naumann March 14, 2017, 11:04 a.m. UTC | #8
Hi,


Am 14.03.2017 um 09:16 schrieb Thomas Petazzoni:
> Hello,
>
> On Mon, 13 Mar 2017 17:33:06 +0100, Yann E. MORIN wrote:
>
>> I had a look at the diff between 1.20.2 (which we have right now) and
>> 1.21, and the only noticeable delta is the change of a bufgfer size in
>> mesage.h, the rest of the delta being the removal of the generated
>> autostuff.
>>
>> So we can quite safely backport that single change.
>
> Andreas, could you test Yann's patch? Does it fix your problem?

I just did, but unfortunately it does not help. However, even with plain 
1.21 I no longer get the correct behaviour. Only thing that helps is 
going back to 1.18.4.
It was late Friday when I thought 1.21 was working, but I may have 
tested an Ubuntu version of it (1.21-3.1 or so). I will try to track 
that down.

regards,
Andreas

>
> Thanks,
>
> Thomas
>
Andreas Naumann March 14, 2017, 1:48 p.m. UTC | #9
Hi again,

I cannot confirm that fakeroot 1.21 solves the problem. What works is 
going back to 1.18.4 or using the packaged fakeroot of my host 
(1.20-3ubuntu2).

To describe the issue again, the problem is doing 'cp -a' in the 
fakeroot environment (genimage does this, so I cant easily change this).
However, I'm not so sure if what so far worked is to be expected. After 
all, -a means --preserve=all.

I have a simple test, running the following script under fakeroot after 
building a defconfig, which provides a rootfs.tar:
  rm -rf .tmpdir* rootfs.2.tar
  mkdir .tmpdir
  tar -xzf output/images/rootfs.tar -C .tmpdir
  cp -a .tmpdir .tmpdir2
  tar -cf rootfs.2.tar -C .tmpdir2 .

When done, a
tar -tvf rootfs.2.tar
shows changed permissions for everything and the original owner for files:

drwx------ root/root         0 2017-03-14 13:37 ./
drwx------ root/root         0 2016-10-06 09:03 ./mnt/
drwxrwxrwt root/root         0 2017-03-10 14:44 ./tmp/
drwx------ root/root         0 2017-03-14 13:37 ./tmp/ldconfig/
-rw------- joe/somegroup     33 2017-03-14 13:37 ./tmp/ldconfig/aux-cache
drwx------ root/root             0 2017-03-10 14:35 ./tmp/fontconfig/
...

I tried to apply the patches that Ubuntu has for the host package, but 
that doesnt help either. What else can I do? Can anybody shed some light 
on this?


thanks,
Andreas






Am 14.03.2017 um 12:04 schrieb Andreas Naumann:
> Hi,
>
>
> Am 14.03.2017 um 09:16 schrieb Thomas Petazzoni:
>> Hello,
>>
>> On Mon, 13 Mar 2017 17:33:06 +0100, Yann E. MORIN wrote:
>>
>>> I had a look at the diff between 1.20.2 (which we have right now) and
>>> 1.21, and the only noticeable delta is the change of a bufgfer size in
>>> mesage.h, the rest of the delta being the removal of the generated
>>> autostuff.
>>>
>>> So we can quite safely backport that single change.
>>
>> Andreas, could you test Yann's patch? Does it fix your problem?
>
> I just did, but unfortunately it does not help. However, even with plain
> 1.21 I no longer get the correct behaviour. Only thing that helps is
> going back to 1.18.4.
> It was late Friday when I thought 1.21 was working, but I may have
> tested an Ubuntu version of it (1.21-3.1 or so). I will try to track
> that down.
>
> regards,
> Andreas
>
>>
>> Thanks,
>>
>> Thomas
>>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
Arnout Vandecappelle March 15, 2017, 12:20 a.m. UTC | #10
On 14-03-17 14:48, Andreas Naumann wrote:
> Hi again,
> 
> I cannot confirm that fakeroot 1.21 solves the problem. What works is going back
> to 1.18.4 or using the packaged fakeroot of my host (1.20-3ubuntu2).
> 
> To describe the issue again, the problem is doing 'cp -a' in the fakeroot
> environment (genimage does this, so I cant easily change this).
> However, I'm not so sure if what so far worked is to be expected. After all, -a
> means --preserve=all.
> 
> I have a simple test, running the following script under fakeroot after building
> a defconfig, which provides a rootfs.tar:
>  rm -rf .tmpdir* rootfs.2.tar
>  mkdir .tmpdir
>  tar -xzf output/images/rootfs.tar -C .tmpdir
>  cp -a .tmpdir .tmpdir2
>  tar -cf rootfs.2.tar -C .tmpdir2 .

 For the record, I can reproduce this on my side. I just do "fakeroot
/bin/bash", then do the commands from the shell. Even an ls -l of the copied
files within the fakeroot shell already shows the "arnout" instead of "root"
user. My host fakeroot (Debian 1.21-3.1).

 I have also tried removing the ac_cv_header_sys_capability_h=y, that doesn't
make a difference.

 I have not yet tried applying the Debian patches to the Buildroot-built fakeroot.

 Regards,
 Arnout

> 
> When done, a
> tar -tvf rootfs.2.tar
> shows changed permissions for everything and the original owner for files:
> 
> drwx------ root/root         0 2017-03-14 13:37 ./
> drwx------ root/root         0 2016-10-06 09:03 ./mnt/
> drwxrwxrwt root/root         0 2017-03-10 14:44 ./tmp/
> drwx------ root/root         0 2017-03-14 13:37 ./tmp/ldconfig/
> -rw------- joe/somegroup     33 2017-03-14 13:37 ./tmp/ldconfig/aux-cache
> drwx------ root/root             0 2017-03-10 14:35 ./tmp/fontconfig/
> ...
> 
> I tried to apply the patches that Ubuntu has for the host package, but that
> doesnt help either. What else can I do? Can anybody shed some light on this?
> 
> 
> thanks,
> Andreas
> 
> 
> 
> 
> 
> 
> Am 14.03.2017 um 12:04 schrieb Andreas Naumann:
>> Hi,
>>
>>
>> Am 14.03.2017 um 09:16 schrieb Thomas Petazzoni:
>>> Hello,
>>>
>>> On Mon, 13 Mar 2017 17:33:06 +0100, Yann E. MORIN wrote:
>>>
>>>> I had a look at the diff between 1.20.2 (which we have right now) and
>>>> 1.21, and the only noticeable delta is the change of a bufgfer size in
>>>> mesage.h, the rest of the delta being the removal of the generated
>>>> autostuff.
>>>>
>>>> So we can quite safely backport that single change.
>>>
>>> Andreas, could you test Yann's patch? Does it fix your problem?
>>
>> I just did, but unfortunately it does not help. However, even with plain
>> 1.21 I no longer get the correct behaviour. Only thing that helps is
>> going back to 1.18.4.
>> It was late Friday when I thought 1.21 was working, but I may have
>> tested an Ubuntu version of it (1.21-3.1 or so). I will try to track
>> that down.
>>
>> regards,
>> Andreas
>>
>>>
>>> Thanks,
>>>
>>> Thomas
>>>
>> _______________________________________________
>> buildroot mailing list
>> buildroot@busybox.net
>> http://lists.busybox.net/mailman/listinfo/buildroot
>>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
Andreas Naumann March 15, 2017, 8:17 a.m. UTC | #11
Hi Arnout,

Am 15.03.2017 um 01:20 schrieb Arnout Vandecappelle:
>
>
>  For the record, I can reproduce this on my side. I just do "fakeroot
> /bin/bash", then do the commands from the shell. Even an ls -l of the copied
> files within the fakeroot shell already shows the "arnout" instead of "root"
> user. My host fakeroot (Debian 1.21-3.1).
So are you saying you see this behaviour with your host fakeroot?

>
>  I have also tried removing the ac_cv_header_sys_capability_h=y, that doesn't
> make a difference.
>
>  I have not yet tried applying the Debian patches to the Buildroot-built fakeroot.
I have done this with the Ubuntu patches for 1.20.2 and Debian patches 
for 1.21-3.1 to no avail.


thanks and regards,
Andreas


>
>  Regards,
>  Arnout
>
>>
>> When done, a
>> tar -tvf rootfs.2.tar
>> shows changed permissions for everything and the original owner for files:
>>
>> drwx------ root/root         0 2017-03-14 13:37 ./
>> drwx------ root/root         0 2016-10-06 09:03 ./mnt/
>> drwxrwxrwt root/root         0 2017-03-10 14:44 ./tmp/
>> drwx------ root/root         0 2017-03-14 13:37 ./tmp/ldconfig/
>> -rw------- joe/somegroup     33 2017-03-14 13:37 ./tmp/ldconfig/aux-cache
>> drwx------ root/root             0 2017-03-10 14:35 ./tmp/fontconfig/
>> ...
>>
>> I tried to apply the patches that Ubuntu has for the host package, but that
>> doesnt help either. What else can I do? Can anybody shed some light on this?
>>
>>
>> thanks,
>> Andreas
>>
>>
>>
>>
>>
>>
>> Am 14.03.2017 um 12:04 schrieb Andreas Naumann:
>>> Hi,
>>>
>>>
>>> Am 14.03.2017 um 09:16 schrieb Thomas Petazzoni:
>>>> Hello,
>>>>
>>>> On Mon, 13 Mar 2017 17:33:06 +0100, Yann E. MORIN wrote:
>>>>
>>>>> I had a look at the diff between 1.20.2 (which we have right now) and
>>>>> 1.21, and the only noticeable delta is the change of a bufgfer size in
>>>>> mesage.h, the rest of the delta being the removal of the generated
>>>>> autostuff.
>>>>>
>>>>> So we can quite safely backport that single change.
>>>>
>>>> Andreas, could you test Yann's patch? Does it fix your problem?
>>>
>>> I just did, but unfortunately it does not help. However, even with plain
>>> 1.21 I no longer get the correct behaviour. Only thing that helps is
>>> going back to 1.18.4.
>>> It was late Friday when I thought 1.21 was working, but I may have
>>> tested an Ubuntu version of it (1.21-3.1 or so). I will try to track
>>> that down.
>>>
>>> regards,
>>> Andreas
>>>
>>>>
>>>> Thanks,
>>>>
>>>> Thomas
>>>>
>>> _______________________________________________
>>> buildroot mailing list
>>> buildroot@busybox.net
>>> http://lists.busybox.net/mailman/listinfo/buildroot
>>>
>> _______________________________________________
>> buildroot mailing list
>> buildroot@busybox.net
>> http://lists.busybox.net/mailman/listinfo/buildroot
>>
>
Arnout Vandecappelle March 15, 2017, 7:07 p.m. UTC | #12
On 15-03-17 09:17, Andreas Naumann wrote:
> Hi Arnout,
> 
> Am 15.03.2017 um 01:20 schrieb Arnout Vandecappelle:
>>
>>
>>  For the record, I can reproduce this on my side. I just do "fakeroot
>> /bin/bash", then do the commands from the shell. Even an ls -l of the copied
>> files within the fakeroot shell already shows the "arnout" instead of "root"
>> user. My host fakeroot (Debian 1.21-3.1).
> So are you saying you see this behaviour with your host fakeroot?

 That was only half a sentence, it should have been:

My host fakeroot (Debian 1.21-3.1) doesn't show the problem.

> 
>>
>>  I have also tried removing the ac_cv_header_sys_capability_h=y, that doesn't
>> make a difference.
>>
>>  I have not yet tried applying the Debian patches to the Buildroot-built
>> fakeroot.
> I have done this with the Ubuntu patches for 1.20.2 and Debian patches for
> 1.21-3.1 to no avail.

 My point was to double-check these things, since sometimes issues like this are
environment related.

 Regards,
 Arnout

> 
> 
> thanks and regards,
> Andreas
> 
> 
>>
>>  Regards,
>>  Arnout
>>
>>>
>>> When done, a
>>> tar -tvf rootfs.2.tar
>>> shows changed permissions for everything and the original owner for files:
>>>
>>> drwx------ root/root         0 2017-03-14 13:37 ./
>>> drwx------ root/root         0 2016-10-06 09:03 ./mnt/
>>> drwxrwxrwt root/root         0 2017-03-10 14:44 ./tmp/
>>> drwx------ root/root         0 2017-03-14 13:37 ./tmp/ldconfig/
>>> -rw------- joe/somegroup     33 2017-03-14 13:37 ./tmp/ldconfig/aux-cache
>>> drwx------ root/root             0 2017-03-10 14:35 ./tmp/fontconfig/
>>> ...
>>>
>>> I tried to apply the patches that Ubuntu has for the host package, but that
>>> doesnt help either. What else can I do? Can anybody shed some light on this?
>>>
>>>
>>> thanks,
>>> Andreas
>>>
>>>
>>>
>>>
>>>
>>>
>>> Am 14.03.2017 um 12:04 schrieb Andreas Naumann:
>>>> Hi,
>>>>
>>>>
>>>> Am 14.03.2017 um 09:16 schrieb Thomas Petazzoni:
>>>>> Hello,
>>>>>
>>>>> On Mon, 13 Mar 2017 17:33:06 +0100, Yann E. MORIN wrote:
>>>>>
>>>>>> I had a look at the diff between 1.20.2 (which we have right now) and
>>>>>> 1.21, and the only noticeable delta is the change of a bufgfer size in
>>>>>> mesage.h, the rest of the delta being the removal of the generated
>>>>>> autostuff.
>>>>>>
>>>>>> So we can quite safely backport that single change.
>>>>>
>>>>> Andreas, could you test Yann's patch? Does it fix your problem?
>>>>
>>>> I just did, but unfortunately it does not help. However, even with plain
>>>> 1.21 I no longer get the correct behaviour. Only thing that helps is
>>>> going back to 1.18.4.
>>>> It was late Friday when I thought 1.21 was working, but I may have
>>>> tested an Ubuntu version of it (1.21-3.1 or so). I will try to track
>>>> that down.
>>>>
>>>> regards,
>>>> Andreas
>>>>
>>>>>
>>>>> Thanks,
>>>>>
>>>>> Thomas
>>>>>
>>>> _______________________________________________
>>>> buildroot mailing list
>>>> buildroot@busybox.net
>>>> http://lists.busybox.net/mailman/listinfo/buildroot
>>>>
>>> _______________________________________________
>>> buildroot mailing list
>>> buildroot@busybox.net
>>> http://lists.busybox.net/mailman/listinfo/buildroot
>>>
>>
Arnout Vandecappelle March 15, 2017, 7:46 p.m. UTC | #13
On 15-03-17 20:07, Arnout Vandecappelle wrote:
> 
> 
> On 15-03-17 09:17, Andreas Naumann wrote:
>> Hi Arnout,
>>
>> Am 15.03.2017 um 01:20 schrieb Arnout Vandecappelle:
>>>
>>>
>>>  For the record, I can reproduce this on my side. I just do "fakeroot
>>> /bin/bash", then do the commands from the shell. Even an ls -l of the copied
>>> files within the fakeroot shell already shows the "arnout" instead of "root"
>>> user. My host fakeroot (Debian 1.21-3.1).
>> So are you saying you see this behaviour with your host fakeroot?
> 
>  That was only half a sentence, it should have been:
> 
> My host fakeroot (Debian 1.21-3.1) doesn't show the problem.

 Buildroot fakeroot works fine when I have libacl1-dev installed on my system -
the Debian package has a build dependency on libacl1-dev. So we would need to
add host-acl to FAKEROOT_DEPENDENCIES. That also pulls in host-attr. On my
system, it brings the time for 'make host-fakeroot' on a clean output from

real    0m12.230s
user    0m8.500s
sys     0m1.132s

to

real    0m21.945s
user    0m17.724s
sys     0m2.948s

so a significant slowdown... Although in absolute numbers it is just 10 seconds,
so maybe it is acceptable.

 Anyway, I'll send a patch that does this, let's see if others consider this
overhead acceptable.

 Regards,
 Arnout
Yann E. MORIN March 15, 2017, 8:09 p.m. UTC | #14
Arnout, All,

On 2017-03-15 20:46 +0100, Arnout Vandecappelle spake thusly:
> On 15-03-17 20:07, Arnout Vandecappelle wrote:
[--SNIP--]
>  Buildroot fakeroot works fine when I have libacl1-dev installed on my system -
> the Debian package has a build dependency on libacl1-dev. So we would need to
> add host-acl to FAKEROOT_DEPENDENCIES. That also pulls in host-attr. On my
> system, it brings the time for 'make host-fakeroot' on a clean output from
> 
> real    0m12.230s
> user    0m8.500s
> sys     0m1.132s
> 
> to
> 
> real    0m21.945s
> user    0m17.724s
> sys     0m2.948s
> 
> so a significant slowdown... Although in absolute numbers it is just 10 seconds,
> so maybe it is acceptable.

It's either correctness and a bit of overhead, or inconsistencies.

I know where my vote lies: correctness. ;-)

Regards,
Yann E. MORIN.

>  Anyway, I'll send a patch that does this, let's see if others consider this
> overhead acceptable.
> 
>  Regards,
>  Arnout
> 
> -- 
> Arnout Vandecappelle                          arnout at mind be
> Senior Embedded Software Architect            +32-16-286500
> Essensium/Mind                                http://www.mind.be
> G.Geenslaan 9, 3001 Leuven, Belgium           BE 872 984 063 RPR Leuven
> LinkedIn profile: http://www.linkedin.com/in/arnoutvandecappelle
> GPG fingerprint:  7493 020B C7E3 8618 8DEC 222C 82EB F404 F9AC 0DDF
Peter Korsgaard March 15, 2017, 8:41 p.m. UTC | #15
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > Arnout, All,
 > On 2017-03-15 20:46 +0100, Arnout Vandecappelle spake thusly:
 >> On 15-03-17 20:07, Arnout Vandecappelle wrote:
 > [--SNIP--]
 >> Buildroot fakeroot works fine when I have libacl1-dev installed on my system -
 >> the Debian package has a build dependency on libacl1-dev. So we would need to
 >> add host-acl to FAKEROOT_DEPENDENCIES. That also pulls in host-attr. On my
 >> system, it brings the time for 'make host-fakeroot' on a clean output from
 >> 
 >> real    0m12.230s
 >> user    0m8.500s
 >> sys     0m1.132s
 >> 
 >> to
 >> 
 >> real    0m21.945s
 >> user    0m17.724s
 >> sys     0m2.948s
 >> 
 >> so a significant slowdown... Although in absolute numbers it is just 10 seconds,
 >> so maybe it is acceptable.

 > It's either correctness and a bit of overhead, or inconsistencies.

 > I know where my vote lies: correctness. ;-)

Yes, naturally. I vaguely remember something about an earlier discussion
related to host-acl/host-attr, but that was perhaps about pseudo?
Thomas Petazzoni March 15, 2017, 10:35 p.m. UTC | #16
Hello,

On Wed, 15 Mar 2017 21:41:23 +0100, Peter Korsgaard wrote:

>  > I know where my vote lies: correctness. ;-)  
> 
> Yes, naturally. I vaguely remember something about an earlier discussion
> related to host-acl/host-attr, but that was perhaps about pseudo?

I think it was about host-libcap, not host-acl/host-attr. See commit
c994c3db1f7d76b5dfe79e3b1133d66fdd06212c.

Thomas
Peter Korsgaard March 15, 2017, 10:55 p.m. UTC | #17
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > Hello,
 > On Wed, 15 Mar 2017 21:41:23 +0100, Peter Korsgaard wrote:

 >> > I know where my vote lies: correctness. ;-)  
 >> 
 >> Yes, naturally. I vaguely remember something about an earlier discussion
 >> related to host-acl/host-attr, but that was perhaps about pseudo?

 > I think it was about host-libcap, not host-acl/host-attr. See commit
 > c994c3db1f7d76b5dfe79e3b1133d66fdd06212c.

Ahh yes, you're right.
Andreas Naumann March 16, 2017, 8:13 a.m. UTC | #18
Hi Arnout,

Am 15.03.2017 um 21:09 schrieb Yann E. MORIN:
> Arnout, All,
>
> On 2017-03-15 20:46 +0100, Arnout Vandecappelle spake thusly:
>> On 15-03-17 20:07, Arnout Vandecappelle wrote:
> [--SNIP--]
>>  Buildroot fakeroot works fine when I have libacl1-dev installed on my system -
This is great! And of course, I dont mind the 10 seconds :-)

[snip]
>
> It's either correctness and a bit of overhead, or inconsistencies.
>
> I know where my vote lies: correctness. ;-)
>
> Regards,
> Yann E. MORIN.
>
>>  Anyway, I'll send a patch that does this, let's see if others consider this
>> overhead acceptable.
I'll test as soon as its there.


Thanks and regards,
Andreas

>>
>>  Regards,
>>  Arnout
>>
>> --
>> Arnout Vandecappelle                          arnout at mind be
>> Senior Embedded Software Architect            +32-16-286500
>> Essensium/Mind                                http://www.mind.be
>> G.Geenslaan 9, 3001 Leuven, Belgium           BE 872 984 063 RPR Leuven
>> LinkedIn profile: http://www.linkedin.com/in/arnoutvandecappelle
>> GPG fingerprint:  7493 020B C7E3 8618 8DEC 222C 82EB F404 F9AC 0DDF
>
Arnout Vandecappelle March 16, 2017, 10:39 p.m. UTC | #19
On 16-03-17 09:13, Andreas Naumann wrote:
> Hi Arnout,
> 
> Am 15.03.2017 um 21:09 schrieb Yann E. MORIN:
>> Arnout, All,
>>
>> On 2017-03-15 20:46 +0100, Arnout Vandecappelle spake thusly:
>>> On 15-03-17 20:07, Arnout Vandecappelle wrote:
>> [--SNIP--]
>>>  Buildroot fakeroot works fine when I have libacl1-dev installed on my system -
> This is great! And of course, I dont mind the 10 seconds :-)
> 
> [snip]
>>
>> It's either correctness and a bit of overhead, or inconsistencies.
>>
>> I know where my vote lies: correctness. ;-)
>>
>> Regards,
>> Yann E. MORIN.
>>
>>>  Anyway, I'll send a patch that does this, let's see if others consider this
>>> overhead acceptable.
> I'll test as soon as its there.

 Oops, I thought I already sent it yesterday. Good that you remind me :-)

 Regards,
 Arnout
diff mbox

Patch

diff --git a/package/fakeroot/0001-Makefile.am-remove-doc-subdir.patch b/package/fakeroot/0001-Makefile.am-remove-doc-subdir.patch
new file mode 100644
index 0000000..9a12752
--- /dev/null
+++ b/package/fakeroot/0001-Makefile.am-remove-doc-subdir.patch
@@ -0,0 +1,27 @@ 
+From 9d842122bdd7b59c5166163b6400aa81763bf844 Mon Sep 17 00:00:00 2001
+From: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
+Date: Tue, 4 Oct 2016 11:10:51 +0200
+Subject: [PATCH] Makefile.am: remove doc subdir
+
+It's not interesting in Buildroot context to make the documentation.
+
+Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 6d6f07f..c9c7bb6 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,6 @@
+ AUTOMAKE_OPTIONS=foreign
+ ACLOCAL_AMFLAGS = -I build-aux
+-SUBDIRS=scripts doc test
++SUBDIRS=scripts test
+ 
+ noinst_LTLIBRARIES = libcommunicate.la libmacosx.la
+ libcommunicate_la_SOURCES = communicate.c
+-- 
+2.9.3
+
diff --git a/package/fakeroot/fakeroot.hash b/package/fakeroot/fakeroot.hash
index f0d436e..f326947 100644
--- a/package/fakeroot/fakeroot.hash
+++ b/package/fakeroot/fakeroot.hash
@@ -1,4 +1,6 @@ 
-# From http://snapshot.debian.org/package/fakeroot/1.20.2-1/
-sha1	367040df07043edb630942b21939e493f3fad888	fakeroot_1.20.2.orig.tar.bz2
+# From http://snapshot.debian.org/package/fakeroot/1.21-2/
+sha1	9ce6155c0f3edf310818a09b6b1b8968a8cb0cd4	fakeroot_1.21.orig.tar.gz
+sha1	7f09b96b495f3502ff8d805376eb74cd98ee188f	fakeroot_1.21-2.debian.tar.xz
 # Calculated based on the hash above
-sha256	7c0a164d19db3efa9e802e0fc7cdfeff70ec6d26cdbdc4338c9c2823c5ea230c	fakeroot_1.20.2.orig.tar.bz2
+sha256	2d6ff6900ebc553b0b66d910b5a7ad4889dd738cd757629afe4bc4e80be484e3	fakeroot_1.21-2.debian.tar.xz
+sha256	5d293c1b3604b2a9265d1811a9890c749887ef08aec55f3237d32bf35836171a	fakeroot_1.21.orig.tar.gz
diff --git a/package/fakeroot/fakeroot.mk b/package/fakeroot/fakeroot.mk
index 168cd13..3209792 100644
--- a/package/fakeroot/fakeroot.mk
+++ b/package/fakeroot/fakeroot.mk
@@ -4,9 +4,11 @@ 
 #
 ################################################################################
 
-FAKEROOT_VERSION = 1.20.2
-FAKEROOT_SOURCE = fakeroot_$(FAKEROOT_VERSION).orig.tar.bz2
-FAKEROOT_SITE = http://snapshot.debian.org/archive/debian/20141005T221953Z/pool/main/f/fakeroot
+FAKEROOT_VERSION = 1.21
+FAKEROOT_SOURCE = fakeroot_$(FAKEROOT_VERSION).orig.tar.gz
+FAKEROOT_SITE = http://snapshot.debian.org/archive/debian/20161003T101329Z/pool/main/f/fakeroot
+FAKEROOT_PATCH = \
+	http://snapshot.debian.org/archive/debian/20161003T101329Z/pool/main/f/fakeroot/fakeroot_$(FAKEROOT_VERSION)-2.debian.tar.xz
 # Force capabilities detection off
 # For now these are process capabilities (faked) rather than file
 # so they're of no real use
@@ -17,4 +19,9 @@  HOST_FAKEROOT_CONF_ENV = \
 FAKEROOT_LICENSE = GPLv3+
 FAKEROOT_LICENSE_FILES = COPYING
 
+define FAKEROOT_RUN_BOOTSTRAP
+	cd $(@D) && PATH=$(BR_PATH) ./bootstrap
+endef
+HOST_FAKEROOT_PRE_CONFIGURE_HOOKS += FAKEROOT_RUN_BOOTSTRAP
+
 $(eval $(host-autotools-package))