diff mbox

mpd: allow to enable/disable httpd output

Message ID 20160119224551.GA16917@waldemar-brodkorb.de
State Accepted
Commit 021cc9533237fe7af7dfa3ab273a8a1187be9948
Headers show

Commit Message

Waldemar Brodkorb Jan. 19, 2016, 10:45 p.m. UTC
It might be useful to disable this plugin.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
While testing sparcv8 compile I tried to disable failing features
and plugins and this couldn't be disabled.
---
 package/mpd/Config.in |    5 +++++
 package/mpd/mpd.mk    |    6 ++++++
 2 files changed, 11 insertions(+)

Comments

Peter Korsgaard Jan. 20, 2016, 2:49 p.m. UTC | #1
>>>>> "Waldemar" == Waldemar Brodkorb <wbx@openadk.org> writes:

 > It might be useful to disable this plugin.

> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>

Committed, thanks.
diff mbox

Patch

diff --git a/package/mpd/Config.in b/package/mpd/Config.in
index 0b3bb72..be0843f 100644
--- a/package/mpd/Config.in
+++ b/package/mpd/Config.in
@@ -223,6 +223,11 @@  config BR2_PACKAGE_MPD_AO
 	help
 	  Enable libao output support.
 
+config BR2_PACKAGE_MPD_HTTPD_OUTPUT
+	bool "httpd output"
+	help
+	  Enable httpd output support.
+
 config BR2_PACKAGE_MPD_JACK2
 	bool "jack2"
 	depends on BR2_ARCH_HAS_ATOMICS
diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
index c794e82..7a265f4 100644
--- a/package/mpd/mpd.mk
+++ b/package/mpd/mpd.mk
@@ -92,6 +92,12 @@  else
 MPD_CONF_OPTS += --disable-flac
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_HTTPD_OUTPUT),y)
+MPD_CONF_OPTS += --enable-httpd-output
+else
+MPD_CONF_OPTS += --disable-httpd-output
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_JACK2),y)
 MPD_DEPENDENCIES += jack2
 MPD_CONF_OPTS += --enable-jack