diff mbox

Choose xz compressed tarball for linux kernel.

Message ID 201305110104.51488.rasasi78@gmail.com
State Accepted
Commit 98b5cc3eb4d4103b2149325b98a5e93e68c68dd8
Headers show

Commit Message

Raúl Sánchez Siles May 10, 2013, 11:04 p.m. UTC
Hi:

  This is a retry of previous patch, now inlined as requested. Patch is the same 
as before so no patch version increased.

  I wanted to apologize to Jerzy for my abrupt appearance: I had this patch 
working some time ago and it was standing in my "to send" queue. I was also 
willing to contribute buildroot somehow.

  Regards,

Signed-off-by: Raúl Sánchez Siles <rasasi78@gmail.com>
---
 linux/linux.mk                             |    2 +-
 toolchain/kernel-headers/kernel-headers.mk |    4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni May 11, 2013, 10:11 a.m. UTC | #1
Dear Raúl Sánchez Siles,

On Sat, 11 May 2013 01:04:51 +0200, Raúl Sánchez Siles wrote:
>   Hi:
> 
>   This is a retry of previous patch, now inlined as requested. Patch is the same 
> as before so no patch version increased.
> 
>   I wanted to apologize to Jerzy for my abrupt appearance: I had this patch 
> working some time ago and it was standing in my "to send" queue. I was also 
> willing to contribute buildroot somehow.
> 
>   Regards,
> 
> Signed-off-by: Raúl Sánchez Siles <rasasi78@gmail.com>
> ---
>  linux/linux.mk                             |    2 +-
>  toolchain/kernel-headers/kernel-headers.mk |    4 ++--
>  2 files changed, 3 insertions(+), 3 deletions(-)

Thanks, but your commit log shouldn't contain "personal messages". It
should contain a description of what the patch is. Basically, anything
that's before the "---" remains forever in the Git history of
Buildroot. If you want to put "personal" messages, or a changelog, or
anything like that, please put it after the "---", or in a separate
e-mail that serves as a cover letter.

Thanks!

Thomas
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index d375cf0..3115564 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -16,7 +16,7 @@  else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_GIT),y)
 LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL))
 LINUX_SITE_METHOD = git
 else
-LINUX_SOURCE = linux-$(LINUX_VERSION).tar.bz2
+LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
 # In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
 # to use the $(word) function. We support versions such as 3.1,
 # 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.
diff --git a/toolchain/kernel-headers/kernel-headers.mk b/toolchain/kernel-
headers/kernel-headers.mk
index adf7bc4..b5ae322 100644
--- a/toolchain/kernel-headers/kernel-headers.mk
+++ b/toolchain/kernel-headers/kernel-headers.mk
@@ -31,8 +31,8 @@  LINUX_HEADERS_SITE:=$(BR2_KERNEL_MIRROR:/=)/linux/kernel/v2.6/
 else
 LINUX_HEADERS_SITE:=$(BR2_KERNEL_MIRROR:/=)/linux/kernel/v3.x/
 endif
-LINUX_HEADERS_SOURCE:=linux-$(LINUX_HEADERS_VERSION).tar.bz2
-LINUX_HEADERS_CAT:=$(BZCAT)
+LINUX_HEADERS_SOURCE:=linux-$(LINUX_HEADERS_VERSION).tar.xz
+LINUX_HEADERS_CAT:=$(XZCAT)
 LINUX_HEADERS_UNPACK_DIR:=$(TOOLCHAIN_DIR)/linux-$(LINUX_HEADERS_VERSION)
 LINUX_HEADERS_DIR:=$(TOOLCHAIN_DIR)/linux