diff mbox

[2,of,4] qwt: use TARGET_MAKE_ENV when running make and qmake

Message ID 163c8448b6f2a17be27d.1395257407@argentina
State Accepted
Commit ae5234e3156eb9db3873daf19916307e0f670349
Headers show

Commit Message

Thomas De Schampheleire March 19, 2014, 7:30 p.m. UTC
This patch prepends TARGET_MAKE_ENV to $(MAKE) and $(QT_QMAKE) command
lines, to make sure PATH is set correctly, and to line up with the qt5
packages that do this consistently.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

---
 package/qwt/qwt.mk |  4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle March 25, 2014, 10:54 p.m. UTC | #1
On 19/03/14 20:30, Thomas De Schampheleire wrote:
> This patch prepends TARGET_MAKE_ENV to $(MAKE) and $(QT_QMAKE) command
> lines, to make sure PATH is set correctly, and to line up with the qt5
> packages that do this consistently.
> 
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

> 
> ---
>  package/qwt/qwt.mk |  4 ++--
>  1 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
> --- a/package/qwt/qwt.mk
> +++ b/package/qwt/qwt.mk
> @@ -28,11 +28,11 @@ endif
>  
>  define QWT_CONFIGURE_CMDS
>  	$(SED) $(QWT_CONFIG) $(@D)/qwtconfig.pri
> -	(cd $(@D); $(QT_QMAKE))
> +	(cd $(@D); $(TARGET_MAKE_ENV) $(QT_QMAKE))
>  endef
>  
>  define QWT_BUILD_CMDS
> -	$(MAKE) -C $(@D)
> +	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
>  endef
>  
>  # After installation, we fixup the INSTALL_PREFIX in qwtconfig.pri so
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
diff mbox

Patch

diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
--- a/package/qwt/qwt.mk
+++ b/package/qwt/qwt.mk
@@ -28,11 +28,11 @@  endif
 
 define QWT_CONFIGURE_CMDS
 	$(SED) $(QWT_CONFIG) $(@D)/qwtconfig.pri
-	(cd $(@D); $(QT_QMAKE))
+	(cd $(@D); $(TARGET_MAKE_ENV) $(QT_QMAKE))
 endef
 
 define QWT_BUILD_CMDS
-	$(MAKE) -C $(@D)
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
 endef
 
 # After installation, we fixup the INSTALL_PREFIX in qwtconfig.pri so