diff mbox series

[v3,2/4] package/freescale-imx/firmware-imx: Fix sdma/vpu firmware install path

Message ID 1594382445-4464-3-git-send-email-stephane.viau@oss.nxp.com
State Accepted
Headers show
Series package/freescale-imx: clean-up proposal | expand

Commit Message

Stephane Viau (OSS) July 10, 2020, noon UTC
In a patch set that did not get in for other reasons, Sebastien proposed
to fix the install path directory of the sdma and vpu firmware code [1]:

	"Mainline and NXP kernels expect the sdma firmware to be in
	/lib/firmware/imx/sdma so fix the install path [...]"

By looking at the code, I believe this is correct even though I have no
means to test it.

[1] http://lists.busybox.net/pipermail/buildroot/2020-June/284875.html

Suggested-by: Sébastien Szymanski <sebastien.szymanski at armadeus.com>
Signed-off-by: Stephane Viau <stephane.viau@oss.nxp.com>
---
 package/freescale-imx/firmware-imx/firmware-imx.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 11, 2020, 2:11 p.m. UTC | #1
On Fri, 10 Jul 2020 14:00:43 +0200
Stephane Viau <stephane.viau@oss.nxp.com> wrote:

> In a patch set that did not get in for other reasons, Sebastien proposed
> to fix the install path directory of the sdma and vpu firmware code [1]:
> 
> 	"Mainline and NXP kernels expect the sdma firmware to be in
> 	/lib/firmware/imx/sdma so fix the install path [...]"
> 
> By looking at the code, I believe this is correct even though I have no
> means to test it.
> 
> [1] http://lists.busybox.net/pipermail/buildroot/2020-June/284875.html
> 
> Suggested-by: Sébastien Szymanski <sebastien.szymanski at armadeus.com>
> Signed-off-by: Stephane Viau <stephane.viau@oss.nxp.com>
> ---
>  package/freescale-imx/firmware-imx/firmware-imx.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/freescale-imx/firmware-imx/firmware-imx.mk b/package/freescale-imx/firmware-imx/firmware-imx.mk
index 55ca6fc..c4ac5f7 100644
--- a/package/freescale-imx/firmware-imx/firmware-imx.mk
+++ b/package/freescale-imx/firmware-imx/firmware-imx.mk
@@ -95,7 +95,7 @@  else
 define FIRMWARE_IMX_INSTALL_TARGET_CMDS
 	mkdir -p $(TARGET_DIR)/lib/firmware/imx
 	for blobdir in $(FIRMWARE_IMX_BLOBS); do \
-		cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware; \
+		cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware/imx; \
 	done
 	cp -r $(@D)/firmware/epdc $(TARGET_DIR)/lib/firmware/imx
 	mv $(TARGET_DIR)/lib/firmware/imx/epdc/epdc_ED060XH2C1.fw.nonrestricted \