diff mbox series

[v4,1/4] imx-mkimage: new package

Message ID 1520065060-20046-2-git-send-email-karl.erik.larsson@gmail.com
State Superseded
Headers show
Series Initial support for NXP iMX8 (imx8mq-evk) | expand

Commit Message

Erik Larsson March 3, 2018, 8:17 a.m. UTC
This package add support for imx-mkimage for iMX8M.
Currently the only hardware it's tested for.

Signed-off-by: Erik Larsson <karl.erik.larsson@gmail.com>
Signed-off-by: Christopher Dahlberg <crille.dahlberg@gmail.com>
---
v4: No changes
v3: Use BR2_TARGET_UBOOT_FORMAT_CUSTOM_NAME in U-Boot so we don't
    need to copy u-boot.bin to u-boot-nodtb.bin (suggested by Baruch)
    Update license to GPL-2.0+ (suggested by Marcus F.)
v2: Moved package from package/freescale-imx to package (suggested by Thomas P.)
    Add upstread URL in Config.in (suggested by Thomas P.)
    Fix install syntax in imx-mkimage.mk (suggested by Thomas P.)
    Use Makefile in imx-mkimage to build imx-boot-imx8mqevk-sd.bin instead of doing that in the post-script.sh (suggested Baruch)
---
 package/Config.in.host                             |  1 +
 .../imx-mkimage/0001-remove-git-build-info.patch   | 29 ++++++++++++++++
 package/imx-mkimage/Config.in.host                 | 11 ++++++
 package/imx-mkimage/imx-mkimage.hash               |  3 ++
 package/imx-mkimage/imx-mkimage.mk                 | 39 ++++++++++++++++++++++
 5 files changed, 83 insertions(+)
 create mode 100644 package/imx-mkimage/0001-remove-git-build-info.patch
 create mode 100644 package/imx-mkimage/Config.in.host
 create mode 100644 package/imx-mkimage/imx-mkimage.hash
 create mode 100644 package/imx-mkimage/imx-mkimage.mk

Comments

Thomas Petazzoni March 3, 2018, 3:47 p.m. UTC | #1
Hello,

On Sat,  3 Mar 2018 09:17:37 +0100, Erik Larsson wrote:

> diff --git a/package/imx-mkimage/imx-mkimage.mk b/package/imx-mkimage/imx-mkimage.mk
> new file mode 100644
> index 0000000..506ae75
> --- /dev/null
> +++ b/package/imx-mkimage/imx-mkimage.mk
> @@ -0,0 +1,39 @@
> +################################################################################
> +#
> +# imx-mkimage
> +#
> +################################################################################
> +
> +IMX_MKIMAGE_VERSION = imx_4.9.51_imx8m_beta
> +IMX_MKIMAGE_SITE = https://source.codeaurora.org/external/imx/imx-mkimage
> +IMX_MKIMAGE_SITE_METHOD = git
> +IMX_MKIMAGE_LICENSE = GPL-2.0+
> +IMX_MKIMAGE_LICENSE_FILES = iMX8dv/COPYING
> +HOST_IMX_MKIMAGE_DEPENDENCIES = uboot linux firmware-imx arm-trusted-firmware
> +
> +define HOST_IMX_MKIMAGE_BUILD_CMDS
> +	# These files are generated by firmware-imx, uboot and arm-trusted-firmware
> +	# Copy the files into the iMX8M folder to make building of this package simple
> +	# The NXP engineers has constructed to buildprocess with a bunch of hardcoded
> +	# file names and pathes.
> +
> +	# Currently this only supports iMX8M. When more hardware is available
> +	# this needs to be selectable based on iMX8-version (iMX8M,iMXQ etc).
> +	cp $(BINARIES_DIR)/u-boot-spl.bin $(@D)/iMX8M
> +	cp $(BINARIES_DIR)/lpddr4_pmu_train* $(@D)/iMX8M
> +	cp $(BINARIES_DIR)/fsl-imx8mq-evk.dtb $(@D)/iMX8M
> +	cp $(BINARIES_DIR)/bl31.bin $(@D)/iMX8M
> +	cp ${BINARIES_DIR}/u-boot-nodtb.bin $(@D)/iMX8M
> +
> +	# In soc.mk it's hardcoded that the mkimage tool is named mkimage_uboot
> +	# and that it's located in the iMX8M folder.
> +	cp $(HOST_DIR)/bin/mkimage $(@D)/iMX8M/mkimage_uboot
> +
> +	$(MAKE) -C $(@D) SOC=iMX8M flash_spl_uboot
> +endef
> +
> +define HOST_IMX_MKIMAGE_INSTALL_CMDS
> +	$(INSTALL) -D -m 755 $(@D)/iMX8M/flash.bin $(BINARIES_DIR)/imx-boot-imx8mqevk-sd.bin

I'm not a big fan of the fact that this host package not does not
install any host tool, but instead post-processes images created by
other packages.

Would it be possible for this package to just install host tools, and
then have a post-image script that uses these host tools to provide the
final flash.bin image ?

Thomas
Erik Larsson March 3, 2018, 6:46 p.m. UTC | #2
Hi Thomas,

2018-03-03 16:47 GMT+01:00 Thomas Petazzoni <thomas.petazzoni@bootlin.com>:
> Hello,
>
> On Sat,  3 Mar 2018 09:17:37 +0100, Erik Larsson wrote:
>
>> diff --git a/package/imx-mkimage/imx-mkimage.mk b/package/imx-mkimage/imx-mkimage.mk
>> new file mode 100644
>> index 0000000..506ae75
>> --- /dev/null
>> +++ b/package/imx-mkimage/imx-mkimage.mk
>> @@ -0,0 +1,39 @@
>> +################################################################################
>> +#
>> +# imx-mkimage
>> +#
>> +################################################################################
>> +
>> +IMX_MKIMAGE_VERSION = imx_4.9.51_imx8m_beta
>> +IMX_MKIMAGE_SITE = https://source.codeaurora.org/external/imx/imx-mkimage
>> +IMX_MKIMAGE_SITE_METHOD = git
>> +IMX_MKIMAGE_LICENSE = GPL-2.0+
>> +IMX_MKIMAGE_LICENSE_FILES = iMX8dv/COPYING
>> +HOST_IMX_MKIMAGE_DEPENDENCIES = uboot linux firmware-imx arm-trusted-firmware
>> +
>> +define HOST_IMX_MKIMAGE_BUILD_CMDS
>> +     # These files are generated by firmware-imx, uboot and arm-trusted-firmware
>> +     # Copy the files into the iMX8M folder to make building of this package simple
>> +     # The NXP engineers has constructed to buildprocess with a bunch of hardcoded
>> +     # file names and pathes.
>> +
>> +     # Currently this only supports iMX8M. When more hardware is available
>> +     # this needs to be selectable based on iMX8-version (iMX8M,iMXQ etc).
>> +     cp $(BINARIES_DIR)/u-boot-spl.bin $(@D)/iMX8M
>> +     cp $(BINARIES_DIR)/lpddr4_pmu_train* $(@D)/iMX8M
>> +     cp $(BINARIES_DIR)/fsl-imx8mq-evk.dtb $(@D)/iMX8M
>> +     cp $(BINARIES_DIR)/bl31.bin $(@D)/iMX8M
>> +     cp ${BINARIES_DIR}/u-boot-nodtb.bin $(@D)/iMX8M
>> +
>> +     # In soc.mk it's hardcoded that the mkimage tool is named mkimage_uboot
>> +     # and that it's located in the iMX8M folder.
>> +     cp $(HOST_DIR)/bin/mkimage $(@D)/iMX8M/mkimage_uboot
>> +
>> +     $(MAKE) -C $(@D) SOC=iMX8M flash_spl_uboot
>> +endef
>> +
>> +define HOST_IMX_MKIMAGE_INSTALL_CMDS
>> +     $(INSTALL) -D -m 755 $(@D)/iMX8M/flash.bin $(BINARIES_DIR)/imx-boot-imx8mqevk-sd.bin
>
> I'm not a big fan of the fact that this host package not does not
> install any host tool, but instead post-processes images created by
> other packages.
>
> Would it be possible for this package to just install host tools, and
> then have a post-image script that uses these host tools to provide the
> final flash.bin image ?

This first version if this patch-serie did sort of that. It build and
installed host tools. And then they were used in post-image.sh. But
after a comments/suggestion from Baruch I got encouraged do it this
way. This solution is much clearer when reading the code then the
first version, but maybe with the drawback of this host-package not
really being a host-package as you stated. If you compare this
solution with the first you will see that there is a pretty convoluted
solution for doing parts that are in the Makefile och imx-mkimage. The
main problem here may be the fact that NXP put stuff in there Makefile
that rally doesn't have anything with the creation of the tool.


>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> Embedded Linux and Kernel engineering
> http://bootlin.com

/Erik
Thomas Petazzoni March 9, 2018, 3:26 p.m. UTC | #3
Hello,

On Sat, 3 Mar 2018 19:46:34 +0100, Erik Larsson wrote:

> > I'm not a big fan of the fact that this host package not does not
> > install any host tool, but instead post-processes images created by
> > other packages.
> >
> > Would it be possible for this package to just install host tools, and
> > then have a post-image script that uses these host tools to provide the
> > final flash.bin image ?  
> 
> This first version if this patch-serie did sort of that. It build and
> installed host tools. And then they were used in post-image.sh. But
> after a comments/suggestion from Baruch I got encouraged do it this
> way. This solution is much clearer when reading the code then the
> first version, but maybe with the drawback of this host-package not
> really being a host-package as you stated. If you compare this
> solution with the first you will see that there is a pretty convoluted
> solution for doing parts that are in the Makefile och imx-mkimage. The
> main problem here may be the fact that NXP put stuff in there Makefile
> that rally doesn't have anything with the creation of the tool.

I think I really prefer the approach where the imx-mkimage package only
installs a host tool, and then a post-image script that uses the host
tool installed by imx-mkimage to post-process the images, and generate
the final bootloader.

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/Config.in.host b/package/Config.in.host
index 199a8e9..06ef5cb 100644
--- a/package/Config.in.host
+++ b/package/Config.in.host
@@ -24,6 +24,7 @@  menu "Host utilities"
 	source "package/go-bootstrap/Config.in.host"
 	source "package/google-breakpad/Config.in.host"
 	source "package/gptfdisk/Config.in.host"
+	source "package/imx-mkimage/Config.in.host"
 	source "package/imx-usb-loader/Config.in.host"
 	source "package/jq/Config.in.host"
 	source "package/jsmin/Config.in.host"
diff --git a/package/imx-mkimage/0001-remove-git-build-info.patch b/package/imx-mkimage/0001-remove-git-build-info.patch
new file mode 100644
index 0000000..9f8da02
--- /dev/null
+++ b/package/imx-mkimage/0001-remove-git-build-info.patch
@@ -0,0 +1,29 @@ 
+From d1bb893300b1bd80eaac27fcc8eb4347f56f83b4 Mon Sep 17 00:00:00 2001
+From: Erik Larsson <erik.larsson@combitech.se>
+Date: Thu, 22 Feb 2018 09:56:53 +0100
+Subject: [PATCH] Remove buildinformation step.
+
+Signed-off-by: Erik Larsson <erik.larsson@combitech.se>
+Signed-off-by: Christopher Dahlberg <crille.dahlberg@gmail.com>
+---
+ Makefile | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 4b449ad..4042a39 100644
+--- a/Makefile
++++ b/Makefile
+@@ -33,9 +33,7 @@ $(MKIMG): buildinfo $(SRCS)
+ bin: $(MKIMG)
+ 
+ buildinfo:
+-	@echo -n '#define MKIMAGE_COMMIT 0x' > src/build_info.h
+-	@git rev-parse --short=8 HEAD >> src/build_info.h
+-	@echo '' >> src/build_info.h
++	@echo "#define MKIMAGE_COMMIT 0x0000" > src/build_info.h
+ 
+ help:
+ 	@echo $(CURR_DIR)
+-- 
+2.7.4
+
diff --git a/package/imx-mkimage/Config.in.host b/package/imx-mkimage/Config.in.host
new file mode 100644
index 0000000..411f67c
--- /dev/null
+++ b/package/imx-mkimage/Config.in.host
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_HOST_IMX_MKIMAGE
+	bool "host imx-mkimage"
+	select BR2_PACKAGE_HOST_UBOOT_TOOLS
+	select BR2_PACKAGE_HOST_UBOOT_TOOLS_FIT_SUPPORT
+	depends on BR2_LINUX_KERNEL
+	depends on BR2_TARGET_UBOOT
+	help
+	  imx-mkimage is used to combine input images and generate
+	  final boot image with appropriate IVT set.
+
+	  https://source.codeaurora.org/external/imx/imx-mkimage
diff --git a/package/imx-mkimage/imx-mkimage.hash b/package/imx-mkimage/imx-mkimage.hash
new file mode 100644
index 0000000..08d31ce
--- /dev/null
+++ b/package/imx-mkimage/imx-mkimage.hash
@@ -0,0 +1,3 @@ 
+# Locally calculated
+sha256 4ddb144520001c33baa24493f68ef2ea9434ac36bf3ae223f78d7ec581aa484c  imx-mkimage-imx_4.9.51_imx8m_beta.tar.gz
+sha256 231f7edcc7352d7734a96eef0b8030f77982678c516876fcb81e25b32d68564c  iMX8dv/COPYING
diff --git a/package/imx-mkimage/imx-mkimage.mk b/package/imx-mkimage/imx-mkimage.mk
new file mode 100644
index 0000000..506ae75
--- /dev/null
+++ b/package/imx-mkimage/imx-mkimage.mk
@@ -0,0 +1,39 @@ 
+################################################################################
+#
+# imx-mkimage
+#
+################################################################################
+
+IMX_MKIMAGE_VERSION = imx_4.9.51_imx8m_beta
+IMX_MKIMAGE_SITE = https://source.codeaurora.org/external/imx/imx-mkimage
+IMX_MKIMAGE_SITE_METHOD = git
+IMX_MKIMAGE_LICENSE = GPL-2.0+
+IMX_MKIMAGE_LICENSE_FILES = iMX8dv/COPYING
+HOST_IMX_MKIMAGE_DEPENDENCIES = uboot linux firmware-imx arm-trusted-firmware
+
+define HOST_IMX_MKIMAGE_BUILD_CMDS
+	# These files are generated by firmware-imx, uboot and arm-trusted-firmware
+	# Copy the files into the iMX8M folder to make building of this package simple
+	# The NXP engineers has constructed to buildprocess with a bunch of hardcoded
+	# file names and pathes.
+
+	# Currently this only supports iMX8M. When more hardware is available
+	# this needs to be selectable based on iMX8-version (iMX8M,iMXQ etc).
+	cp $(BINARIES_DIR)/u-boot-spl.bin $(@D)/iMX8M
+	cp $(BINARIES_DIR)/lpddr4_pmu_train* $(@D)/iMX8M
+	cp $(BINARIES_DIR)/fsl-imx8mq-evk.dtb $(@D)/iMX8M
+	cp $(BINARIES_DIR)/bl31.bin $(@D)/iMX8M
+	cp ${BINARIES_DIR}/u-boot-nodtb.bin $(@D)/iMX8M
+
+	# In soc.mk it's hardcoded that the mkimage tool is named mkimage_uboot
+	# and that it's located in the iMX8M folder.
+	cp $(HOST_DIR)/bin/mkimage $(@D)/iMX8M/mkimage_uboot
+
+	$(MAKE) -C $(@D) SOC=iMX8M flash_spl_uboot
+endef
+
+define HOST_IMX_MKIMAGE_INSTALL_CMDS
+	$(INSTALL) -D -m 755 $(@D)/iMX8M/flash.bin $(BINARIES_DIR)/imx-boot-imx8mqevk-sd.bin
+endef
+
+$(eval $(host-generic-package))