diff mbox series

[v2,1/1] LIBLO : bump version to 0.29

Message ID 1518118669-24714-1-git-send-email-alexbaldwinmusic@gmail.com
State Not Applicable
Headers show
Series [v2,1/1] LIBLO : bump version to 0.29 | expand

Commit Message

Alex B Feb. 8, 2018, 7:37 p.m. UTC
From: Alex <alexbaldwinmusic@gmail.com>

Starting from version 0.28, C++ wrappers are provided as well. The configure
script appropriately detects the availability of a C++ compiler so no Buildroot
changes are needed for this.

Building fails with --enable-ipv6 so --disable-ipv6 is needed in CONF_OPTS.
This is known by liblo developers and building without ipv6 support is recomennded.

Included hash for license files.

Signed-off-by: Alex Baldwin <alexbaldwinmusic@gmail.com>

---
CHANGELOG

No longer including a patch for liblo/configure. This was the wrong way of dealing with --enable-ipv6.
SHA256 for COPYING file instead of sha1.
Include  # License files comment for clarity.
---
 package/liblo/liblo.hash | 10 +++++++---
 package/liblo/liblo.mk   |  3 ++-
 2 files changed, 9 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Feb. 8, 2018, 10:04 p.m. UTC | #1
Hello,

On Thu,  8 Feb 2018 20:37:48 +0100, Alex B wrote:

> diff --git a/package/liblo/liblo.hash b/package/liblo/liblo.hash
> index a4e01a6..862b6fb 100644
> --- a/package/liblo/liblo.hash
> +++ b/package/liblo/liblo.hash
> @@ -1,3 +1,7 @@
> -# From http://sourceforge.net/projects/liblo/files/liblo/0.26/
> -sha1	21942c8f19e9829b5842cb85352f98c49dfbc823  liblo-0.26.tar.gz
> -md5	5351de14262560e15e7f23865293b16f  liblo-0.26.tar.gz
> +# From http://sourceforge.net/projects/liblo/files/liblo/0.29/
> +sha1    6aa69456787d3d6ef915281b4a0f8f2c79548ce3  liblo-0.29.tar.gz
> +md5	b0e70bc0fb2254addf94adddf85cffd3  liblo-0.29.tar.gz
> +
> +# Locally computed
> +sha1    caeb68c46fa36651acf592771d09de7937926bb3  COPYING	
> +md5 fbc093901857fcd118f065f900982c24  COPYING

A single sha256 hash was sufficient here.

> diff --git a/package/liblo/liblo.mk b/package/liblo/liblo.mk
> index 3c852be..856b437 100644
> --- a/package/liblo/liblo.mk
> +++ b/package/liblo/liblo.mk
> @@ -4,11 +4,12 @@
>  #
>  ################################################################################
>  
> -LIBLO_VERSION = 0.26
> +LIBLO_VERSION = 0.29
>  LIBLO_SITE = http://downloads.sourceforge.net/project/liblo/liblo/$(LIBLO_VERSION)
>  
>  LIBLO_LICENSE = LGPL-2.1+
>  LIBLO_LICENSE_FILES = COPYING
>  LIBLO_INSTALL_STAGING = YES
> +LIBLO_CONF_OPTS += --disable-ipv6

A comment above this line (in addition to the commit log) would have
been nice.

I've fixed both issues, and applied your patch to next. Thanks!

Thomas
Alex B Feb. 10, 2018, 4:19 p.m. UTC | #2
Hi Thomas,

I  am not sure the best place to address this so please correct me :) I
noticed that this patch failed with your submission as well as Matt
Webber's, but for different reasons.

It seems that on yours
http://autobuild.buildroot.net/results/71a6d7e02a50f6cb53c70c38e82e2a2ae8af13ea/build-end.log
there is a warning about having to redirect <sys/poll.h> to <poll.h> in the
file "server.c:54". This could be sorted with a simple patch, is it
acceptable to patch for this?

On Matt's
http://autobuild.buildroot.net/results/c8b/c8bed3a3fa7d2b2258f573cbfcb01af07419e0bf/build-end.log
we fail because undefined reference to  __atomic_fetch_add_4 . I think a
possible fix could be manually linking to libatomic. I am not entirely sure
why, seems that some compilers are happy to find libatomic on their own and
others aren't. Is this something that buildroot would normally patch for?

Thanks,

Alex


On 8 February 2018 at 23:04, Thomas Petazzoni <thomas.petazzoni@bootlin.com>
wrote:
>
> Hello,
>
> On Thu,  8 Feb 2018 20:37:48 +0100, Alex B wrote:
>
> > diff --git a/package/liblo/liblo.hash b/package/liblo/liblo.hash
> > index a4e01a6..862b6fb 100644
> > --- a/package/liblo/liblo.hash
> > +++ b/package/liblo/liblo.hash
> > @@ -1,3 +1,7 @@
> > -# From http://sourceforge.net/projects/liblo/files/liblo/0.26/
> > -sha1 21942c8f19e9829b5842cb85352f98c49dfbc823  liblo-0.26.tar.gz
> > -md5  5351de14262560e15e7f23865293b16f  liblo-0.26.tar.gz
> > +# From http://sourceforge.net/projects/liblo/files/liblo/0.29/
> > +sha1    6aa69456787d3d6ef915281b4a0f8f2c79548ce3  liblo-0.29.tar.gz
> > +md5  b0e70bc0fb2254addf94adddf85cffd3  liblo-0.29.tar.gz
> > +
> > +# Locally computed
> > +sha1    caeb68c46fa36651acf592771d09de7937926bb3  COPYING
> > +md5 fbc093901857fcd118f065f900982c24  COPYING
>
> A single sha256 hash was sufficient here.
>
> > diff --git a/package/liblo/liblo.mk b/package/liblo/liblo.mk
> > index 3c852be..856b437 100644
> > --- a/package/liblo/liblo.mk
> > +++ b/package/liblo/liblo.mk
> > @@ -4,11 +4,12 @@
> >  #
> >
 ################################################################################
> >
> > -LIBLO_VERSION = 0.26
> > +LIBLO_VERSION = 0.29
> >  LIBLO_SITE =
http://downloads.sourceforge.net/project/liblo/liblo/$(LIBLO_VERSION)
> >
> >  LIBLO_LICENSE = LGPL-2.1+
> >  LIBLO_LICENSE_FILES = COPYING
> >  LIBLO_INSTALL_STAGING = YES
> > +LIBLO_CONF_OPTS += --disable-ipv6
>
> A comment above this line (in addition to the commit log) would have
> been nice.
>
> I've fixed both issues, and applied your patch to next. Thanks!
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> Embedded Linux and Kernel engineering
> http://bootlin.com
<div dir="ltr">Hi Thomas,<br><br>I  am not sure the best place to address this so please correct me :) I noticed that this patch failed with your submission as well as Matt Webber&#39;s, but for different reasons.<br><br>It seems that on yours <a href="http://autobuild.buildroot.net/results/71a6d7e02a50f6cb53c70c38e82e2a2ae8af13ea/build-end.log">http://autobuild.buildroot.net/results/71a6d7e02a50f6cb53c70c38e82e2a2ae8af13ea/build-end.log</a> there is a warning about having to redirect &lt;sys/poll.h&gt; to &lt;poll.h&gt; in the file &quot;server.c:54&quot;. This could be sorted with a simple patch, is it acceptable to patch for this?<br><br>On Matt&#39;s <a href="http://autobuild.buildroot.net/results/c8b/c8bed3a3fa7d2b2258f573cbfcb01af07419e0bf/build-end.log">http://autobuild.buildroot.net/results/c8b/c8bed3a3fa7d2b2258f573cbfcb01af07419e0bf/build-end.log</a> we fail because undefined reference to  __atomic_fetch_add_4 . I think a possible fix could be manually linking to libatomic. I am not entirely sure why, seems that some compilers are happy to find libatomic on their own and others aren&#39;t. Is this something that buildroot would normally patch for?<br><br>Thanks,<br><br>Alex<br><br><br>On 8 February 2018 at 23:04, Thomas Petazzoni &lt;<a href="mailto:thomas.petazzoni@bootlin.com">thomas.petazzoni@bootlin.com</a>&gt; wrote:<br>&gt;<br>&gt; Hello,<br>&gt;<br>&gt; On Thu,  8 Feb 2018 20:37:48 +0100, Alex B wrote:<br>&gt;<br>&gt; &gt; diff --git a/package/liblo/liblo.hash b/package/liblo/liblo.hash<br>&gt; &gt; index a4e01a6..862b6fb 100644<br>&gt; &gt; --- a/package/liblo/liblo.hash<br>&gt; &gt; +++ b/package/liblo/liblo.hash<br>&gt; &gt; @@ -1,3 +1,7 @@<br>&gt; &gt; -# From <a href="http://sourceforge.net/projects/liblo/files/liblo/0.26/">http://sourceforge.net/projects/liblo/files/liblo/0.26/</a><br>&gt; &gt; -sha1 21942c8f19e9829b5842cb85352f98c49dfbc823  liblo-0.26.tar.gz<br>&gt; &gt; -md5  5351de14262560e15e7f23865293b16f  liblo-0.26.tar.gz<br>&gt; &gt; +# From <a href="http://sourceforge.net/projects/liblo/files/liblo/0.29/">http://sourceforge.net/projects/liblo/files/liblo/0.29/</a><br>&gt; &gt; +sha1    6aa69456787d3d6ef915281b4a0f8f2c79548ce3  liblo-0.29.tar.gz<br>&gt; &gt; +md5  b0e70bc0fb2254addf94adddf85cffd3  liblo-0.29.tar.gz<br>&gt; &gt; +<br>&gt; &gt; +# Locally computed<br>&gt; &gt; +sha1    caeb68c46fa36651acf592771d09de7937926bb3  COPYING<br>&gt; &gt; +md5 fbc093901857fcd118f065f900982c24  COPYING<br>&gt;<br>&gt; A single sha256 hash was sufficient here.<br>&gt;<br>&gt; &gt; diff --git a/package/liblo/<a href="http://liblo.mk">liblo.mk</a> b/package/liblo/<a href="http://liblo.mk">liblo.mk</a><br>&gt; &gt; index 3c852be..856b437 100644<br>&gt; &gt; --- a/package/liblo/<a href="http://liblo.mk">liblo.mk</a><br>&gt; &gt; +++ b/package/liblo/<a href="http://liblo.mk">liblo.mk</a><br>&gt; &gt; @@ -4,11 +4,12 @@<br>&gt; &gt;  #<br>&gt; &gt;  ################################################################################<br>&gt; &gt;<br>&gt; &gt; -LIBLO_VERSION = 0.26<br>&gt; &gt; +LIBLO_VERSION = 0.29<br>&gt; &gt;  LIBLO_SITE = <a href="http://downloads.sourceforge.net/project/liblo/liblo/$(LIBLO_VERSION)">http://downloads.sourceforge.net/project/liblo/liblo/$(LIBLO_VERSION)</a><br>&gt; &gt;<br>&gt; &gt;  LIBLO_LICENSE = LGPL-2.1+<br>&gt; &gt;  LIBLO_LICENSE_FILES = COPYING<br>&gt; &gt;  LIBLO_INSTALL_STAGING = YES<br>&gt; &gt; +LIBLO_CONF_OPTS += --disable-ipv6<br>&gt;<br>&gt; A comment above this line (in addition to the commit log) would have<br>&gt; been nice.<br>&gt;<br>&gt; I&#39;ve fixed both issues, and applied your patch to next. Thanks!<br>&gt;<br>&gt; Thomas<br>&gt; --<br>&gt; Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)<br>&gt; Embedded Linux and Kernel engineering<br>&gt; <a href="http://bootlin.com">http://bootlin.com</a></div>
Thomas Petazzoni Feb. 10, 2018, 5:45 p.m. UTC | #3
Hello Alex,

On Sat, 10 Feb 2018 17:19:16 +0100, Alex Baldwin wrote:

> I  am not sure the best place to address this so please correct me :) I
> noticed that this patch failed with your submission as well as Matt
> Webber's, but for different reasons.
> 
> It seems that on yours
> http://autobuild.buildroot.net/results/71a6d7e02a50f6cb53c70c38e82e2a2ae8af13ea/build-end.log
> there is a warning about having to redirect <sys/poll.h> to <poll.h> in the
> file "server.c:54". This could be sorted with a simple patch, is it
> acceptable to patch for this?

Yes, it is acceptable. In addition to fixing this particular problem,
it would be nice to avoid using -Werror. Indeed, the problem here is
that this warning is treated as an error, causing a build failure.

While -Werror makes sense during development, it doesn't make much
sense for releases.

> On Matt's
> http://autobuild.buildroot.net/results/c8b/c8bed3a3fa7d2b2258f573cbfcb01af07419e0bf/build-end.log
> we fail because undefined reference to  __atomic_fetch_add_4 . I think a
> possible fix could be manually linking to libatomic. I am not entirely sure
> why, seems that some compilers are happy to find libatomic on their own and
> others aren't. Is this something that buildroot would normally patch for?

The libatomic situation depends on the architecture. On most
architectures, __atomic_fetch_add_4 is a compiler builtin, so you don't
need to link with libatomic.

However, on SPARC (which is the CPU architecture on which this build
failure occurs), libatomic is needed for __atomic_fetch_add_4.

You have two solutions to handle that:

 (1) Just pass LIBS="-latomic" in LIBLO_CONF_ENV when
     BR2_TOOLCHAIN_HAS_LIBATOMIC=y

 (2) Patch the configure.ac script so that it tests if linking with
     libatomic is needed or not, and links with it if needed.

In any case, if you do a patch against liblo, don't forget to submit it
upstream.

Thanks!

Thomas
Alex B Feb. 11, 2018, 4:25 p.m. UTC | #4
Hi Thomas (sorry about the double message, forgot to include the mailing list!)

On 10 February 2018 at 18:45, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
> Hello Alex,
>
> On Sat, 10 Feb 2018 17:19:16 +0100, Alex Baldwin wrote:
>
>> I  am not sure the best place to address this so please correct me :) I
>> noticed that this patch failed with your submission as well as Matt
>> Webber's, but for different reasons.
>>
>> It seems that on yours
>> http://autobuild.buildroot.net/results/71a6d7e02a50f6cb53c70c38e82e2a2ae8af13ea/build-end.log
>> there is a warning about having to redirect <sys/poll.h> to <poll.h> in the
>> file "server.c:54". This could be sorted with a simple patch, is it
>> acceptable to patch for this?
>
> Yes, it is acceptable. In addition to fixing this particular problem,
> it would be nice to avoid using -Werror. Indeed, the problem here is
> that this warning is treated as an error, causing a build failure.
>
> While -Werror makes sense during development, it doesn't make much
> sense for releases.
>
>> On Matt's
>> http://autobuild.buildroot.net/results/c8b/c8bed3a3fa7d2b2258f573cbfcb01af07419e0bf/build-end.log
>> we fail because undefined reference to  __atomic_fetch_add_4 . I think a
>> possible fix could be manually linking to libatomic. I am not entirely sure
>> why, seems that some compilers are happy to find libatomic on their own and
>> others aren't. Is this something that buildroot would normally patch for?
>
> The libatomic situation depends on the architecture. On most
> architectures, __atomic_fetch_add_4 is a compiler builtin, so you don't
> need to link with libatomic.
>
> However, on SPARC (which is the CPU architecture on which this build
> failure occurs), libatomic is needed for __atomic_fetch_add_4.
>
> You have two solutions to handle that:
>
>  (1) Just pass LIBS="-latomic" in LIBLO_CONF_ENV when
>      BR2_TOOLCHAIN_HAS_LIBATOMIC=y
>
>  (2) Patch the configure.ac script so that it tests if linking with
>      libatomic is needed or not, and links with it if needed.


>
> In any case, if you do a patch against liblo, don't forget to submit it
> upstream.

When submitting this patch should I include it as V3 (as V2 failed),
with all the original patches and ammend the changlog or simply just
submit the new changes?


>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> Embedded Linux and Kernel engineering
> http://bootlin.com

Thanks,

Alex
Thomas Petazzoni Feb. 12, 2018, 8:05 p.m. UTC | #5
Hello,

On Sun, 11 Feb 2018 17:25:25 +0100, Alex Baldwin wrote:

> > In any case, if you do a patch against liblo, don't forget to submit it
> > upstream.  
> 
> When submitting this patch should I include it as V3 (as V2 failed),
> with all the original patches and ammend the changlog or simply just
> submit the new changes?

As replied to your new submission: you should have sent just the new
changes, because the liblo package has been applied to the next branch
already (which is why it was tested by our autobuilders, and why you
received e-mails about build failures).

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/liblo/liblo.hash b/package/liblo/liblo.hash
index a4e01a6..862b6fb 100644
--- a/package/liblo/liblo.hash
+++ b/package/liblo/liblo.hash
@@ -1,3 +1,7 @@ 
-# From http://sourceforge.net/projects/liblo/files/liblo/0.26/
-sha1	21942c8f19e9829b5842cb85352f98c49dfbc823  liblo-0.26.tar.gz
-md5	5351de14262560e15e7f23865293b16f  liblo-0.26.tar.gz
+# From http://sourceforge.net/projects/liblo/files/liblo/0.29/
+sha1    6aa69456787d3d6ef915281b4a0f8f2c79548ce3  liblo-0.29.tar.gz
+md5	b0e70bc0fb2254addf94adddf85cffd3  liblo-0.29.tar.gz
+
+# Locally computed
+sha1    caeb68c46fa36651acf592771d09de7937926bb3  COPYING	
+md5 fbc093901857fcd118f065f900982c24  COPYING
diff --git a/package/liblo/liblo.mk b/package/liblo/liblo.mk
index 3c852be..856b437 100644
--- a/package/liblo/liblo.mk
+++ b/package/liblo/liblo.mk
@@ -4,11 +4,12 @@ 
 #
 ################################################################################
 
-LIBLO_VERSION = 0.26
+LIBLO_VERSION = 0.29
 LIBLO_SITE = http://downloads.sourceforge.net/project/liblo/liblo/$(LIBLO_VERSION)
 
 LIBLO_LICENSE = LGPL-2.1+
 LIBLO_LICENSE_FILES = COPYING
 LIBLO_INSTALL_STAGING = YES
+LIBLO_CONF_OPTS += --disable-ipv6
 
 $(eval $(autotools-package))