diff mbox series

[RFC,v4,4/4] package/runc: converting to golang infrastructure

Message ID 1508879672-12957-4-git-send-email-angelo.compagnucci@gmail.com
State Superseded
Headers show
Series [RFC,v4,1/4] package/pkg-golang: new package infrastructure | expand

Commit Message

Angelo Compagnucci Oct. 24, 2017, 9:14 p.m. UTC
This patch converts the runc package to the new golang
infrastructure.

Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
---
 package/runc/runc.mk | 36 +++---------------------------------
 1 file changed, 3 insertions(+), 33 deletions(-)

Comments

Arnout Vandecappelle Oct. 24, 2017, 10:14 p.m. UTC | #1
On 24-10-17 23:14, Angelo Compagnucci wrote:
> -RUNC_GOTAGS = cgo static_build
> +RUNC_GO_TAGS = cgo static_build
>  
>  ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
>  RUNC_GOTAGS += seccomp

 I guess this should be RUNC_GO_TAGS?

 Regards,
 Arnout

>  RUNC_DEPENDENCIES += libseccomp host-pkgconf
>  endif
diff mbox series

Patch

diff --git a/package/runc/runc.mk b/package/runc/runc.mk
index 0b51e11..5d9e732 100644
--- a/package/runc/runc.mk
+++ b/package/runc/runc.mk
@@ -9,43 +9,13 @@  RUNC_SITE = $(call github,opencontainers,runc,$(RUNC_VERSION))
 RUNC_LICENSE = Apache-2.0
 RUNC_LICENSE_FILES = LICENSE
 
-RUNC_DEPENDENCIES = host-go
+RUNC_GO_LDFLAGS = -X main.gitCommit=$(RUNC_VERSION)
 
-RUNC_GOPATH = "$(@D)/Godeps/_workspace"
-RUNC_MAKE_ENV = $(HOST_GO_TARGET_ENV) \
-	CGO_ENABLED=1 \
-	GOBIN="$(@D)/bin" \
-	GOPATH="$(RUNC_GOPATH)" \
-	PATH=$(BR_PATH)
-
-RUNC_GLDFLAGS = \
-	-X main.gitCommit=$(RUNC_VERSION)
-
-ifeq ($(BR2_STATIC_LIBS),y)
-RUNC_GLDFLAGS += -extldflags '-static'
-endif
-
-RUNC_GOTAGS = cgo static_build
+RUNC_GO_TAGS = cgo static_build
 
 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
 RUNC_GOTAGS += seccomp
 RUNC_DEPENDENCIES += libseccomp host-pkgconf
 endif
 
-define RUNC_CONFIGURE_CMDS
-	mkdir -p $(RUNC_GOPATH)/src/github.com/opencontainers
-	ln -s $(@D) $(RUNC_GOPATH)/src/github.com/opencontainers/runc
-endef
-
-define RUNC_BUILD_CMDS
-	cd $(RUNC_GOPATH)/src/github.com/opencontainers/runc && \
-		$(RUNC_MAKE_ENV) $(HOST_DIR)/bin/go \
-		build -v -o $(@D)/bin/runc \
-		-tags "$(RUNC_GOTAGS)" -ldflags "$(RUNC_GLDFLAGS)" .
-endef
-
-define RUNC_INSTALL_TARGET_CMDS
-	$(INSTALL) -D -m 0755 $(@D)/bin/runc $(TARGET_DIR)/usr/bin/runc
-endef
-
-$(eval $(generic-package))
+$(eval $(golang-package))