diff mbox

assimp: work around gcc bug on SuperH

Message ID 1488148706-15109-1-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Headers show

Commit Message

Thomas Petazzoni Feb. 26, 2017, 10:38 p.m. UTC
gcc versions earlier than gcc 6.x fail to build assimp on SuperH when
static linking:

  AssxmlExporter.cpp:623:1: error: unable to find a register to spill in class 'GENERAL_REGS'

It's the combination of -Os and *not* having -fPIC that makes gcc
fail, which explains why configurations with dynamic linking work
fine.

 -Os -fPIC -> works
 -Os       -> fails
 -O2 -fPIC -> works
 -O2       -> works

Therefore, as a workaround, we are forcing the use of -O2 on SuperH
when the gcc version is older than gcc 6.x and we're statically
linking.

Fixes:

  http://autobuild.buildroot.net/results/ec88aa8118179e30e24603cc45292047dca19216/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/assimp/assimp.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni Feb. 27, 2017, 8:39 p.m. UTC | #1
Hello,

On Sun, 26 Feb 2017 23:38:26 +0100, Thomas Petazzoni wrote:
> gcc versions earlier than gcc 6.x fail to build assimp on SuperH when
> static linking:
> 
>   AssxmlExporter.cpp:623:1: error: unable to find a register to spill in class 'GENERAL_REGS'
> 
> It's the combination of -Os and *not* having -fPIC that makes gcc
> fail, which explains why configurations with dynamic linking work
> fine.
> 
>  -Os -fPIC -> works
>  -Os       -> fails
>  -O2 -fPIC -> works
>  -O2       -> works
> 
> Therefore, as a workaround, we are forcing the use of -O2 on SuperH
> when the gcc version is older than gcc 6.x and we're statically
> linking.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/ec88aa8118179e30e24603cc45292047dca19216/
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
>  package/assimp/assimp.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)

Applied to master, thanks.

Thomas
diff mbox

Patch

diff --git a/package/assimp/assimp.mk b/package/assimp/assimp.mk
index 08893ff..298e121 100644
--- a/package/assimp/assimp.mk
+++ b/package/assimp/assimp.mk
@@ -16,6 +16,14 @@  ifeq ($(BR2_m68k),y)
 ASSIMP_CXXFLAGS += -mxgot
 endif
 
+# workaround SuperH compiler failure when static linking (i.e -fPIC is
+# not passed) in gcc versions 5.x or older. The -Os optimization level
+# causes a "unable to find a register to spill in class
+# ‘GENERAL_REGS’" error. -O2 works fine.
+ifeq ($(BR2_sh):$(BR2_STATIC_LIBS):$(BR2_HOST_GCC_AT_LEAST_6),y:y:)
+ASSIMP_CXXFLAGS += -O2
+endif
+
 ASSIMP_CONF_OPTS += -DASSIMP_BUILD_TESTS=OFF \
 	-DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) $(ASSIMP_CXXFLAGS)"