diff mbox

package/open2300: fix static builds

Message ID 1467637517-14388-1-git-send-email-yann.morin.1998@free.fr
State Accepted
Commit 382fa60f9c7445e962b290c74779a0e0fd7e310f
Headers show

Commit Message

Yann E. MORIN July 4, 2016, 1:05 p.m. UTC
libmysqlclient needs -lz to build, so we have to pass it explicitly for
static builds.

For almost-two-and-a-half years this error has been happenning, noone
ever tried to fix it. This is now done, at last! ;-]

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/open2300/open2300.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Peter Korsgaard July 4, 2016, 1:40 p.m. UTC | #1
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > libmysqlclient needs -lz to build, so we have to pass it explicitly for
 > static builds.

 > For almost-two-and-a-half years this error has been happenning, noone
 > ever tried to fix it. This is now done, at last! ;-]

 > Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Committed after adding a reference to the autobuilders, thanks.
diff mbox

Patch

diff --git a/package/open2300/open2300.mk b/package/open2300/open2300.mk
index 73db2a0..323f566 100644
--- a/package/open2300/open2300.mk
+++ b/package/open2300/open2300.mk
@@ -21,6 +21,10 @@  OPEN2300_DEPENDENCIES += mysql
 OPEN2300_BINS += mysql2300 mysqlhistlog2300
 OPEN2300_CFLAGS += -I$(STAGING_DIR)/usr/include/mysql
 OPEN2300_LDFLAGS += -L$(STAGING_DIR)/usr/lib/mysql -lmysqlclient
+ifeq ($(BR2_STATIC_LIBS),y)
+# mysql needs -lz, so we need to specify it for static builds
+OPEN2300_LDFLAGS += -lz
+endif
 endif
 
 define OPEN2300_BUILD_CMDS