diff mbox

[01/31] package/systemd: add optional support for tmpfiles

Message ID 1467409891-9458-1-git-send-email-maxime.hadjinlian@gmail.com
State Accepted
Headers show

Commit Message

Maxime Hadjinlian July 1, 2016, 9:51 p.m. UTC
From: Gabe Evans <gabe@hashrabbit.co>

Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
[Maxime: Add default y]
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
 package/systemd/Config.in  | 10 ++++++++++
 package/systemd/systemd.mk |  6 ++++++
 2 files changed, 16 insertions(+)

Comments

Thomas Petazzoni July 2, 2016, 11:14 a.m. UTC | #1
Hello,

On Fri,  1 Jul 2016 23:51:01 +0200, Maxime Hadjinlian wrote:
> From: Gabe Evans <gabe@hashrabbit.co>
> 
> Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
> [Maxime: Add default y]
> Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>

I've applied patches 1-18, but for many of them, I had to rewrap the
Config.in help text as several of them had too long lines.

Due to this, patch 19 (which re-orders the Config.in options) did not
apply, with lots of conflicts.

I nonetheless managed to apply patches 20, 21, 22, 23 and 24, as well
as 27 and 28. So you have 19, 25, 26, 29, 30 and 31 that remain to be
applied. I've kept them in the "New" state on patchwork so that you can
easily identify what remains to be applied.

Also, could you integrate your bootchard changes in the same series, in
order to avoid conflicts?

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/systemd/Config.in b/package/systemd/Config.in
index 324e884..65998a4 100644
--- a/package/systemd/Config.in
+++ b/package/systemd/Config.in
@@ -131,6 +131,16 @@  config BR2_PACKAGE_SYSTEMD_QUOTACHECK
 
 	  http://www.freedesktop.org/software/systemd/man/systemd-quotacheck.service.html
 
+config BR2_PACKAGE_SYSTEMD_TMPFILES
+	bool "enable tmpfiles support"
+	default y
+	help
+	  systemd-tmpfiles creates, deletes, and cleans up volatile and temporary
+	  files and directories, based on the configuration file format and location
+	  specified in tmpfiles.d(5).
+
+	  http://www.freedesktop.org/software/systemd/man/systemd-tmpfiles.html
+
 config BR2_PACKAGE_SYSTEMD_NETWORKD
 	bool "enable network manager"
 	help
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index c0503ae..779d7c5 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -159,6 +159,12 @@  else
 SYSTEMD_CONF_OPTS += --disable-quotacheck
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_TMPFILES),y)
+SYSTEMD_CONF_OPTS += --enable-tmpfiles
+else
+SYSTEMD_CONF_OPTS += --disable-tmpfiles
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += --enable-networkd
 define SYSTEMD_INSTALL_RESOLVCONF_HOOK