diff mbox

[1/2] Set PGROOT dir owner to be "postgres".

Message ID 1457296152-4047-2-git-send-email-alan@tkos.co.il
State Rejected
Headers show

Commit Message

Alan Yaniger March 6, 2016, 8:29 p.m. UTC
Without this
 change, the postgres server fails to start on boot.

Signed-off-by: Alan Yaniger <alan@tkos.co.il>
---
 package/postgresql/postgresql.mk | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox

Patch

diff --git a/package/postgresql/postgresql.mk b/package/postgresql/postgresql.mk
index 444c1b1..5906ce9 100644
--- a/package/postgresql/postgresql.mk
+++ b/package/postgresql/postgresql.mk
@@ -17,6 +17,10 @@  POSTGRESQL_CONF_ENV = ac_cv_type_struct_sockaddr_in6=yes \
 POSTGRESQL_AUTORECONF = YES
 POSTGRESQL_CONF_OPTS = --disable-rpath
 
+define POSTGRESQL_PERMISSIONS
+	/var/lib/pgsql d 755 postgres postgres - - - - -
+endef
+
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 # PostgreSQL does not build against uClibc with locales
 # enabled, due to an uClibc bug, see