diff mbox

[v3,02/37] package/expedite: move to package directory

Message ID 1444471422-15118-3-git-send-email-romain.naour@openwide.fr
State Changes Requested
Headers show

Commit Message

Romain Naour Oct. 10, 2015, 10:03 a.m. UTC
Add efl reverse dependencies.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
 package/Config.in                |  1 +
 package/efl/Config.in            |  1 -
 package/efl/expedite/Config.in   | 15 ---------------
 package/efl/expedite/expedite.mk | 20 --------------------
 package/expedite/Config.in       | 18 ++++++++++++++++++
 package/expedite/expedite.mk     | 20 ++++++++++++++++++++
 6 files changed, 39 insertions(+), 36 deletions(-)
 delete mode 100644 package/efl/expedite/Config.in
 delete mode 100644 package/efl/expedite/expedite.mk
 create mode 100644 package/expedite/Config.in
 create mode 100644 package/expedite/expedite.mk

Comments

Thomas Petazzoni Oct. 10, 2015, 10:54 a.m. UTC | #1
Dear Romain Naour,

On Sat, 10 Oct 2015 12:03:07 +0200, Romain Naour wrote:
> Add efl reverse dependencies.

This is a bit of a poor commit log. Why do you move expedite to the
package/ directory? And what does it mean to "add reverse
dependencies" ?

Also, it seems like you don't have rename detection enabled in Git.

Thanks,

Thomas
Romain Naour Oct. 10, 2015, 12:43 p.m. UTC | #2
Hi Thomas,

Le 10/10/2015 12:54, Thomas Petazzoni a écrit :
> Dear Romain Naour,
> 
> On Sat, 10 Oct 2015 12:03:07 +0200, Romain Naour wrote:
>> Add efl reverse dependencies.
> 
> This is a bit of a poor commit log. Why do you move expedite to the
> package/ directory? And what does it mean to "add reverse
> dependencies" ?

Ok, I'll complete the commit log with this:

"We usually do not have a sub-directory for a family of related packages, so
move expedite to package directory.
Since expedite now select the efl package, propagate the reverse dependencies on
mmu and wchar."

I'll fixes that also in the following patches.

> 
> Also, it seems like you don't have rename detection enabled in Git.

Indeed, sorry for that... The patch generated with git format-patch didn't look
like the one viewed through gitk.
I fixed that using:
git config --global diff.renames copies

Also the following patches moving efl packages to package directory have the
same issue...

Best regards,
Romain

> 
> Thanks,
> 
> Thomas
>
Thomas Petazzoni Oct. 10, 2015, 12:55 p.m. UTC | #3
Dear Romain Naour,

On Sat, 10 Oct 2015 14:43:35 +0200, Romain Naour wrote:

> "We usually do not have a sub-directory for a family of related packages, so
> move expedite to package directory.

This is not exactly true. When they need to share the same version
number (example: qt5), then we do have a sub-directory for a family of
related packages. So I think this should be reworded a bit.

> > Also, it seems like you don't have rename detection enabled in Git.
> 
> Indeed, sorry for that... The patch generated with git format-patch didn't look
> like the one viewed through gitk.
> I fixed that using:
> git config --global diff.renames copies
> 
> Also the following patches moving efl packages to package directory have the
> same issue...

Perfect. It will indeed make the review easier.

Thanks!

Thomas
Romain Naour Oct. 10, 2015, 1:31 p.m. UTC | #4
Hi Thomas,

Le 10/10/2015 14:55, Thomas Petazzoni a écrit :
> Dear Romain Naour,
> 
> On Sat, 10 Oct 2015 14:43:35 +0200, Romain Naour wrote:
> 
>> "We usually do not have a sub-directory for a family of related packages, so
>> move expedite to package directory.
> 
> This is not exactly true. When they need to share the same version
> number (example: qt5), then we do have a sub-directory for a family of
> related packages. So I think this should be reworded a bit.

IIRC the sentence has been borrowed from a commit log from matchbox series
http://git.buildroot.net/buildroot/commit/?id=3b468acbb4ec2aca748fc022ff0d53a530b3264b

Yann, no offense :)

I think there is no advantage for efl related packages to share the same version
number anymore, Except maybe for efl and libelementary...

See: https://www.enlightenment.org/download

EFL			1.15.2
Elementary		1.15.2
Emotion Generic Players	1.15.0
Evas Generic Loaders	1.15.0
Python-EFL		1.15.0

expedite is downloaded from the 1.15 branch in the git repository

> 
>>> Also, it seems like you don't have rename detection enabled in Git.
>>
>> Indeed, sorry for that... The patch generated with git format-patch didn't look
>> like the one viewed through gitk.
>> I fixed that using:
>> git config --global diff.renames copies
>>
>> Also the following patches moving efl packages to package directory have the
>> same issue...
> 
> Perfect. It will indeed make the review easier.

Thanks for noticing it.

Best regards,
Romain

> 
> Thanks!
> 
> Thomas
>
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 3794f44..fbe3d62 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -66,6 +66,7 @@  menu "Debugging, profiling and benchmark"
 	source "package/dropwatch/Config.in"
 	source "package/dstat/Config.in"
 	source "package/duma/Config.in"
+	source "package/expedite/Config.in"
 	source "package/fio/Config.in"
 	source "package/gdb/Config.in"
 	source "package/google-breakpad/Config.in"
diff --git a/package/efl/Config.in b/package/efl/Config.in
index 3d31a26..cb91660 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -10,7 +10,6 @@  menuconfig BR2_PACKAGE_EFL
 
 if BR2_PACKAGE_EFL
 
-source "package/efl/expedite/Config.in"
 source "package/efl/libeina/Config.in"
 source "package/efl/libecore/Config.in"
 source "package/efl/libeet/Config.in"
diff --git a/package/efl/expedite/Config.in b/package/efl/expedite/Config.in
deleted file mode 100644
index 1e12108..0000000
--- a/package/efl/expedite/Config.in
+++ /dev/null
@@ -1,15 +0,0 @@ 
-config BR2_PACKAGE_EXPEDITE
-	bool "expedite"
-	select BR2_PACKAGE_LIBEINA
-	select BR2_PACKAGE_LIBEVAS
-	select BR2_PACKAGE_LIBEET
-	depends on BR2_INSTALL_LIBSTDCPP
-	depends on BR2_TOOLCHAIN_HAS_THREADS # libevas
-	help
-	  Expedite is the official Evas benchmark tool. It can test different
-	  engines, such as X11, XRender, OpenGL (also ES variant), SDL,
-	  DirectFB and so on. Its tests are quite extensive, trying to
-	  reproduce real world usage cases.
-
-comment "expedite needs a toolchain w/ C++, threads"
-	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/efl/expedite/expedite.mk b/package/efl/expedite/expedite.mk
deleted file mode 100644
index 9b232f8..0000000
--- a/package/efl/expedite/expedite.mk
+++ /dev/null
@@ -1,20 +0,0 @@ 
-################################################################################
-#
-# expedite
-#
-################################################################################
-
-EXPEDITE_VERSION = 1.7.10
-EXPEDITE_SITE = http://download.enlightenment.org/releases
-EXPEDITE_LICENSE = BSD-2c
-EXPEDITE_LICENSE_FILES = COPYING
-
-EXPEDITE_DEPENDENCIES = libevas libeina libeet
-
-ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
-EXPEDITE_CONF_OPTS += --with-x=$(STAGING_DIR) \
-	--x-includes=$(STAGING_DIR)/usr/include \
-	--x-libraries=$(STAGING_DIR)/usr/lib
-endif
-
-$(eval $(autotools-package))
diff --git a/package/expedite/Config.in b/package/expedite/Config.in
new file mode 100644
index 0000000..82bceb9
--- /dev/null
+++ b/package/expedite/Config.in
@@ -0,0 +1,18 @@ 
+config BR2_PACKAGE_EXPEDITE
+	bool "expedite"
+	select BR2_PACKAGE_EFL
+	select BR2_PACKAGE_LIBEINA
+	select BR2_PACKAGE_LIBEVAS
+	select BR2_PACKAGE_LIBEET
+	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_TOOLCHAIN_HAS_THREADS # libevas
+	depends on BR2_USE_MMU # efl
+	depends on BR2_USE_WCHAR # efl
+	help
+	  Expedite is the official Evas benchmark tool. It can test different
+	  engines, such as X11, XRender, OpenGL (also ES variant), SDL,
+	  DirectFB and so on. Its tests are quite extensive, trying to
+	  reproduce real world usage cases.
+
+comment "expedite needs a toolchain w/ C++, threads, wchar"
+	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
diff --git a/package/expedite/expedite.mk b/package/expedite/expedite.mk
new file mode 100644
index 0000000..9b232f8
--- /dev/null
+++ b/package/expedite/expedite.mk
@@ -0,0 +1,20 @@ 
+################################################################################
+#
+# expedite
+#
+################################################################################
+
+EXPEDITE_VERSION = 1.7.10
+EXPEDITE_SITE = http://download.enlightenment.org/releases
+EXPEDITE_LICENSE = BSD-2c
+EXPEDITE_LICENSE_FILES = COPYING
+
+EXPEDITE_DEPENDENCIES = libevas libeina libeet
+
+ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
+EXPEDITE_CONF_OPTS += --with-x=$(STAGING_DIR) \
+	--x-includes=$(STAGING_DIR)/usr/include \
+	--x-libraries=$(STAGING_DIR)/usr/lib
+endif
+
+$(eval $(autotools-package))