diff mbox

[v3,15/37] package/efl: add frame buffer config option

Message ID 1444471422-15118-16-git-send-email-romain.naour@openwide.fr
State Changes Requested
Headers show

Commit Message

Romain Naour Oct. 10, 2015, 10:03 a.m. UTC
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
 package/efl/Config.in | 5 +++++
 package/efl/efl.mk    | 6 ++++++
 2 files changed, 11 insertions(+)
diff mbox

Patch

diff --git a/package/efl/Config.in b/package/efl/Config.in
index 6815189..00b14ca 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -36,6 +36,11 @@  config BR2_PACKAGE_EFL_RECOMMENDED_CONFIG
 	  otherwise we need to add a very long and obscure option
 	  to start the build.
 
+comment "libecore video support"
+
+config BR2_PACKAGE_EFL_FB
+	bool "libecore framebuffer support"
+
 comment "libevas loaders"
 
 config BR2_PACKAGE_EFL_PNG
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index 4441d91..35ee466 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -165,6 +165,12 @@  else
 EFL_CONF_OPTS += --enable-wayland=no
 endif
 
+ifeq ($(BR2_PACKAGE_EFL_FB),y)
+EFL_CONF_OPTS += --enable-fb=yes
+else
+EFL_CONF_OPTS += --enable-fb=no
+endif
+
 # image loader: handle only loaders that requires dependencies.
 # All other loaders are builded by default statically.
 ifeq ($(BR2_PACKAGE_EFL_PNG),y)