diff mbox

[PACH,v2,25/38] package/libelementary: add host package

Message ID 1441747212-27421-26-git-send-email-romain.naour@openwide.fr
State Superseded
Headers show

Commit Message

Romain Naour Sept. 8, 2015, 9:19 p.m. UTC
libelementary for the target needs elm_prefs_cc in order to
cross-compile correctly.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
 package/libelementary/libelementary.mk | 14 +++++++++++++-
 1 file changed, 13 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/libelementary/libelementary.mk b/package/libelementary/libelementary.mk
index fb16d6a..74a8d7a 100644
--- a/package/libelementary/libelementary.mk
+++ b/package/libelementary/libelementary.mk
@@ -12,14 +12,26 @@  LIBELEMENTARY_LICENSE_FILES = COPYING
 
 LIBELEMENTARY_INSTALL_STAGING = YES
 
-LIBELEMENTARY_DEPENDENCIES = host-pkgconf host-efl efl
+LIBELEMENTARY_DEPENDENCIES = host-pkgconf host-efl efl host-libelementary
 
 LIBELEMENTARY_CONF_OPTS = \
 	--with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
 	--with-eet-eet=$(HOST_DIR)/usr/bin/eet \
 	--with-eolian-gen=$(HOST_DIR)/usr/bin/eolian_gen \
 	--with-eldbus_codegen=$(HOST_DIR)/usr/bin/eldbus-codegen \
+	--with-elm-prefs-cc=$(HOST_DIR)/usr/bin/elm_prefs_cc \
 	--with-doxygen=no \
 	--disable-elementary-test
 
+# We need a host package in order to provide elm_prefs_cc and
+# elementary_codegen.
+HOST_LIBELEMENTARY_DEPENDENCIES = host-pkgconf host-efl
+HOST_LIBELEMENTARY_CONF_OPTS = \
+	--with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
+	--with-eet-eet=$(HOST_DIR)/usr/bin/eet \
+	--with-eolian-gen=$(HOST_DIR)/usr/bin/eolian_gen \
+ 	--with-doxygen=no \
+ 	--disable-elementary-test
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))