diff mbox

[1/1] package/shairport-sync: bump to version 2.4

Message ID 1441639190-7447-1-git-send-email-joerg.krause@embedded.rocks
State Changes Requested
Headers show

Commit Message

Jörg Krause Sept. 7, 2015, 3:19 p.m. UTC
Version 2.4 of shairport-sync introduces new optional features (metadata,
stdout, pipe) which we enable by default. The impact on the binary size is
about 18 kB (110 kB vs 92 kB) for an ARM target.

Also add a new dependency to libconfig and install the default config script.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
 package/shairport-sync/Config.in         | 1 +
 package/shairport-sync/shairport-sync.mk | 9 +++++++--
 2 files changed, 8 insertions(+), 2 deletions(-)

Comments

Baruch Siach Sept. 7, 2015, 6:15 p.m. UTC | #1
Hi Jörg,

On Mon, Sep 07, 2015 at 05:19:50PM +0200, Jörg Krause wrote:
> Version 2.4 of shairport-sync introduces new optional features (metadata,
> stdout, pipe) which we enable by default. The impact on the binary size is
> about 18 kB (110 kB vs 92 kB) for an ARM target.
> 
> Also add a new dependency to libconfig and install the default config script.
> 
> Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
> ---
>  package/shairport-sync/Config.in         | 1 +
>  package/shairport-sync/shairport-sync.mk | 9 +++++++--
>  2 files changed, 8 insertions(+), 2 deletions(-)
> 
> diff --git a/package/shairport-sync/Config.in b/package/shairport-sync/Config.in
> index c1d81a7..c558a64 100644
> --- a/package/shairport-sync/Config.in
> +++ b/package/shairport-sync/Config.in
> @@ -4,6 +4,7 @@ config BR2_PACKAGE_SHAIRPORT_SYNC
>  	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
>  	select BR2_PACKAGE_ALSA_LIB
>  	select BR2_PACKAGE_ALSA_LIB_MIXER
> +	select BR2_PACKAGE_LIBCONFIG

Isn't that a build time dependency? If so, please add to 
SHAIRPORT_SYNC_DEPENDENCIES as well.

baruch
diff mbox

Patch

diff --git a/package/shairport-sync/Config.in b/package/shairport-sync/Config.in
index c1d81a7..c558a64 100644
--- a/package/shairport-sync/Config.in
+++ b/package/shairport-sync/Config.in
@@ -4,6 +4,7 @@  config BR2_PACKAGE_SHAIRPORT_SYNC
 	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
 	select BR2_PACKAGE_ALSA_LIB
 	select BR2_PACKAGE_ALSA_LIB_MIXER
+	select BR2_PACKAGE_LIBCONFIG
 	select BR2_PACKAGE_LIBDAEMON
 	select BR2_PACKAGE_POLARSSL if !BR2_PACKAGE_OPENSSL
 	select BR2_PACKAGE_POPT
diff --git a/package/shairport-sync/shairport-sync.mk b/package/shairport-sync/shairport-sync.mk
index 881cced..5cf56a3 100644
--- a/package/shairport-sync/shairport-sync.mk
+++ b/package/shairport-sync/shairport-sync.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-SHAIRPORT_SYNC_VERSION = 2.2.4
+SHAIRPORT_SYNC_VERSION = 2.4
 SHAIRPORT_SYNC_SITE = $(call github,mikebrady,shairport-sync,$(SHAIRPORT_SYNC_VERSION))
 
 SHAIRPORT_SYNC_LICENSE = MIT, BSD-3c
@@ -14,7 +14,10 @@  SHAIRPORT_SYNC_DEPENDENCIES = alsa-lib libdaemon popt host-pkgconf
 # Touching configure.ac with the patches
 SHAIRPORT_SYNC_AUTORECONF = YES
 
-SHAIRPORT_SYNC_CONF_OPTS = --with-alsa
+SHAIRPORT_SYNC_CONF_OPTS = --with-alsa \
+	--with-metadata \
+	--with-pipe \
+	--with-stdout
 
 # Avahi or tinysvcmdns (shaiport-sync bundles its own version of tinysvcmdns).
 # Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
@@ -45,6 +48,8 @@  endif
 define SHAIRPORT_SYNC_INSTALL_TARGET_CMDS
 	$(INSTALL) -D -m 0755 $(@D)/shairport-sync \
 		$(TARGET_DIR)/usr/bin/shairport-sync
+	$(INSTALL) -D -m 0644 $(@D)/scripts/shairport-sync.conf \
+		$(TARGET_DIR)/etc/shairport-sync.conf
 endef
 
 define SHAIRPORT_SYNC_INSTALL_INIT_SYSV