diff mbox

[1/1] release: remove manual build files from release tarballs

Message ID 1437128435-17331-1-git-send-email-patrickdepinguin@gmail.com
State Accepted
Headers show

Commit Message

Thomas De Schampheleire July 17, 2015, 10:20 a.m. UTC
From: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

The Buildroot release tarballs inadvertently contain a build/docs directory,
containing the manual sources, the generated lists, and manual.text and
manual.pdf (but excluding manual.html).

This directory is populated as $(BUILD_DIR) (==$(O)/build), while O is
set explicitly from the release target to a subdirectory
buildroot-xxxx.yy-git/ which was populated with 'git archive'.

Since the generated manuals are available in docs/manual, which is
also referred to from the README, the build directory is not needed and
should be removed from the release tarball.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
---
 Makefile | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN July 17, 2015, 4:53 p.m. UTC | #1
Thomas, All,

On 2015-07-17 12:20 +0200, Thomas De Schampheleire spake thusly:
> From: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
> 
> The Buildroot release tarballs inadvertently contain a build/docs directory,
> containing the manual sources, the generated lists, and manual.text and
> manual.pdf (but excluding manual.html).
> 
> This directory is populated as $(BUILD_DIR) (==$(O)/build), while O is
> set explicitly from the release target to a subdirectory
> buildroot-xxxx.yy-git/ which was populated with 'git archive'.
> 
> Since the generated manuals are available in docs/manual, which is
> also referred to from the README, the build directory is not needed and
> should be removed from the release tarball.
> 
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  Makefile | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/Makefile b/Makefile
> index 531ac5d..168d62a 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -936,6 +936,7 @@ release: OUT = buildroot-$(BR2_VERSION)
>  release:
>  	git archive --format=tar --prefix=$(OUT)/ HEAD > $(OUT).tar
>  	$(MAKE) O=$(OUT) manual-html manual-text manual-pdf
> +	$(MAKE) O=$(OUT) manual-clean
>  	tar rf $(OUT).tar $(OUT)
>  	gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
>  	bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2
> -- 
> 1.8.5.1
>
Thomas Petazzoni July 18, 2015, 9:11 a.m. UTC | #2
Dear Thomas De Schampheleire,

On Fri, 17 Jul 2015 12:20:35 +0200, Thomas De Schampheleire wrote:
> From: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
> 
> The Buildroot release tarballs inadvertently contain a build/docs directory,
> containing the manual sources, the generated lists, and manual.text and
> manual.pdf (but excluding manual.html).
> 
> This directory is populated as $(BUILD_DIR) (==$(O)/build), while O is
> set explicitly from the release target to a subdirectory
> buildroot-xxxx.yy-git/ which was populated with 'git archive'.
> 
> Since the generated manuals are available in docs/manual, which is
> also referred to from the README, the build directory is not needed and
> should be removed from the release tarball.
> 
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
> ---
>  Makefile | 1 +
>  1 file changed, 1 insertion(+)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 531ac5d..168d62a 100644
--- a/Makefile
+++ b/Makefile
@@ -936,6 +936,7 @@  release: OUT = buildroot-$(BR2_VERSION)
 release:
 	git archive --format=tar --prefix=$(OUT)/ HEAD > $(OUT).tar
 	$(MAKE) O=$(OUT) manual-html manual-text manual-pdf
+	$(MAKE) O=$(OUT) manual-clean
 	tar rf $(OUT).tar $(OUT)
 	gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
 	bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2