diff mbox

[v3,1/1] linux: add config options for nfs-utils

Message ID 1436886176-118956-1-git-send-email-ryan.barnett@rockwellcollins.com
State Rejected
Headers show

Commit Message

Ryan Barnett July 14, 2015, 3:02 p.m. UTC
When nfs-utils packages is selected, automatically enable the kernel
options for NFSD. This will allow for an NFS server to work by only
adding /etc/exports to the filesystem.

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
---
Test with qemu_x86_defconfig

Changes v2 -> v3:
  - Add CONFIG_NFSD_V3 option as well to really support only v3 of NFS

Changes v1 -> v2:
  - Only enable CONFIG_NFSD (suggested by Arnout)
---
 linux/linux.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Arnout Vandecappelle Oct. 4, 2015, 5:58 p.m. UTC | #1
On 14-07-15 16:02, Ryan Barnett wrote:
> When nfs-utils packages is selected, automatically enable the kernel
> options for NFSD. This will allow for an NFS server to work by only
> adding /etc/exports to the filesystem.
> 
> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>

 Hi Ryan,

 I've marked your patch as Rejected in patchwork. We don't want to add automatic
kernel config fiddling unless really needed for either building (e.g.
xtables-addons builds a kernel module that requires specific functions) or for
booting (e.g. systemd, ARM ABI).

 In addition, in this particular case, it's possible that someone enables
nfs-utils just to be able to run rpc.statd in a nfs client that requires locking.

 So instead, we think it's better to update the nfs-utils help test to mention
the Kconfig options that have to be enabled to have an NFS server.

 Sorry that it had to come to a v3 and several months later before coming to
such a conclusion.

 Regards,
 Arnout
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index 8c535f3..31e1f01 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -217,6 +217,9 @@  define LINUX_KCONFIG_FIXUP_CMDS
 	$(if $(BR2_PACKAGE_XTABLES_ADDONS),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
 		$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
+	$(if $(BR2_PACKAGE_NFS_UTILS),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_NFSD,$(@D)/.config)
+		$(call KCONFIG_ENABLE_OPT,CONFIG_NFSD_V3,$(@D)/.config))
 	$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
 endef