diff mbox

[1/1] linux: add server options for NFSD

Message ID 1436829189-90663-1-git-send-email-ryan.barnett@rockwellcollins.com
State Changes Requested
Headers show

Commit Message

Ryan Barnett July 13, 2015, 11:13 p.m. UTC
When nfs-utils packages is selected, automatically enable the kernel
options for NFSD. This will allow for an NFS server to work by only
adding /etc/exports to the filesystem.

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
---

Test with qemu_x86_defconfig

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
---
 linux/linux.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Arnout Vandecappelle July 13, 2015, 11:22 p.m. UTC | #1
On 07/14/15 01:13, Ryan Barnett wrote:
> When nfs-utils packages is selected, automatically enable the kernel
> options for NFSD. This will allow for an NFS server to work by only
> adding /etc/exports to the filesystem.
> 
> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
> ---
> 
> Test with qemu_x86_defconfig
> 
> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
> ---
>  linux/linux.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/linux/linux.mk b/linux/linux.mk
> index b602a04..ef876c4 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -229,6 +229,9 @@ define LINUX_KCONFIG_FIXUP_CMDS
>  	$(if $(BR2_PACKAGE_XTABLES_ADDONS),
>  		$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
>  		$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
> +	$(if $(BR2_PACKAGE_NFS_UTILS),
> +		$(call KCONFIG_ENABLE_OPT,CONFIG_NFSD,$(@D)/.config)
> +		$(call KCONFIG_ENABLE_OPT,CONFIG_NFSD_V4,$(@D)/.config))

 Since v4 is currently disabled in nfs-utils, this isn't useful at the moment,
right?

 Regards,
 Arnout

>  	$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
>  		$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
>  endef
>
Ryan Barnett July 13, 2015, 11:30 p.m. UTC | #2
Arnout,

On Mon, Jul 13, 2015 at 6:22 PM, Arnout Vandecappelle <arnout@mind.be> wrote:
> On 07/14/15 01:13, Ryan Barnett wrote:
>> When nfs-utils packages is selected, automatically enable the kernel
>> options for NFSD. This will allow for an NFS server to work by only
>> adding /etc/exports to the filesystem.
>>
>> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
>> ---
>>
>> Test with qemu_x86_defconfig
>>
>> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
>> ---
>>  linux/linux.mk | 3 +++
>>  1 file changed, 3 insertions(+)
>>
>> diff --git a/linux/linux.mk b/linux/linux.mk
>> index b602a04..ef876c4 100644
>> --- a/linux/linux.mk
>> +++ b/linux/linux.mk
>> @@ -229,6 +229,9 @@ define LINUX_KCONFIG_FIXUP_CMDS
>>       $(if $(BR2_PACKAGE_XTABLES_ADDONS),
>>               $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
>>               $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
>> +     $(if $(BR2_PACKAGE_NFS_UTILS),
>> +             $(call KCONFIG_ENABLE_OPT,CONFIG_NFSD,$(@D)/.config)
>> +             $(call KCONFIG_ENABLE_OPT,CONFIG_NFSD_V4,$(@D)/.config))
>
>  Since v4 is currently disabled in nfs-utils, this isn't useful at the moment,
> right?

Hmm - good catch I just assumed that it had the support enabled. I
will send an update to just support CONFIG_NFSD.

Thanks,
-Ryan
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index b602a04..ef876c4 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -229,6 +229,9 @@  define LINUX_KCONFIG_FIXUP_CMDS
 	$(if $(BR2_PACKAGE_XTABLES_ADDONS),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
 		$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
+	$(if $(BR2_PACKAGE_NFS_UTILS),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_NFSD,$(@D)/.config)
+		$(call KCONFIG_ENABLE_OPT,CONFIG_NFSD_V4,$(@D)/.config))
 	$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
 endef