diff mbox

[4/6] php: add PHP_VERSION_MAJOR variable

Message ID 1431978724-25081-4-git-send-email-bos@je-eigen-domein.nl
State Accepted
Commit 24d340fd46c082f71d04db186fdb703b39b57f22
Headers show

Commit Message

Floris Bos May 18, 2015, 7:52 p.m. UTC
Add PHP_VERSION_MAJOR variable to php.mk for use by other packages.
E.g. to install the Ioncube loader binary, it is necessary to
know the PHP major version.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
---
 package/php/php.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni May 18, 2015, 8:25 p.m. UTC | #1
Dear Floris Bos,

On Mon, 18 May 2015 21:52:02 +0200, Floris Bos wrote:
> Add PHP_VERSION_MAJOR variable to php.mk for use by other packages.
> E.g. to install the Ioncube loader binary, it is necessary to
> know the PHP major version.

Are such packages going to be submitted to Buildroot at some point?

Thanks,

Thomas
Floris Bos May 18, 2015, 8:34 p.m. UTC | #2
On 05/18/2015 10:25 PM, Thomas Petazzoni wrote:
> Dear Floris Bos,
>
> On Mon, 18 May 2015 21:52:02 +0200, Floris Bos wrote:
>> Add PHP_VERSION_MAJOR variable to php.mk for use by other packages.
>> E.g. to install the Ioncube loader binary, it is necessary to
>> know the PHP major version.
> Are such packages going to be submitted to Buildroot at some point?
>

Maybe some time in the future.
There are currently some practical packaging problems with Ioncube, that 
have to be solved by the developer first.
Like that they only offer the latest version of the package for direct 
download, and not previous versions.


Yours sincerely,

Floris Bos
Peter Korsgaard May 20, 2015, 11:17 a.m. UTC | #3
>>>>> "Floris" == Floris Bos <bos@je-eigen-domein.nl> writes:

 > Add PHP_VERSION_MAJOR variable to php.mk for use by other packages.
 > E.g. to install the Ioncube loader binary, it is necessary to
 > know the PHP major version.

 > Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>

Committed, thanks.
diff mbox

Patch

diff --git a/package/php/php.mk b/package/php/php.mk
index 65d5015..1635a63 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -4,7 +4,8 @@ 
 #
 ################################################################################
 
-PHP_VERSION = 5.6.8
+PHP_VERSION_MAJOR = 5.6
+PHP_VERSION = $(PHP_VERSION_MAJOR).8
 PHP_SITE = http://www.php.net/distributions
 PHP_SOURCE = php-$(PHP_VERSION).tar.xz
 PHP_INSTALL_STAGING = YES