diff mbox

Backport valgrind patch to fix build on 4.0 host kernels

Message ID 1430933218-10933-1-git-send-email-christian@gridshowsystems.com
State Accepted
Headers show

Commit Message

Christian Artin May 6, 2015, 5:26 p.m. UTC
Valgrind fails to build when the host kernel is >=4.0. This patch
backports the commit from upstream that fixes the kernel version
verification. This verification is pointless for buildroot anyway, but
it fixes the building process.

Signed-off-by: Christian Artin <christian@gridshowsystems.com>
---
 ...01-Fix-configure-for-Linux-kernel-4.0-rc1.patch | 46 ++++++++++++++++++++++
 1 file changed, 46 insertions(+)
 create mode 100644 package/valgrind/0001-Fix-configure-for-Linux-kernel-4.0-rc1.patch

Comments

Peter Korsgaard May 7, 2015, 8:36 p.m. UTC | #1
>>>>> "Christian" == Christian Artin <christian@gridshowsystems.com> writes:

 > Valgrind fails to build when the host kernel is >=4.0. This patch
 > backports the commit from upstream that fixes the kernel version
 > verification. This verification is pointless for buildroot anyway, but
 > it fixes the building process.

 > Signed-off-by: Christian Artin <christian@gridshowsystems.com>

Thanks, committed with a few minor fixes:

- We already have a 0001-.. patch for valgrind, so renamed to 0002-Fix..
- Added your Signed-off-by to the patch as well.
- Reworded title so it starts with valgrind:
diff mbox

Patch

diff --git a/package/valgrind/0001-Fix-configure-for-Linux-kernel-4.0-rc1.patch b/package/valgrind/0001-Fix-configure-for-Linux-kernel-4.0-rc1.patch
new file mode 100644
index 0000000..4b33d63
--- /dev/null
+++ b/package/valgrind/0001-Fix-configure-for-Linux-kernel-4.0-rc1.patch
@@ -0,0 +1,46 @@ 
+From 8e958577f01e2e877fb1dbdca09718ef6ea0c748 Mon Sep 17 00:00:00 2001
+From: cborntra <cborntra@a5019735-40e9-0310-863c-91ae7b9d1cf9>
+Date: Mon, 23 Feb 2015 20:19:03 +0000
+Subject: [PATCH] Fix configure for Linux kernel >= 4.0-rc1 In addition raise
+ the minimal Linux version to 2.6 as there is almost no test coverage for 2.4
+ and 2.6 was released in 2003.
+
+git-svn-id: svn://svn.valgrind.org/valgrind/trunk@14955 a5019735-40e9-0310-863c-91ae7b9d1cf9
+---
+ configure.ac | 18 ++++++------------
+ 1 file changed, 6 insertions(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index bdf5f22..136f49a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -325,20 +325,14 @@ case "${host_os}" in
+         kernel=`uname -r`
+ 
+         case "${kernel}" in
+-             2.6.*|3.*) 
+-        	    AC_MSG_RESULT([2.6.x/3.x family (${kernel})])
+-        	    AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x])
+-        	    ;;
+-
+-             2.4.*) 
+-        	    AC_MSG_RESULT([2.4 family (${kernel})])
+-        	    AC_DEFINE([KERNEL_2_4], 1, [Define to 1 if you're using Linux 2.4.x])
+-        	    ;;
+-
+-             *) 
++             0.*|1.*|2.0.*|2.1.*|2.2.*|2.3.*|2.4.*|2.5.*) 
+         	    AC_MSG_RESULT([unsupported (${kernel})])
+-        	    AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
++        	    AC_MSG_ERROR([Valgrind needs a Linux kernel >= 2.6])
+         	    ;;
++
++             *)
++        	    AC_MSG_RESULT([2.6 or later (${kernel})])
++                    ;;
+         esac
+ 
+         ;;
+-- 
+2.3.7
+