diff mbox

[next,v2,4/4] package/apr-util: add support for unixodbc

Message ID 1425204461-27877-4-git-send-email-bernd.kuhls@t-online.de
State Superseded
Headers show

Commit Message

Bernd Kuhls March 1, 2015, 10:07 a.m. UTC
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
v2: first inclusion in patch series, unix odbc detection works without
    odbc_config

 package/apr-util/apr-util.mk |    7 +++++++
 1 file changed, 7 insertions(+)
diff mbox

Patch

diff --git a/package/apr-util/apr-util.mk b/package/apr-util/apr-util.mk
index 3b0a71b..07ac573 100644
--- a/package/apr-util/apr-util.mk
+++ b/package/apr-util/apr-util.mk
@@ -53,4 +53,11 @@  else
 APR_UTIL_CONF_OPTS += --without-crypto
 endif
 
+ifeq ($(BR2_PACKAGE_UNIXODBC),y)
+APR_UTIL_CONF_OPTS += --with-odbc="$(STAGING_DIR)/usr"
+APR_UTIL_DEPENDENCIES += unixodbc
+else
+APR_UTIL_CONF_OPTS += --without-odbc
+endif
+
 $(eval $(autotools-package))