diff mbox

evtest: disable documentation

Message ID 1424621272-13706-1-git-send-email-Vincent.Riera@imgtec.com
State Superseded
Headers show

Commit Message

Vicente Olivert Riera Feb. 22, 2015, 4:07 p.m. UTC
evtest uses asciidoc to but /usr/bin/asciidoc will try to use
buildroot's host-python which doesn't have the required unicodedata. To
avoid that, define ASCIIDOC as an empty string so the Makefile can't
find the executable and skips the documentation generation.  This is the
same solution used in the evemu package. Otherwise it will fail with
this message:

make[1]: Entering directory `/br/output/build/evtest-1.32'
/usr/bin/make  all-am
make[2]: Entering directory `/br/output/build/evtest-1.32'
  File "/usr/bin/asciidoc", line 95
    except KeyError, k: return None

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/evtest/evtest.mk |    5 +++++
 1 files changed, 5 insertions(+), 0 deletions(-)
diff mbox

Patch

diff --git a/package/evtest/evtest.mk b/package/evtest/evtest.mk
index 42a7999..1573f52 100644
--- a/package/evtest/evtest.mk
+++ b/package/evtest/evtest.mk
@@ -13,4 +13,9 @@  EVTEST_DEPENDENCIES = host-pkgconf
 # needed because source package contains no generated files
 EVTEST_AUTORECONF = YES
 
+# asciidoc used to generate manpages, which we don't need, and if it's
+# present on the build host, it ends getting called with our host-python
+# which doesn't have all the needed modules enabled, breaking the build
+EVTEST_CONF_ENV = ac_cv_path_ASCIIDOC=""
+
 $(eval $(autotools-package))