diff mbox

[v2,18/30] libnspr: use the BR2_ARM_CPU_ARMV7A option

Message ID 1413923237-2861-19-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Headers show

Commit Message

Thomas Petazzoni Oct. 21, 2014, 8:27 p.m. UTC
The libnspr --enable-thumb2 option was only enabled on Cortex-A8 and
Cortex-A9. This commit switches ot using BR2_ARM_CPU_ARMV7A instead,
which will allow using Thumb2 for this package even with the other
Cortex-A cores.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/libnspr/libnspr.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Nov. 6, 2014, 10:57 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > The libnspr --enable-thumb2 option was only enabled on Cortex-A8 and
 > Cortex-A9. This commit switches ot using BR2_ARM_CPU_ARMV7A instead,
 > which will allow using Thumb2 for this package even with the other
 > Cortex-A cores.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 > ---
 >  package/libnspr/libnspr.mk | 2 +-
 >  1 file changed, 1 insertion(+), 1 deletion(-)

 > diff --git a/package/libnspr/libnspr.mk b/package/libnspr/libnspr.mk
 > index eaa6eb7..537caa6 100644
 > --- a/package/libnspr/libnspr.mk
 > +++ b/package/libnspr/libnspr.mk
 > @@ -22,7 +22,7 @@ LIBNSPR_CONF_OPTS += --$(if $(BR2_ARCH_IS_64),en,dis)able-64bit
 >  LIBNSPR_CONF_OPTS += --$(if $(BR2_INET_IPV6),en,dis)able-ipv6
 
 >  ifeq ($(BR2_arm),y)
 > -ifeq ($(BR2_cortex_a8)$(BR2_cortex_a9),y)
 > +ifeq ($(BR2_ARM_CPU_ARMV7A),y)

There's currently no functional difference, but it makes more sense to
use BR2_ARM_CPU_HAS_THUMB2 here.

Committed with that fixed, thanks.
diff mbox

Patch

diff --git a/package/libnspr/libnspr.mk b/package/libnspr/libnspr.mk
index eaa6eb7..537caa6 100644
--- a/package/libnspr/libnspr.mk
+++ b/package/libnspr/libnspr.mk
@@ -22,7 +22,7 @@  LIBNSPR_CONF_OPTS += --$(if $(BR2_ARCH_IS_64),en,dis)able-64bit
 LIBNSPR_CONF_OPTS += --$(if $(BR2_INET_IPV6),en,dis)able-ipv6
 
 ifeq ($(BR2_arm),y)
-ifeq ($(BR2_cortex_a8)$(BR2_cortex_a9),y)
+ifeq ($(BR2_ARM_CPU_ARMV7A),y)
 LIBNSPR_CONF_OPTS += --enable-thumb2
 else
 LIBNSPR_CONF_OPTS += --disable-thumb2