diff mbox

[1/1] pkg-download: fix svn download for deleted path

Message ID 1403788659-1936-1-git-send-email-ryan.barnett@rockwellcollins.com
State Accepted
Headers show

Commit Message

Ryan Barnett June 26, 2014, 1:17 p.m. UTC
If a SVN path has been deleted in a future revision, downloading a
package's source will fail using 'svn checkout -r'. Fix using
URL@REV syntax since the SVN command will then verify the path at the
specified version. Without using the URL@REV syntax, the SVN command
will attempt to verify the path exists on the the HEAD revision before
checking out the path at the specified revision.

Error seen if SVN path has been deleted in HEAD using svn checkout -r:
  svn: E160013: '/svn/path/' path not found

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
---
 package/pkg-download.mk |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN June 26, 2014, 4:30 p.m. UTC | #1
Ryan, All,

On 2014-06-26 08:17 -0500, Ryan Barnett spake thusly:
> If a SVN path has been deleted in a future revision, downloading a
> package's source will fail using 'svn checkout -r'. Fix using
> URL@REV syntax since the SVN command will then verify the path at the
> specified version. Without using the URL@REV syntax, the SVN command
> will attempt to verify the path exists on the the HEAD revision before
> checking out the path at the specified revision.
> 
> Error seen if SVN path has been deleted in HEAD using svn checkout -r:
>   svn: E160013: '/svn/path/' path not found
> 
> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/pkg-download.mk |    4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/pkg-download.mk b/package/pkg-download.mk
> index 4cfb913..e07fd1b 100644
> --- a/package/pkg-download.mk
> +++ b/package/pkg-download.mk
> @@ -145,14 +145,14 @@ endef
>  define DOWNLOAD_SVN
>  	test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
>  	(pushd $(DL_DIR) > /dev/null && \
> -	$(SVN) export -r $($(PKG)_DL_VERSION) $($(PKG)_SITE) $($(PKG)_DL_DIR) && \
> +	$(SVN) export $($(PKG)_SITE)@$($(PKG)_DL_VERSION) $($(PKG)_DL_DIR) && \
>  	$(TAR) czf $($(PKG)_SOURCE) $($(PKG)_BASE_NAME)/ && \
>  	rm -rf $($(PKG)_DL_DIR) && \
>  	popd > /dev/null)
>  endef
>  
>  define SOURCE_CHECK_SVN
> -  $(SVN) ls $($(PKG)_SITE) > /dev/null
> +  $(SVN) ls $($(PKG)_SITE)@$($(PKG)_DL_VERSION) > /dev/null
>  endef
>  
>  define SHOW_EXTERNAL_DEPS_SVN
> -- 
> 1.7.9.5
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni June 29, 2014, 8:43 a.m. UTC | #2
Dear Ryan Barnett,

On Thu, 26 Jun 2014 08:17:39 -0500, Ryan Barnett wrote:
> If a SVN path has been deleted in a future revision, downloading a
> package's source will fail using 'svn checkout -r'. Fix using
> URL@REV syntax since the SVN command will then verify the path at the
> specified version. Without using the URL@REV syntax, the SVN command
> will attempt to verify the path exists on the the HEAD revision before
> checking out the path at the specified revision.
> 
> Error seen if SVN path has been deleted in HEAD using svn checkout -r:
>   svn: E160013: '/svn/path/' path not found
> 
> Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
> ---
>  package/pkg-download.mk |    4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index 4cfb913..e07fd1b 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -145,14 +145,14 @@  endef
 define DOWNLOAD_SVN
 	test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
 	(pushd $(DL_DIR) > /dev/null && \
-	$(SVN) export -r $($(PKG)_DL_VERSION) $($(PKG)_SITE) $($(PKG)_DL_DIR) && \
+	$(SVN) export $($(PKG)_SITE)@$($(PKG)_DL_VERSION) $($(PKG)_DL_DIR) && \
 	$(TAR) czf $($(PKG)_SOURCE) $($(PKG)_BASE_NAME)/ && \
 	rm -rf $($(PKG)_DL_DIR) && \
 	popd > /dev/null)
 endef
 
 define SOURCE_CHECK_SVN
-  $(SVN) ls $($(PKG)_SITE) > /dev/null
+  $(SVN) ls $($(PKG)_SITE)@$($(PKG)_DL_VERSION) > /dev/null
 endef
 
 define SHOW_EXTERNAL_DEPS_SVN