diff mbox

[4/7,v3] package/powerpc-utils: Add powerpc hardware utilities

Message ID 1402982507.185290.70487867379.4.gpush@pablo
State Accepted
Headers show

Commit Message

Jeremy Kerr June 17, 2014, 5:21 a.m. UTC
This change adds a package definition for the powerpc-utils project,
containing a set of powerpc-specific hardware management utilities.

We're using a git tag from upstream, which contains a few build-system
fixes.

Signed-off-by: Jeremy Kerr <jk@ozlabs.org>

---
 package/Config.in                      |    1 +
 package/powerpc-utils/Config.in        |    5 +++++
 package/powerpc-utils/powerpc-utils.mk |   16 ++++++++++++++++
 3 files changed, 22 insertions(+)

Comments

Thomas Petazzoni July 17, 2014, 9:07 p.m. UTC | #1
Dear Jeremy Kerr,

On Tue, 17 Jun 2014 13:21:47 +0800, Jeremy Kerr wrote:
> This change adds a package definition for the powerpc-utils project,
> containing a set of powerpc-specific hardware management utilities.
> 
> We're using a git tag from upstream, which contains a few build-system
> fixes.
> 
> Signed-off-by: Jeremy Kerr <jk@ozlabs.org>

Thanks, applied with minor changes, as outlined in the commit log:

    [Thomas:
     - Add dependency on PowerPC architecture in Config.in.
     - Add homepage in Config.in help text.]
    
Thanks,

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index f43e985..125f3f0 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1115,6 +1115,7 @@  endif
 	source "package/ncdu/Config.in"
 	source "package/numactl/Config.in"
 	source "package/nut/Config.in"
+	source "package/powerpc-utils/Config.in"
 	source "package/polkit/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 	source "package/procps-ng/Config.in"
diff --git a/package/powerpc-utils/Config.in b/package/powerpc-utils/Config.in
new file mode 100644
index 0000000..c919094
--- /dev/null
+++ b/package/powerpc-utils/Config.in
@@ -0,0 +1,5 @@ 
+config BR2_PACKAGE_POWERPC_UTILS
+	bool "powerpc-utils"
+	select BR2_PACKAGE_ZLIB
+	help
+	  System utilities for powerpc machines
diff --git a/package/powerpc-utils/powerpc-utils.mk b/package/powerpc-utils/powerpc-utils.mk
new file mode 100644
index 0000000..c9cc096
--- /dev/null
+++ b/package/powerpc-utils/powerpc-utils.mk
@@ -0,0 +1,16 @@ 
+################################################################################
+#
+# powerpc-utils
+#
+################################################################################
+
+POWERPC_UTILS_VERSION = v1.4
+POWERPC_UTILS_SITE = git://git.code.sf.net/p/powerpc-utils/powerpc-utils
+POWERPC_UTILS_AUTORECONF = YES
+POWERPC_UTILS_DEPENDENCIES = zlib
+POWERPC_UTILS_LICENSE = Common Public License Version 1.0
+POWERPC_UTILS_LICENSE_FILES = COPYRIGHT
+
+POWERPC_UTILS_CONF_OPT = --without-librtas
+
+$(eval $(autotools-package))