diff mbox

[1/2] package/webkit: Fix detection of egl headers provided by rpi-userland

Message ID 1401366393-5815-2-git-send-email-bernd.kuhls@t-online.de
State Deferred
Headers show

Commit Message

Bernd Kuhls May 29, 2014, 12:26 p.m. UTC
quote from webkit/config.log:
/home/br2/output/host/usr/arm-buildroot-linux-uclibcgnueabi/sysroot/usr/include/interface/vcos/vcos_types.h:38:33:
fatal error: vcos_platform_types.h: No such file or directory

Package rpi-userland provides this header file, but in a non-default directory,
therefore use pkg-config to add the appropriate flags.

Fixes
http://autobuild.buildroot.net/results/bc0/bc0f9114f9dacf68a510f1e01f2dc3661c34f536/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/webkit/webkit.mk |    6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni July 23, 2014, 9:54 p.m. UTC | #1
Dear Bernd Kuhls,

On Thu, 29 May 2014 14:26:32 +0200, Bernd Kuhls wrote:
> quote from webkit/config.log:
> /home/br2/output/host/usr/arm-buildroot-linux-uclibcgnueabi/sysroot/usr/include/interface/vcos/vcos_types.h:38:33:
> fatal error: vcos_platform_types.h: No such file or directory
> 
> Package rpi-userland provides this header file, but in a non-default directory,
> therefore use pkg-config to add the appropriate flags.
> 
> Fixes
> http://autobuild.buildroot.net/results/bc0/bc0f9114f9dacf68a510f1e01f2dc3661c34f536/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/webkit/webkit.mk |    6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)

Could you update on whether this patch and patch 2/2 in this series are
still needed? There were also unanswered questions in your patch 2/2.

Thanks,

Thomas
Bernd Kuhls July 25, 2014, 7:34 p.m. UTC | #2
Thomas Petazzoni <thomas.petazzoni-wi1+55ScJUtKEb57/3fJTNBPR1lH4CV8
@public.gmane.org> wrote in news:20140723235453.5ebea556@free-electrons.com:

> Could you update on whether this patch and patch 2/2 in this series are
> still needed? There were also unanswered questions in your patch 2/2.

Hi Thomas,

the autobuild error I was trying to fix occured on May 29th:
http://autobuild.buildroot.net/results/bc0/bc0f9114f9dacf68a510f1e01f2dc3661c
34f536/

The same error was still present on July, 21th:
http://autobuild.buildroot.net/results/1e8/1e8cab75025316b22205be7fb08a93148a
256b9c/

As I wrote in my cover letter[1] for this patch series

> the rpi experts should have a closer look whether webkit could work on rpi
> despite the current problem

I asked for this help because I have basically no knowledge about the rpi-
specific binary blobs provided by rpi-userland.

Maybe HadrienĀ“s patch series[2] to bump webkit to 2.4.3 will solve the 
problem in a better way than with my patches.

@Hadrien: Could you please test your patch using the defconfig used by the 
autobuilder where webkit-1 failed to compile for rpi?

Regards, Bernd

[1] http://article.gmane.org/gmane.comp.lib.uclibc.buildroot/85281
[2] http://thread.gmane.org/gmane.comp.lib.uclibc.buildroot/89775
Hadrien Boutteville July 28, 2014, 4:20 p.m. UTC | #3
Hi Bernd,

On Fri, 25 Jul 2014 21:34:07 +0200, Bernd Kuhls wrote:
> Thomas Petazzoni <thomas.petazzoni-wi1+55ScJUtKEb57/3fJTNBPR1lH4CV8
> @public.gmane.org> wrote in news:20140723235453.5ebea556@free-electrons.com:
> 
>> Could you update on whether this patch and patch 2/2 in this series are
>> still needed? There were also unanswered questions in your patch 2/2.
> 
> Hi Thomas,
> 
> the autobuild error I was trying to fix occured on May 29th:
> http://autobuild.buildroot.net/results/bc0/bc0f9114f9dacf68a510f1e01f2dc3661c
> 34f536/
> 
> The same error was still present on July, 21th:
> http://autobuild.buildroot.net/results/1e8/1e8cab75025316b22205be7fb08a93148a
> 256b9c/
> 
> As I wrote in my cover letter[1] for this patch series
> 
>> the rpi experts should have a closer look whether webkit could work on rpi
>> despite the current problem
> 
> I asked for this help because I have basically no knowledge about the rpi-
> specific binary blobs provided by rpi-userland.
> 
> Maybe HadrienĀ“s patch series[2] to bump webkit to 2.4.3 will solve the 
> problem in a better way than with my patches.
> 
> @Hadrien: Could you please test your patch using the defconfig used by the 
> autobuilder where webkit-1 failed to compile for rpi?

Actually, I had forgotten this problem but yes, when I initially tested
the bump of WebKit with rpi-userland the EGL check failed too. So it's
not solved in my series or with version 2.4.3 and this seems to be
related to rpi-userland (no problem with ti-gfx and imx-lib, with which
I test now).

I will test my patch with the defconfig used by the autobuilder and test
your patch if the problem occurs again.

Regards,

Hadrien
diff mbox

Patch

diff --git a/package/webkit/webkit.mk b/package/webkit/webkit.mk
index 6b04ccd..1f40736 100644
--- a/package/webkit/webkit.mk
+++ b/package/webkit/webkit.mk
@@ -35,8 +35,9 @@  WEBKIT_PRE_CONFIGURE_HOOKS += DISABLE_INDEXED_DATABASE
 # Give explicit path to icu-config, and silence gazillions of warnings
 # with recent gcc versions.
 WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
-	CFLAGS="$(TARGET_CFLAGS) -Wno-cast-align -Wno-sign-compare" \
-	CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align -Wno-sign-compare" \
+	CFLAGS="$(TARGET_CFLAGS) $(WEBKIT_EGLFLAGS) -Wno-cast-align -Wno-sign-compare" \
+	CPPFLAGS="$(TARGET_CPPFLAGS) $(WEBKIT_EGLFLAGS)" \
+	CXXFLAGS="$(TARGET_CXXFLAGS) $(WEBKIT_EGLFLAGS) -Wno-cast-align -Wno-sign-compare" \
 	AR_FLAGS="cru"
 
 WEBKIT_CONF_OPT += \
@@ -55,6 +56,7 @@  WEBKIT_DEPENDENCIES += xlib_libXt
 ifeq ($(BR2_PACKAGE_HAS_LIBEGL)$(BR2_PACKAGE_HAS_LIBGLES),yy)
 WEBKIT_CONF_OPT += --enable-gles2
 WEBKIT_DEPENDENCIES += libegl libgles
+WEBKIT_EGLFLAGS = $(shell $(PKG_CONFIG_HOST_BINARY) --cflags egl)
 else
 WEBKIT_CONF_OPT += --disable-gles2
 endif