diff mbox

[V2] pkg-perl: prevents the interactive prompts

Message ID 1395340542-23383-1-git-send-email-francois.perrad@gadz.org
State Accepted
Headers show

Commit Message

Francois Perrad March 20, 2014, 6:35 p.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/pkg-perl.mk |    4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni March 29, 2014, 9:32 a.m. UTC | #1
Dear Francois Perrad,

On Thu, 20 Mar 2014 19:35:42 +0100, Francois Perrad wrote:
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/pkg-perl.mk |    4 ++++
>  1 file changed, 4 insertions(+)

Applied, thanks!

Speaking of the perl-package infrastructure, we don't have any target
perl-package in the tree as of today. Would it be possible to add at
least a few of them, at least to make sure the perl-package
infrastructure is regularly exercised by the autobuilder tests?

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/pkg-perl.mk b/package/pkg-perl.mk
index fdf1580..447f364 100644
--- a/package/pkg-perl.mk
+++ b/package/pkg-perl.mk
@@ -49,6 +49,7 @@  ifeq ($(4),target)
 # Configure package for target
 define $(2)_CONFIGURE_CMDS
 	cd $$($$(PKG)_SRCDIR) && if [ -f Build.PL ] ; then \
+		PERL_MM_USE_DEFAULT=1 \
 		perl Build.PL \
 			--config ar="$(TARGET_AR)" \
 			--config full_ar="$(TARGET_AR)" \
@@ -68,6 +69,7 @@  define $(2)_CONFIGURE_CMDS
 			--install_path libdoc=/usr/share/man/man3 \
 			$$($(2)_CONF_OPT); \
 	else \
+		PERL_MM_USE_DEFAULT=1 \
 		PERL_AUTOINSTALL=--skipdeps \
 		perl Makefile.PL \
 			AR="$(TARGET_AR)" \
@@ -93,11 +95,13 @@  else
 # Configure package for host
 define $(2)_CONFIGURE_CMDS
 	cd $$($$(PKG)_SRCDIR) && if [ -f Build.PL ] ; then \
+		PERL_MM_USE_DEFAULT=1 \
 		perl Build.PL \
 			--install_base $$(HOST_DIR)/usr \
 			--installdirs vendor \
 			$$($(2)_CONF_OPT); \
 	else \
+		PERL_MM_USE_DEFAULT=1 \
 		PERL_AUTOINSTALL=--skipdeps \
 		perl Makefile.PL \
 			INSTALL_BASE=$$(HOST_DIR)/usr \