diff mbox

binutils: install libiberty

Message ID 1393108410-9568-1-git-send-email-arnout@mind.be
State Accepted
Commit 70ee9fcdfcf6fc7cb214e454afe55cbffec84621
Headers show

Commit Message

Arnout Vandecappelle Feb. 22, 2014, 10:33 p.m. UTC
Some packages (actually, just oprofile) need to link against libiberty.
This option just installs libiberty.a so it has no effect on the target,
therefore it's not needed to add a config option for it.

Before binutils-2.24, there was a bug in libiberty/Makefile.in that
caused libiberty to be installed regardless of the
--enable-install-libiberty option. This problem wasn't noticed before
because binutils-2.24 is not selected on any of the autobuilders: the
version can only be selected if an internal toolchain is used, and it
defaults to 2.21.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/binutils/binutils.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Feb. 22, 2014, 10:43 p.m. UTC | #1
Dear Arnout Vandecappelle (Essensium/Mind),

On Sat, 22 Feb 2014 23:33:30 +0100, Arnout Vandecappelle
(Essensium/Mind) wrote:
> Some packages (actually, just oprofile) need to link against libiberty.
> This option just installs libiberty.a so it has no effect on the target,
> therefore it's not needed to add a config option for it.
> 
> Before binutils-2.24, there was a bug in libiberty/Makefile.in that
> caused libiberty to be installed regardless of the
> --enable-install-libiberty option. This problem wasn't noticed before
> because binutils-2.24 is not selected on any of the autobuilders: the
> version can only be selected if an internal toolchain is used, and it
> defaults to 2.21.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  package/binutils/binutils.mk | 1 +
>  1 file changed, 1 insertion(+)

I believe this might fix:

http://autobuild.buildroot.org/results/be1/be199b97dcdaf28a8fef9d90953115a005baa173/build-end.log

If someone could verify this, maybe this patch could be committed to
master.

On Microblaze, a non-default binutils version is used, and the version
is fairly recent, most likely a 2.24-something version (we actually use
a git commit).

Best regards,

Thomas
Peter Korsgaard Feb. 22, 2014, 11:05 p.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 > Some packages (actually, just oprofile) need to link against libiberty.
 > This option just installs libiberty.a so it has no effect on the target,
 > therefore it's not needed to add a config option for it.

 > Before binutils-2.24, there was a bug in libiberty/Makefile.in that
 > caused libiberty to be installed regardless of the
 > --enable-install-libiberty option. This problem wasn't noticed before
 > because binutils-2.24 is not selected on any of the autobuilders: the
 > version can only be selected if an internal toolchain is used, and it
 > defaults to 2.21.

 > Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Committed, thanks.
diff mbox

Patch

diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index d6828f5..b5a2dc7 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -51,6 +51,7 @@  endif
 BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
 		--host=$(GNU_TARGET_NAME) \
 		--target=$(GNU_TARGET_NAME) \
+		--enable-install-libiberty \
 		$(BINUTILS_EXTRA_CONFIG_OPTIONS)
 
 # Install binutils after busybox to prefer full-blown utilities