diff mbox

[1/1] gpm: run autogen.sh as PRE_CONFIGURE step

Message ID 1391506737-16469-1-git-send-email-rjbarnet@rockwellcollins.com
State Accepted
Commit 15fed7179a8c7d9d82ee96751600d3b6e8b391af
Headers show

Commit Message

Ryan Barnett Feb. 4, 2014, 9:38 a.m. UTC
Move the GPM_RUN_AUTOGEN to be a PRE_CONFIGURE step because this step
depends on the dependancies being built. If it is a POST_PATCH step
the dependancies won't be built and the GPM_RUN_AUTOGEN step will fail.

Signed-off-by: Ryan Barnett <rjbarnet@rockwellcollins.com>
---
 package/gpm/gpm.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Feb. 4, 2014, 9:50 a.m. UTC | #1
>>>>> "Ryan" == Ryan Barnett <ryanbarnett3@gmail.com> writes:

 > Move the GPM_RUN_AUTOGEN to be a PRE_CONFIGURE step because this step
 > depends on the dependancies being built. If it is a POST_PATCH step
 > the dependancies won't be built and the GPM_RUN_AUTOGEN step will fail.

Committed, thanks.
diff mbox

Patch

diff --git a/package/gpm/gpm.mk b/package/gpm/gpm.mk
index 296966a..58fab00 100644
--- a/package/gpm/gpm.mk
+++ b/package/gpm/gpm.mk
@@ -28,7 +28,7 @@  GPM_CONF_OPT = --without-curses
 define GPM_RUN_AUTOGEN
 	cd $(@D) && PATH=$(HOST_PATH) ./autogen.sh
 endef
-GPM_POST_PATCH_HOOKS += GPM_RUN_AUTOGEN
+GPM_PRE_CONFIGURE_HOOKS += GPM_RUN_AUTOGEN
 
 GPM_DEPENDENCIES += host-automake host-autoconf host-libtool