diff mbox

[1/3] ncftp: specify ln -sf to remove existing destination files

Message ID 1381756890.15266.1.camel@phoenix
State Accepted
Commit eed2e02fb99f31196df75ec3dadaf80fa68fffe3
Headers show

Commit Message

Axel Lin Oct. 14, 2013, 1:21 p.m. UTC
This fixes below build error when executing "make ncftp-dirclean; make".

ln -s /usr/bin/ncftpbatch /opt/test/br-x86/buildroot/output/target/usr/bin/ncftpspooler
ln: failed to create symbolic link '/opt/test/br-x86/buildroot/output/target/usr/bin/ncftpspooler': File exists
make: *** [/opt/test/br-x86/buildroot/output/build/ncftp-3.2.5/.stamp_target_installed] Error 1

Signed-off-by: Axel Lin <axel.lin@ingics.com>
---
 package/ncftp/ncftp.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Oct. 14, 2013, 8 p.m. UTC | #1
>>>>> "Axel" == Axel Lin <axel.lin@ingics.com> writes:

 Axel> This fixes below build error when executing "make ncftp-dirclean; make".
 Axel> ln -s /usr/bin/ncftpbatch /opt/test/br-x86/buildroot/output/target/usr/bin/ncftpspooler
 Axel> ln: failed to create symbolic link '/opt/test/br-x86/buildroot/output/target/usr/bin/ncftpspooler': File exists
 Axel> make: *** [/opt/test/br-x86/buildroot/output/build/ncftp-3.2.5/.stamp_target_installed] Error 1

 Axel> Signed-off-by: Axel Lin <axel.lin@ingics.com>

Committed all 3, thanks.
diff mbox

Patch

diff --git a/package/ncftp/ncftp.mk b/package/ncftp/ncftp.mk
index 56d5d47..03874d1 100644
--- a/package/ncftp/ncftp.mk
+++ b/package/ncftp/ncftp.mk
@@ -26,7 +26,7 @@  endif
 ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
 	NCFTP_TARGET_BINS += ncftpbatch
 	NCFTP_INSTALL_NCFTP_BATCH = \
-		ln -s /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
+		ln -sf /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
 endif
 
 ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)