diff mbox

package/libmicrohttpd: minor fixes and additions

Message ID 1372187313-15042-1-git-send-email-c.schoenert@gmail.com
State Superseded
Headers show

Commit Message

Carsten Schoenert June 25, 2013, 7:08 p.m. UTC
From: Carsten Schoenert <c.schoenert@gmail.com>

Correcting the indentation inside Config.in. Also adding the missed
license information.

Note: libmicrohttpd is partialy dual licensed, if you don't need or want
to use the HTTPS option you can choose between LPGLv2.1 and the eCos
license (http://ecos.sourceware.org/license-overview.html).
If you use the HTTPS option you have to agree to the LGPLv2.1!

Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com>
---
 package/libmicrohttpd/Config.in        |   14 +++++++-------
 package/libmicrohttpd/libmicrohttpd.mk |    5 ++++-
 2 files changed, 11 insertions(+), 8 deletions(-)

Comments

Arnout Vandecappelle June 25, 2013, 9:25 p.m. UTC | #1
On 25/06/13 21:08, Carsten Schoenert wrote:
> From: Carsten Schoenert <c.schoenert@gmail.com>
>
> Correcting the indentation inside Config.in. Also adding the missed
> license information.
>
> Note: libmicrohttpd is partialy dual licensed, if you don't need or want
> to use the HTTPS option you can choose between LPGLv2.1 and the eCos
> license (http://ecos.sourceware.org/license-overview.html).
> If you use the HTTPS option you have to agree to the LGPLv2.1!
>
> Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com>
> ---
>   package/libmicrohttpd/Config.in        |   14 +++++++-------
>   package/libmicrohttpd/libmicrohttpd.mk |    5 ++++-
>   2 files changed, 11 insertions(+), 8 deletions(-)
>
> diff --git a/package/libmicrohttpd/Config.in b/package/libmicrohttpd/Config.in
> index 2e4de0f..5c20ba6 100644
> --- a/package/libmicrohttpd/Config.in
> +++ b/package/libmicrohttpd/Config.in
> @@ -8,13 +8,13 @@ config BR2_PACKAGE_LIBMICROHTTPD
>   	  http://www.gnu.org/software/libmicrohttpd/
>
>   config BR2_PACKAGE_LIBMICROHTTPD_SSL
> -       bool "https support"
> -       depends on BR2_PACKAGE_LIBMICROHTTPD
> -       depends on BR2_USE_WCHAR
> -       select BR2_PACKAGE_GNUTLS
> -       select BR2_PACKAGE_LIBGCRYPT
> -       help
> -         Enable HTTPS (SSL) support.
> +	bool "https support"
> +	depends on BR2_PACKAGE_LIBMICROHTTPD
> +	depends on BR2_USE_WCHAR
> +	select BR2_PACKAGE_GNUTLS
> +	select BR2_PACKAGE_LIBGCRYPT
> +	help
> +	  Enable HTTPS (SSL) support.
>
>   comment "libmicrohttpd needs a toolchain with thread support"
>   	depends on !BR2_TOOLCHAIN_HAS_THREADS
> diff --git a/package/libmicrohttpd/libmicrohttpd.mk b/package/libmicrohttpd/libmicrohttpd.mk
> index 697cbf5..40ef197 100644
> --- a/package/libmicrohttpd/libmicrohttpd.mk
> +++ b/package/libmicrohttpd/libmicrohttpd.mk
> @@ -6,12 +6,15 @@
>
>   LIBMICROHTTPD_VERSION = 0.9.27
>   LIBMICROHTTPD_SITE = $(BR2_GNU_MIRROR)/libmicrohttpd
> +LIBMICROHTTPD_LICENSE = LGPLv2.1 eCos

  Quick check tells me it's LGPLv2.1+

  I would write "LGPLv2.1+ or eCos license" to make the choice more 
explicit, else it looks as if both licenses apply.

> +LIBMICROHTTPD_LICENSE_FILE = COPYING
>   LIBMICROHTTPD_INSTALL_STAGING = YES
>
>   ifeq ($(BR2_PACKAGE_LIBMICROHTTPD_SSL),y)
>   LIBMICROHTTPD_DEPENDENCIES += gnutls libgcrypt
>   LIBMICROHTTPD_CONF_OPT += --enable-https --with-gnutls=$(STAGING_DIR)/usr \
> -			  --with-libgcrypt-prefix=$(STAGING_DIR)/usr
> +						  --with-libgcrypt-prefix=$(STAGING_DIR)/usr
> +LIBMICROHTTPD_LICENSE = LGPLv2.1

  We would typically put the LGPLv2.1 or eCos option in the else branch 
of the condition, rather than overwriting it.

  Regards,
  Arnout

>   else
>   LIBMICROHTTPD_CONF_OPT += --disable-https
>   endif
>
Carsten Schoenert June 26, 2013, 5:09 p.m. UTC | #2
Hello Arnout,

Am 25.06.2013 23:25, schrieb Arnout Vandecappelle:
>  Quick check tells me it's LGPLv2.1+

Ah, yes. I just looked into COPYING. Will correct.

>  I would write "LGPLv2.1+ or eCos license" to make the choice more
> explicit, else it looks as if both licenses apply.

Also true. Agreed.

>  We would typically put the LGPLv2.1 or eCos option in the else branch
> of the condition, rather than overwriting it.

I was thinking about that, but decided to the kind I made the patch. I
prepare a new patch and will resend.

Regards
Carsten
Carsten Schoenert June 26, 2013, 7:03 p.m. UTC | #3
Hello again,

Am 25.06.2013 23:25, schrieb Arnout Vandecappelle:
>  I would write "LGPLv2.1+ or eCos license" to make the choice more
> explicit, else it looks as if both licenses apply.

I have a take a look into the documenation and this part is missing that
kind of info. I have tried to wrote some informative, what do you think?

> diff --git a/docs/manual/adding-packages-generic.txt b/docs/manual/adding-packages-generic.txt
> index faf70b1..f31e069 100644
> --- a/docs/manual/adding-packages-generic.txt
> +++ b/docs/manual/adding-packages-generic.txt
> @@ -328,6 +328,24 @@ information is (assuming the package name is +libfoo+) :
>    ambiguous names such as +BSD+ which actually name a family of licenses.
>    This variable is optional. If it is not defined, +unknown+ will appear in
>    the +license+ field of the manifest file for this package.
> +  If the package is licensed with more than one license just write all
> +  licenses into that line and make clear how the usage of the licenses are
> +  interact.
> +
> +For example the package could licensed under LGPLv2.1+ or MIT:
> +
> +---------------------------------
> +LIBFOO_LICENSE = LGPLv2.1+ or MIT
> +---------------------------------
> +
> +Some packages may need two licenses at the same time, that would be the
> +opposite of the above example. Then you have to combine the two licenses
> +(don't forget to check if there are two, or more, fields in
> ++LIBFOO_LICENSE_FILES+ needed):
> +
> +--------------------------------------
> +LIBFOO_LICENSE = Special1 and Special2
> +--------------------------------------
> 
>  * +LIBFOO_LICENSE_FILES+ is a space-separated list of files in the package
>    tarball that contain the license(s) under which the package is released.

Regards
Carsten
diff mbox

Patch

diff --git a/package/libmicrohttpd/Config.in b/package/libmicrohttpd/Config.in
index 2e4de0f..5c20ba6 100644
--- a/package/libmicrohttpd/Config.in
+++ b/package/libmicrohttpd/Config.in
@@ -8,13 +8,13 @@  config BR2_PACKAGE_LIBMICROHTTPD
 	  http://www.gnu.org/software/libmicrohttpd/
 
 config BR2_PACKAGE_LIBMICROHTTPD_SSL
-       bool "https support"
-       depends on BR2_PACKAGE_LIBMICROHTTPD
-       depends on BR2_USE_WCHAR
-       select BR2_PACKAGE_GNUTLS
-       select BR2_PACKAGE_LIBGCRYPT
-       help
-         Enable HTTPS (SSL) support.
+	bool "https support"
+	depends on BR2_PACKAGE_LIBMICROHTTPD
+	depends on BR2_USE_WCHAR
+	select BR2_PACKAGE_GNUTLS
+	select BR2_PACKAGE_LIBGCRYPT
+	help
+	  Enable HTTPS (SSL) support.
 
 comment "libmicrohttpd needs a toolchain with thread support"
 	depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libmicrohttpd/libmicrohttpd.mk b/package/libmicrohttpd/libmicrohttpd.mk
index 697cbf5..40ef197 100644
--- a/package/libmicrohttpd/libmicrohttpd.mk
+++ b/package/libmicrohttpd/libmicrohttpd.mk
@@ -6,12 +6,15 @@ 
 
 LIBMICROHTTPD_VERSION = 0.9.27
 LIBMICROHTTPD_SITE = $(BR2_GNU_MIRROR)/libmicrohttpd
+LIBMICROHTTPD_LICENSE = LGPLv2.1 eCos
+LIBMICROHTTPD_LICENSE_FILE = COPYING
 LIBMICROHTTPD_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_LIBMICROHTTPD_SSL),y)
 LIBMICROHTTPD_DEPENDENCIES += gnutls libgcrypt
 LIBMICROHTTPD_CONF_OPT += --enable-https --with-gnutls=$(STAGING_DIR)/usr \
-			  --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+						  --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+LIBMICROHTTPD_LICENSE = LGPLv2.1
 else
 LIBMICROHTTPD_CONF_OPT += --disable-https
 endif