diff mbox

pixman: Apply upstream patch to fix compilation on MIPS

Message ID 1369040459-17604-1-git-send-email-markos.chandras@gmail.com
State Superseded
Headers show

Commit Message

Markos Chandras May 20, 2013, 9 a.m. UTC
From: Markos Chandras <markos.chandras@imgtec.com>

Fixes:
http://autobuild.buildroot.net/results/38aa4f2a2269b80226b910c46e0c9abe7dc38ff8/

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
---
 package/pixman/pixman-0.30.0-loongson-cflags.patch | 38 ++++++++++++++++++++++
 package/pixman/pixman.mk                           |  3 +-
 2 files changed, 40 insertions(+), 1 deletion(-)
 create mode 100644 package/pixman/pixman-0.30.0-loongson-cflags.patch

Comments

Markos Chandras May 20, 2013, 9:15 a.m. UTC | #1
On 20 May 2013 10:00, Markos Chandras <markos.chandras@gmail.com> wrote:
> From: Markos Chandras <markos.chandras@imgtec.com>
>
> Fixes:
> http://autobuild.buildroot.net/results/38aa4f2a2269b80226b910c46e0c9abe7dc38ff8/
>
> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
> ---
>  package/pixman/pixman-0.30.0-loongson-cflags.patch | 38 ++++++++++++++++++++++
>  package/pixman/pixman.mk                           |  3 +-
>  2 files changed, 40 insertions(+), 1 deletion(-)
>  create mode 100644 package/pixman/pixman-0.30.0-loongson-cflags.patch
>
> diff --git a/package/pixman/pixman-0.30.0-loongson-cflags.patch b/package/pixman/pixman-0.30.0-loongson-cflags.patch
> new file mode 100644
> index 0000000..fc53be2
> --- /dev/null
> +++ b/package/pixman/pixman-0.30.0-loongson-cflags.patch
> @@ -0,0 +1,38 @@
> +configure.ac: Verify that the Loongson MMI code can link
> +
> +The Loongson MMI code modifies -march and as a result it breaks linking
> +when the rest of the code is built with a different -match/-mtune.
> +This patch fixes the problem by trying to link the code instead of just
> +compiling it. This patch is already committed upstream.
> +
> +Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
> +
> +From d77d75cc6e5de14d027d22b70389a4d0c71048b9 Mon Sep 17 00:00:00 2001
> +From: Markos Chandras <markos.chandras@imgtec.com>
> +Date: Wed, 15 May 2013 16:51:20 +0000
> +Subject: Use AC_LINK_IFELSE to check if the Loongson MMI code can link
> +
> +The Loongson code is compiled with -march=loongson2f to enable the MMI
> +instructions, but binutils refuses to link object code compiled with
> +different -march settings, leading to link failures later in the
> +compile. This avoids that problem by checking if we can link code
> +compiled for Loongson.
> +
> +Reviewed-by: Matt Turner <mattst88@gmail.com>
> +Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
> +---
> +diff --git a/configure.ac b/configure.ac
> +index c43a0d2..221179f 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -279,7 +279,7 @@ AC_MSG_CHECKING(whether to use Loongson MMI assembler)
> +
> + xserver_save_CFLAGS=$CFLAGS
> + CFLAGS=" $LS_CFLAGS $CFLAGS -I$srcdir"
> +-AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
> ++AC_LINK_IFELSE([AC_LANG_SOURCE([[
> + #ifndef __mips_loongson_vector_rev
> + #error "Loongson Multimedia Instructions are only available on Loongson"
> + #endif
> +--
> +cgit v0.9.0.2-2-gbebe
> diff --git a/package/pixman/pixman.mk b/package/pixman/pixman.mk
> index c2ee035..7822ede 100644
> --- a/package/pixman/pixman.mk
> +++ b/package/pixman/pixman.mk
> @@ -3,11 +3,12 @@
>  # pixman
>  #
>  ################################################################################
> -PIXMAN_VERSION = 0.28.2
> +PIXMAN_VERSION = 0.30.0
>  PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
>  PIXMAN_LICENSE = MIT
>  PIXMAN_LICENSE_FILES = COPYING
>
> +PIXMAN_AUTORECONF = YES
>  PIXMAN_INSTALL_STAGING = YES
>  PIXMAN_DEPENDENCIES = host-pkgconf
>  # don't build gtk based demos
> --
> 1.8.2.1
>
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot

Hi,

I accidentally bumped pixman to 0.30.0 in order to test this patch,
but this is already in the -next branch. Apologies for that. Do you
want me to resend this patch without the version bump or you will fix
it yourself before committing it?

--
Regards,
Markos Chandras
Baruch Siach May 20, 2013, 9:20 a.m. UTC | #2
Hi Markos,

On Mon, May 20, 2013 at 10:00:59AM +0100, Markos Chandras wrote:
> From: Markos Chandras <markos.chandras@imgtec.com>
> 
> Fixes:
> http://autobuild.buildroot.net/results/38aa4f2a2269b80226b910c46e0c9abe7dc38ff8/
> 
> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
> ---
>  package/pixman/pixman-0.30.0-loongson-cflags.patch | 38 ++++++++++++++++++++++

We now usually omit version numbers from bundled patches file names.

>  package/pixman/pixman.mk                           |  3 +-
>  2 files changed, 40 insertions(+), 1 deletion(-)
>  create mode 100644 package/pixman/pixman-0.30.0-loongson-cflags.patch

[snip]

> diff --git a/package/pixman/pixman.mk b/package/pixman/pixman.mk
> index c2ee035..7822ede 100644
> --- a/package/pixman/pixman.mk
> +++ b/package/pixman/pixman.mk
> @@ -3,11 +3,12 @@
>  # pixman
>  #
>  ################################################################################
> -PIXMAN_VERSION = 0.28.2
> +PIXMAN_VERSION = 0.30.0

This is a version bump. The commit log should change accordingly.

>  PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
>  PIXMAN_LICENSE = MIT
>  PIXMAN_LICENSE_FILES = COPYING
>  
> +PIXMAN_AUTORECONF = YES

Please add a comment explaining why this is needed.

>  PIXMAN_INSTALL_STAGING = YES
>  PIXMAN_DEPENDENCIES = host-pkgconf
>  # don't build gtk based demos

baruch
Markos Chandras May 20, 2013, 9:24 a.m. UTC | #3
Hi Baruch,

>
> We now usually omit version numbers from bundled patches file names.
Oh sorry I didn't notice. I will fix it.

>
>> -PIXMAN_VERSION = 0.28.2
>> +PIXMAN_VERSION = 0.30.0
>
> This is a version bump. The commit log should change accordingly.
Yes, I sent a follow-up e-mail explaining this was an accident. The
version bump is already present the -next branch.

>
>>  PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
>>  PIXMAN_LICENSE = MIT
>>  PIXMAN_LICENSE_FILES = COPYING
>>
>> +PIXMAN_AUTORECONF = YES
>
> Please add a comment explaining why this is needed.

I thought it was obvious because the patch fixes the configure.ac
file. But ok, I will add a comment.

Thanks for the review.
Baruch Siach May 20, 2013, 9:34 a.m. UTC | #4
Hi Markos,

On Mon, May 20, 2013 at 10:24:32AM +0100, Markos Chandras wrote:
> >>  PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
> >>  PIXMAN_LICENSE = MIT
> >>  PIXMAN_LICENSE_FILES = COPYING
> >>
> >> +PIXMAN_AUTORECONF = YES
> >
> > Please add a comment explaining why this is needed.
> 
> I thought it was obvious because the patch fixes the configure.ac
> file. But ok, I will add a comment.

I missed that. In this case a comment is not needed I guess, unless others 
have a different opinion.

baruch
Markos Chandras May 20, 2013, 9:38 a.m. UTC | #5
Hi Baruch,

On 20 May 2013 10:34, Baruch Siach <baruch@tkos.co.il> wrote:
> Hi Markos,
>
> On Mon, May 20, 2013 at 10:24:32AM +0100, Markos Chandras wrote:
>> >>  PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
>> >>  PIXMAN_LICENSE = MIT
>> >>  PIXMAN_LICENSE_FILES = COPYING
>> >>
>> >> +PIXMAN_AUTORECONF = YES
>> >
>> > Please add a comment explaining why this is needed.
>>
>> I thought it was obvious because the patch fixes the configure.ac
>> file. But ok, I will add a comment.
>
> I missed that. In this case a comment is not needed I guess, unless others
> have a different opinion.
>
> baruch
>

I sent v2. I didn't add a comment because I see that most of packages
do not explain with AUTORECONF is needed.

Thank you for your comments.

--
Regards,
Markos Chandras
diff mbox

Patch

diff --git a/package/pixman/pixman-0.30.0-loongson-cflags.patch b/package/pixman/pixman-0.30.0-loongson-cflags.patch
new file mode 100644
index 0000000..fc53be2
--- /dev/null
+++ b/package/pixman/pixman-0.30.0-loongson-cflags.patch
@@ -0,0 +1,38 @@ 
+configure.ac: Verify that the Loongson MMI code can link
+
+The Loongson MMI code modifies -march and as a result it breaks linking
+when the rest of the code is built with a different -match/-mtune.
+This patch fixes the problem by trying to link the code instead of just
+compiling it. This patch is already committed upstream.
+
+Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
+
+From d77d75cc6e5de14d027d22b70389a4d0c71048b9 Mon Sep 17 00:00:00 2001
+From: Markos Chandras <markos.chandras@imgtec.com>
+Date: Wed, 15 May 2013 16:51:20 +0000
+Subject: Use AC_LINK_IFELSE to check if the Loongson MMI code can link
+
+The Loongson code is compiled with -march=loongson2f to enable the MMI
+instructions, but binutils refuses to link object code compiled with
+different -march settings, leading to link failures later in the
+compile. This avoids that problem by checking if we can link code
+compiled for Loongson.
+
+Reviewed-by: Matt Turner <mattst88@gmail.com>
+Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
+---
+diff --git a/configure.ac b/configure.ac
+index c43a0d2..221179f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -279,7 +279,7 @@ AC_MSG_CHECKING(whether to use Loongson MMI assembler)
+ 
+ xserver_save_CFLAGS=$CFLAGS
+ CFLAGS=" $LS_CFLAGS $CFLAGS -I$srcdir"
+-AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
++AC_LINK_IFELSE([AC_LANG_SOURCE([[
+ #ifndef __mips_loongson_vector_rev
+ #error "Loongson Multimedia Instructions are only available on Loongson"
+ #endif
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/package/pixman/pixman.mk b/package/pixman/pixman.mk
index c2ee035..7822ede 100644
--- a/package/pixman/pixman.mk
+++ b/package/pixman/pixman.mk
@@ -3,11 +3,12 @@ 
 # pixman
 #
 ################################################################################
-PIXMAN_VERSION = 0.28.2
+PIXMAN_VERSION = 0.30.0
 PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
 PIXMAN_LICENSE = MIT
 PIXMAN_LICENSE_FILES = COPYING
 
+PIXMAN_AUTORECONF = YES
 PIXMAN_INSTALL_STAGING = YES
 PIXMAN_DEPENDENCIES = host-pkgconf
 # don't build gtk based demos