diff mbox

[v6,7/7] package: Introduce NOMMU symbol

Message ID 1366279592-9055-7-git-send-email-sonic.adi@gmail.com
State Superseded
Headers show

Commit Message

Sonic Zhang April 18, 2013, 10:06 a.m. UTC
From: Sonic Zhang <sonic.zhang@analog.com>

Introduce NOMMU symbol __NOMMU__

---
v6-changes:
- Remove space between comma and y.
- Restore endif after rebase.

Signed-off-by: Sonic Zhang <sonic.zhang@analog.com>
---
 package/Makefile.in |    4 ++++
 1 files changed, 4 insertions(+), 0 deletions(-)

Comments

Sonic Zhang April 26, 2013, 3:22 a.m. UTC | #1
Hi Thomas,

On Thu, Apr 18, 2013 at 6:06 PM, Sonic Zhang <sonic.adi@gmail.com> wrote:
> From: Sonic Zhang <sonic.zhang@analog.com>
>
> Introduce NOMMU symbol __NOMMU__
>
> ---
> v6-changes:
> - Remove space between comma and y.
> - Restore endif after rebase.
>
> Signed-off-by: Sonic Zhang <sonic.zhang@analog.com>
> ---
>  package/Makefile.in |    4 ++++
>  1 files changed, 4 insertions(+), 0 deletions(-)
>
> diff --git a/package/Makefile.in b/package/Makefile.in
> index a449089..55d725d 100644
> --- a/package/Makefile.in
> +++ b/package/Makefile.in
> @@ -107,6 +107,10 @@ ifeq ($(BR2_BINFMT_FLAT),y)
>  TARGET_LDFLAGS += $(if $($(PKG)_FLAT_STACKSIZE),-Wl$(comma)-elf2flt=-s$($(PKG)_FLAT_STACKSIZE))
>  endif
>
> +ifneq ($(BR2_USE_MMU),y)
> +TARGET_CFLAGS += -D__NOMMU__
> +endif
> +
>  ifeq ($(BR2_BINFMT_FLAT_SHARED),y)
>  TARGET_LDFLAGS += -mid-shared-library -mshared-library-id=0
>  TARGET_CFLAGS += -mid-shared-library -mshared-library-id=0
> --
> 1.7.0.4
>
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot

May I have your Acked-by against this patch?

Thanks

Sonic Zhang
diff mbox

Patch

diff --git a/package/Makefile.in b/package/Makefile.in
index a449089..55d725d 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -107,6 +107,10 @@  ifeq ($(BR2_BINFMT_FLAT),y)
 TARGET_LDFLAGS += $(if $($(PKG)_FLAT_STACKSIZE),-Wl$(comma)-elf2flt=-s$($(PKG)_FLAT_STACKSIZE))
 endif
 
+ifneq ($(BR2_USE_MMU),y)
+TARGET_CFLAGS += -D__NOMMU__
+endif
+
 ifeq ($(BR2_BINFMT_FLAT_SHARED),y)
 TARGET_LDFLAGS += -mid-shared-library -mshared-library-id=0
 TARGET_CFLAGS += -mid-shared-library -mshared-library-id=0