diff mbox

[v2,5/8] gptfdisk: fix installation step

Message ID 1362689131-1479-6-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Headers show

Commit Message

Thomas Petazzoni March 7, 2013, 8:45 p.m. UTC
The installation step was not giving the full destination path even
though it was using -D, and it was forgetting to explicitly specify
the permissions of the file to install. This commit fixes both of
these minor issues.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/gptfdisk/gptfdisk.mk |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard March 10, 2013, 9:23 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> The installation step was not giving the full destination path even
 Thomas> though it was using -D, and it was forgetting to explicitly specify
 Thomas> the permissions of the file to install. This commit fixes both of
 Thomas> these minor issues.

Committed, thanks.
diff mbox

Patch

diff --git a/package/gptfdisk/gptfdisk.mk b/package/gptfdisk/gptfdisk.mk
index 656a187..988eecf 100644
--- a/package/gptfdisk/gptfdisk.mk
+++ b/package/gptfdisk/gptfdisk.mk
@@ -22,7 +22,7 @@  endef
 
 define GPTFDISK_INSTALL_TARGET_CMDS
 	for i in $(GPTFDISK_TARGETS_y); do \
-	    $(INSTALL) -D $(@D)/$$i $(TARGET_DIR)/usr/sbin/; \
+	    $(INSTALL) -D -m 0755 $(@D)/$$i $(TARGET_DIR)/usr/sbin/$$i; \
 	done
 endef