diff mbox

[v2,4/8] gptfdisk: use TARGET_CONFIGURE_OPTS properly, use TARGET_MAKE_ENV

Message ID 1362689131-1479-5-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Headers show

Commit Message

Thomas Petazzoni March 7, 2013, 8:45 p.m. UTC
$(TARGET_CONFIGURE_OPTS) should be passed as $(MAKE) argument, not in
the environment. We can then remove the redefined CC and LD variables
that were useless. We also take this opportunity to pass
$(TARGET_MAKE_ENV) in the environment of make.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/gptfdisk/gptfdisk.mk |    5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Peter Korsgaard March 10, 2013, 9:22 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> $(TARGET_CONFIGURE_OPTS) should be passed as $(MAKE) argument, not in
 Thomas> the environment. We can then remove the redefined CC and LD variables
 Thomas> that were useless. We also take this opportunity to pass
 Thomas> $(TARGET_MAKE_ENV) in the environment of make.

Committed, thanks.
diff mbox

Patch

diff --git a/package/gptfdisk/gptfdisk.mk b/package/gptfdisk/gptfdisk.mk
index 2d3cb1a..656a187 100644
--- a/package/gptfdisk/gptfdisk.mk
+++ b/package/gptfdisk/gptfdisk.mk
@@ -15,10 +15,9 @@  ifeq ($(BR2_PACKAGE_GPTFDISK_SGDISK),y)
     GPTFDISK_DEPENDENCIES += popt
 endif
 
-
 define GPTFDISK_BUILD_CMDS
-	$(TARGET_CONFIGURE_OPTS) $(MAKE) CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" \
-		-C $(@D) $(GPTFDISK_TARGETS_y)
+	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+		$(GPTFDISK_TARGETS_y)
 endef
 
 define GPTFDISK_INSTALL_TARGET_CMDS