diff mbox

Fixed dts parent directory issue.

Message ID 1360688135-7785-1-git-send-email-nagy@accelecon.com
State Superseded
Headers show

Commit Message

Michael Nagy Feb. 12, 2013, 4:55 p.m. UTC
---
 linux/linux.mk |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Feb. 12, 2013, 7:27 p.m. UTC | #1
Dear Michael Nagy,

On Tue, 12 Feb 2013 11:55:35 -0500, Michael Nagy wrote:

>  define LINUX_INSTALL_DTB
> -	cp $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb $(BINARIES_DIR)/
> +	cp $(KERNEL_ARCH_PATH)/boot/dts/$(KERNEL_DTS_NAME).dtb $(BINARIES_DIR)/
>  endef
>  endif
>  endif

This has already been fixed in the Git repository by
5b33e0b6a139ce3a622817b45a8882a448312fc0 and
a1cfe20df6c6b4f148db0c104e8ff701654a2c09.

Your fix was also not entirely correct, because it would have broken
the build of kernel earlier than 3.8 (at which time dtbs were build in
arch/<arch>/boot and not arch/<arch>/boot/dts). The commits we have in
the Git repository take this into account.

Note that those two fixes are also part of the 2013.02-rc1 release
candidate that was published a few days ago.

Best regards,

Thomas
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index c4bdf90..8182f62 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -190,14 +190,14 @@  define LINUX_BUILD_DTB
 	$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(KERNEL_DTS_NAME).dtb
 endef
 define LINUX_INSTALL_DTB
-	cp $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb $(BINARIES_DIR)/
+	cp $(KERNEL_ARCH_PATH)/boot/dts/$(KERNEL_DTS_NAME).dtb $(BINARIES_DIR)/
 endef
 endif
 endif
 
 ifeq ($(BR2_LINUX_KERNEL_APPENDED_UIMAGE),y)
 define LINUX_APPEND_DTB
-	cat $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb >> $(KERNEL_ARCH_PATH)/boot/zImage
+	cat $(KERNEL_ARCH_PATH)/boot/dts/$(KERNEL_DTS_NAME).dtb >> $(KERNEL_ARCH_PATH)/boot/zImage
 	# We need to generate the uImage here after that so that the uImage is
 	# generated with the right image size.
 	$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) uImage