diff mbox

[3/5] Add common declaration to ease the support of both version

Message ID 1360678441-3199-4-git-send-email-kpa_info@yahoo.fr
State Superseded
Headers show

Commit Message

kpa_info@yahoo.fr Feb. 12, 2013, 2:13 p.m. UTC
Define a new variable called PYTHON_GENERIC_DEPENDENCIES either to
"python" or "python3" depending of the selected Python version. This
is needed to easily set dependencies for packages that could be used
either with Python 2 or Python 3.

Signed-off-by: Patrick Gerber <kpa_info@yahoo.fr>
---
 package/python-generic/python-generic.mk |   16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 package/python-generic/python-generic.mk
diff mbox

Patch

diff --git a/package/python-generic/python-generic.mk b/package/python-generic/python-generic.mk
new file mode 100644
index 0000000..0cf0e9d
--- /dev/null
+++ b/package/python-generic/python-generic.mk
@@ -0,0 +1,16 @@ 
+#############################################################
+#
+# python-generic
+#
+#############################################################
+# PYTHON_GENERIC_DEPENDENCIES is defined to the selected python 
+# version. 
+
+ifeq ($(BR2_PACKAGE_PYTHON),y)
+	PYTHON_GENERIC_DEPENDENCIES = python
+endif
+
+ifeq ($(BR2_PACKAGE_PYTHON3),y)
+	PYTHON_GENERIC_DEPENDENCIES = python3
+endif
+