diff mbox

iftop: new package

Message ID 1358800841-20820-1-git-send-email-bogdan@nimblex.net
State Accepted
Headers show

Commit Message

Bogdan Radulescu Jan. 21, 2013, 8:40 p.m. UTC
Added the iftop package which is really usefull to see quickly
what uses the bandwidth on your machine.

Signed-off-by: Bogdan Radulescu <bogdan@nimblex.net>
---
 package/Config.in       |  1 +
 package/iftop/Config.in | 15 +++++++++++++++
 package/iftop/iftop.mk  | 15 +++++++++++++++
 3 files changed, 31 insertions(+)
 create mode 100644 package/iftop/Config.in
 create mode 100644 package/iftop/iftop.mk

Comments

Peter Korsgaard Jan. 21, 2013, 9:59 p.m. UTC | #1
>>>>> "Bogdan" == Bogdan Radulescu <bogdan@nimblex.net> writes:

 Bogdan> Added the iftop package which is really usefull to see quickly
 Bogdan> what uses the bandwidth on your machine.

 Bogdan> Signed-off-by: Bogdan Radulescu <bogdan@nimblex.net>
 Bogdan> ---
 Bogdan>  package/Config.in       |  1 +
 Bogdan>  package/iftop/Config.in | 15 +++++++++++++++
 Bogdan>  package/iftop/iftop.mk  | 15 +++++++++++++++
 Bogdan>  3 files changed, 31 insertions(+)
 Bogdan>  create mode 100644 package/iftop/Config.in
 Bogdan>  create mode 100644 package/iftop/iftop.mk

 Bogdan> diff --git a/package/Config.in b/package/Config.in
 Bogdan> index ba03b3c..9e2dd8b 100644
 Bogdan> --- a/package/Config.in
 Bogdan> +++ b/package/Config.in
 Bogdan> @@ -772,6 +772,7 @@ endif
 Bogdan>  source "package/bwm-ng/Config.in"
 Bogdan>  source "package/cpuload/Config.in"
 Bogdan>  source "package/htop/Config.in"
 Bogdan> +source "package/iftop/Config.in"

I find it more sensible to have it under Networking applications
together with E.G. iperf, so I've moved it.

 Bogdan> +++ b/package/iftop/iftop.mk
 Bogdan> @@ -0,0 +1,15 @@
 Bogdan> +#############################################################
 Bogdan> +#
 Bogdan> +# iftop
 Bogdan> +#
 Bogdan> +#############################################################
 Bogdan> +
 Bogdan> +IFTOP_VERSION = 1.0pre2
 Bogdan> +IFTOP_SITE = http://www.ex-parrot.com/pdw/iftop/download/
 Bogdan> +
 Bogdan> +IFTOP_DEPENDENCIES = ncurses libpcap
 Bogdan> +
 Bogdan> +IFTOP_LICENSE = GPL
 Bogdan> +IFTOP_LICENSE_FILES = COPYING

License is GPLv2+

Committed with these changes, thanks.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index ba03b3c..9e2dd8b 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -772,6 +772,7 @@  endif
 source "package/bwm-ng/Config.in"
 source "package/cpuload/Config.in"
 source "package/htop/Config.in"
+source "package/iftop/Config.in"
 source "package/keyutils/Config.in"
 source "package/kmod/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
diff --git a/package/iftop/Config.in b/package/iftop/Config.in
new file mode 100644
index 0000000..99ea973
--- /dev/null
+++ b/package/iftop/Config.in
@@ -0,0 +1,15 @@ 
+config BR2_PACKAGE_IFTOP
+	bool "iftop"
+	select BR2_PACKAGE_NCURSES
+	select BR2_PACKAGE_LIBPCAP
+	depends on BR2_INET_IPV6
+	help
+	  iftop does for network usage what top(1) does for CPU usage.
+	  It listens to network traffic on a named interface and displays
+	  a table of current bandwidth usage by pairs of hosts. Handy for
+	  answering the question "why is our ADSL link so slow?".
+
+	  http://www.ex-parrot.com/pdw/iftop/
+
+comment "iftop requires IPv6 support in toolchain"
+	depends on !BR2_INET_IPV6
diff --git a/package/iftop/iftop.mk b/package/iftop/iftop.mk
new file mode 100644
index 0000000..48c9480
--- /dev/null
+++ b/package/iftop/iftop.mk
@@ -0,0 +1,15 @@ 
+#############################################################
+#
+# iftop
+#
+#############################################################
+
+IFTOP_VERSION = 1.0pre2
+IFTOP_SITE = http://www.ex-parrot.com/pdw/iftop/download/
+
+IFTOP_DEPENDENCIES = ncurses libpcap
+
+IFTOP_LICENSE = GPL
+IFTOP_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))