diff mbox

[3/3] sdl_gfx: bump to version 2.0.24

Message ID 1358453318-751-3-git-send-email-gilles.talis@gmail.com
State Accepted
Headers show

Commit Message

Gilles Talis Jan. 17, 2013, 8:08 p.m. UTC
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
---
 package/sdl_gfx/sdl_gfx.mk |    5 ++++-
 1 files changed, 4 insertions(+), 1 deletions(-)

Comments

Peter Korsgaard Jan. 19, 2013, 9:46 p.m. UTC | #1
>>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:

 Gilles> Signed-off-by: Gilles Talis <gilles.talis@gmail.com>

I'm having problems building 2.0.24, as it ends up trying to run aclocal
during the build step:

>>> sdl_gfx 2.0.24 Building
PATH="/home/peko/source/buildroot/testsdl/host/bin:/home/peko/source/buildroot/testsdl/host/usr/bin:/home/peko/source/buildroot/testsdl/host/usr/sbin/:/home/peko/bin:/home/peko/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/opt/barco/current/usr/bin:/opt/barco/current/usr/bin" PERLLIB="/home/peko/source/buildroot/testsdl/host/usr/lib/perl"  /usr/bin/make -j8  -C /home/peko/source/buildroot/testsdl/build/sdl_gfx-2.0.24/
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash
/home/peko/source/buildroot/testsdl/build/sdl_gfx-2.0.24/missing --run
aclocal-1.11 -I m4

I haven't figured out why yet. 2.0.23 builds fine and I don't see any
significant changes to the build system between 23 and 24 (besides that
aclocal.m4 has been generated by a newer aclocal version).

So I've changed it to use 2.0.23 for now instead.
Gilles Talis Jan. 25, 2013, 2:59 a.m. UTC | #2
finally found some time to look into this.
The issue comes from the fact that even though aclocal.m4 and
configure.inare identical across 2.0.23 and 2.0.24,
configure.in timestamp has changed, making it newer than aclocal.m4. This
leads "make" to try and re-generate aclocal.m4.
I am not expert enough in aclocal and m4 to fix the missing variables
issue. The only quick & dirty workaround I have found is to change
configure.in file timestamp to what it was in 2.0.23 (touch -t .....).

Would it be an acceptable patch to bump sdl_gfx to 2.0.24?

thanks
Gilles.

2013/1/19 Peter Korsgaard <jacmet@uclibc.org>

> >>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:
>
>  Gilles> Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
>
> I'm having problems building 2.0.24, as it ends up trying to run aclocal
> during the build step:
>
> >>> sdl_gfx 2.0.24 Building
> PATH="/home/peko/source/buildroot/testsdl/host/bin:/home/peko/source/buildroot/testsdl/host/usr/bin:/home/peko/source/buildroot/testsdl/host/usr/sbin/:/home/peko/bin:/home/peko/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/opt/barco/current/usr/bin:/opt/barco/current/usr/bin"
> PERLLIB="/home/peko/source/buildroot/testsdl/host/usr/lib/perl"
>  /usr/bin/make -j8  -C
> /home/peko/source/buildroot/testsdl/build/sdl_gfx-2.0.24/
> CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash
> /home/peko/source/buildroot/testsdl/build/sdl_gfx-2.0.24/missing --run
> aclocal-1.11 -I m4
>
> I haven't figured out why yet. 2.0.23 builds fine and I don't see any
> significant changes to the build system between 23 and 24 (besides that
> aclocal.m4 has been generated by a newer aclocal version).
>
> So I've changed it to use 2.0.23 for now instead.
>
> --
> Bye, Peter Korsgaard
>
Peter Korsgaard Jan. 25, 2013, 10:06 a.m. UTC | #3
>>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:

 Gilles> finally found some time to look into this.

 Gilles> The issue comes from the fact that even though aclocal.m4 and
 Gilles> configure.in are identical across 2.0.23 and 2.0.24,
 Gilles>  configure.in timestamp has changed, making it newer than
 Gilles> aclocal.m4. This leads "make" to try and re-generate
 Gilles> aclocal.m4.  I am not expert enough in aclocal and m4 to fix
 Gilles> the missing variables issue.  The only quick & dirty workaround
 Gilles> I have found is to change configure.in file timestamp to what
 Gilles> it was in 2.0.23 (touch -t .....).

 Gilles> Would it be an acceptable patch to bump sdl_gfx to 2.0.24?

Is there any strong reason to go for 2.0.24 over 23? Perhaps you could
bring it up with sdl_gfx and get them to do a 2.0.25 release with
aclocal.m4 regenerated?
diff mbox

Patch

diff --git a/package/sdl_gfx/sdl_gfx.mk b/package/sdl_gfx/sdl_gfx.mk
index c1c7f91..440e7ea 100644
--- a/package/sdl_gfx/sdl_gfx.mk
+++ b/package/sdl_gfx/sdl_gfx.mk
@@ -3,9 +3,12 @@ 
 # SDL_gfx addon for SDL
 #
 #############################################################
-SDL_GFX_VERSION = 2.0.19
+
+SDL_GFX_VERSION = 2.0.24
 SDL_GFX_SOURCE = SDL_gfx-$(SDL_GFX_VERSION).tar.gz
 SDL_GFX_SITE = http://www.ferzkopp.net/Software/SDL_gfx-2.0/
+SDL_GFX_LICENSE = zlib
+SDL_GFX_LICENSE_FILES = COPYING LICENSE
 SDL_GFX_INSTALL_STAGING = YES
 SDL_GFX_DEPENDENCIES = sdl
 SDL_GFX_CONF_OPT = \