diff mbox

iftop: new package

Message ID 1358351378-10876-2-git-send-email-bogdan@nimblex.net
State Changes Requested
Headers show

Commit Message

Bogdan Radulescu Jan. 16, 2013, 3:49 p.m. UTC
Added the iftop package which is really usefull to see quickly
what uses the bandwidth on your machine.
---
 package/Config.in       |  1 +
 package/iftop/Config.in | 12 ++++++++++++
 package/iftop/iftop.mk  | 14 ++++++++++++++
 3 files changed, 27 insertions(+)
 create mode 100644 package/iftop/Config.in
 create mode 100644 package/iftop/iftop.mk

Comments

Thomas Petazzoni Jan. 16, 2013, 1:55 p.m. UTC | #1
Dear Bogdan Radulescu,

On Wed, 16 Jan 2013 15:49:38 +0000, Bogdan Radulescu wrote:

> +	select BR2_TOOLCHAIN_BUILDROOT_INET_IPV6

No, selecting toolchain options is not correct, and in this particular
case, it would only work for the internal toolchain backend (breaking
the external backend and Crosstool-NG backend).

See package/squid/Config.in for an example.

Basically, you must do something like:

config BR2_PACKAGE_FOO
	depends on BR2_INET_IPV6

comment "foo requires IPv6 support in toolchain"
	depends on !BR2_INET_IPV6

Best regards,

Thomas
Peter Korsgaard Jan. 16, 2013, 2:11 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> Dear Bogdan Radulescu,
 Thomas> On Wed, 16 Jan 2013 15:49:38 +0000, Bogdan Radulescu wrote:

 >> +	select BR2_TOOLCHAIN_BUILDROOT_INET_IPV6

 Thomas> No, selecting toolchain options is not correct, and in this particular
 Thomas> case, it would only work for the internal toolchain backend (breaking
 Thomas> the external backend and Crosstool-NG backend).

 Thomas> See package/squid/Config.in for an example.

 Thomas> Basically, you must do something like:

 Thomas> config BR2_PACKAGE_FOO
 Thomas> 	depends on BR2_INET_IPV6

 Thomas> comment "foo requires IPv6 support in toolchain"
 Thomas> 	depends on !BR2_INET_IPV6

Indeed. Also don't forget to sign off on your patch (git commit -s).
Peter Korsgaard Jan. 20, 2013, 8:50 p.m. UTC | #3
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

Hi,

 Thomas> No, selecting toolchain options is not correct, and in this particular
 Thomas> case, it would only work for the internal toolchain backend (breaking
 Thomas> the external backend and Crosstool-NG backend).

 Thomas> See package/squid/Config.in for an example.

 Thomas> Basically, you must do something like:

 Thomas> config BR2_PACKAGE_FOO
 Thomas> 	depends on BR2_INET_IPV6

 Thomas> comment "foo requires IPv6 support in toolchain"
 Thomas> 	depends on !BR2_INET_IPV6

Bogdan, care to resend with the issues pointed out by me and Thomas
fixed?
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index ba03b3c..9e2dd8b 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -772,6 +772,7 @@  endif
 source "package/bwm-ng/Config.in"
 source "package/cpuload/Config.in"
 source "package/htop/Config.in"
+source "package/iftop/Config.in"
 source "package/keyutils/Config.in"
 source "package/kmod/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
diff --git a/package/iftop/Config.in b/package/iftop/Config.in
new file mode 100644
index 0000000..ddcc4c9
--- /dev/null
+++ b/package/iftop/Config.in
@@ -0,0 +1,12 @@ 
+config BR2_PACKAGE_IFTOP
+	bool "iftop"
+	select BR2_PACKAGE_NCURSES
+	select BR2_PACKAGE_LIBPCAP
+	select BR2_TOOLCHAIN_BUILDROOT_INET_IPV6
+	help
+	  iftop does for network usage what top(1) does for CPU usage.
+	  It listens to network traffic on a named interface and displays
+	  a table of current bandwidth usage by pairs of hosts. Handy for
+	  answering the question "why is our ADSL link so slow?".
+
+	  http://www.ex-parrot.com/pdw/iftop/
diff --git a/package/iftop/iftop.mk b/package/iftop/iftop.mk
new file mode 100644
index 0000000..3c8df9d
--- /dev/null
+++ b/package/iftop/iftop.mk
@@ -0,0 +1,14 @@ 
+#############################################################
+#
+# iftop
+#
+#############################################################
+IFTOP_VERSION = 1.0pre2
+IFTOP_SITE = http://www.ex-parrot.com/pdw/iftop/download/
+
+IFTOP_DEPENDENCIES = ncurses libpcap
+
+IFTOP_LICENSE = GPL
+IFTOP_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))