diff mbox

Clean kernel when "make linux-clean" is called

Message ID 1354886413-28939-1-git-send-email-sho@relinux.de
State Rejected
Headers show

Commit Message

Stephan Hoffmann Dec. 7, 2012, 1:20 p.m. UTC
When "make linux-clean" is typed one expects that the kernel tree
gets cleaned. Before this patch, only the stamp files had been
removed.

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
---
 linux/linux.mk |    3 +++
 1 files changed, 3 insertions(+), 0 deletions(-)

Comments

Stephan Hoffmann Jan. 31, 2013, 4:41 p.m. UTC | #1
ping
Am 07.12.2012 14:20, schrieb Stephan Hoffmann:
> When "make linux-clean" is typed one expects that the kernel tree
> gets cleaned. Before this patch, only the stamp files had been
> removed.
>
> Signed-off-by: Stephan Hoffmann <sho@relinux.de>
> ---
>  linux/linux.mk |    3 +++
>  1 files changed, 3 insertions(+), 0 deletions(-)
>
> diff --git a/linux/linux.mk b/linux/linux.mk
> index c4bdf90..e517d1d 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -221,6 +221,9 @@ define LINUX_BUILD_CMDS
>  	$(LINUX_APPEND_DTB)
>  endef
>  
> +define LINUX_CLEAN_CMDS
> +	$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) clean
> +endef
>  
>  ifeq ($(BR2_LINUX_KERNEL_INSTALL_TARGET),y)
>  define LINUX_INSTALL_KERNEL_IMAGE_TO_TARGET
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index c4bdf90..e517d1d 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -221,6 +221,9 @@  define LINUX_BUILD_CMDS
 	$(LINUX_APPEND_DTB)
 endef
 
+define LINUX_CLEAN_CMDS
+	$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) clean
+endef
 
 ifeq ($(BR2_LINUX_KERNEL_INSTALL_TARGET),y)
 define LINUX_INSTALL_KERNEL_IMAGE_TO_TARGET