diff mbox

pkg-infra: correct the source name for host-only packages

Message ID 1350227854-6823-1-git-send-email-arnout@mind.be
State Accepted
Commit 79bfcd556027901b847cae063cbcfbedf75e394a
Headers show

Commit Message

Arnout Vandecappelle Oct. 14, 2012, 3:17 p.m. UTC
Host-only package that don't define their <PKG>_SOURCE variable would
default to host-<pkg>-<version>.tar.gz.  It's more logical to remove
the host- prefix in this case.

This problem is most apparent with host-only packages downloaded from
version control, because they never define <PKG>_SOURCE.

Reported by Thomas Petazzoni and initial analysis by Luca Ceresoli.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

---
 package/pkg-generic.mk |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Oct. 14, 2012, 5:55 p.m. UTC | #1
On Sun, 14 Oct 2012 17:17:34 +0200, Arnout Vandecappelle
(Essensium/Mind) wrote:
> Host-only package that don't define their <PKG>_SOURCE variable would
> default to host-<pkg>-<version>.tar.gz.  It's more logical to remove
> the host- prefix in this case.
> 
> This problem is most apparent with host-only packages downloaded from
> version control, because they never define <PKG>_SOURCE.
> 
> Reported by Thomas Petazzoni and initial analysis by Luca Ceresoli.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Thanks!

Thomas
Peter Korsgaard Oct. 15, 2012, 7:29 a.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 Arnout> Host-only package that don't define their <PKG>_SOURCE variable would
 Arnout> default to host-<pkg>-<version>.tar.gz.  It's more logical to remove
 Arnout> the host- prefix in this case.

 Arnout> This problem is most apparent with host-only packages downloaded from
 Arnout> version control, because they never define <PKG>_SOURCE.

 Arnout> Reported by Thomas Petazzoni and initial analysis by Luca Ceresoli.

Committed, thanks.
diff mbox

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index ffe7dfb..270da60 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -231,7 +231,7 @@  ifndef $(2)_SOURCE
  ifdef $(3)_SOURCE
   $(2)_SOURCE = $($(3)_SOURCE)
  else
-  $(2)_SOURCE			?= $$($(2)_BASE_NAME).tar.gz
+  $(2)_SOURCE			?= $$($(2)_RAWNAME)-$$($(2)_VERSION).tar.gz
  endif
 endif