diff mbox

unionfs: add patch to disable search for the C++ compiler

Message ID 1350206503-22821-1-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 7b0e4f21d30cf115baa8b57a7edd7683d58ced6f
Headers show

Commit Message

Thomas Petazzoni Oct. 14, 2012, 9:21 a.m. UTC
Fixes

  http://autobuild.buildroot.org/results/9c4a9897dda1b99cc7a57af605301b53ed32b95d/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/unionfs/unionfs-fuse-no-cxx-needed.patch |   19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 package/unionfs/unionfs-fuse-no-cxx-needed.patch

Comments

Peter Korsgaard Oct. 14, 2012, 9:39 a.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> Fixes
 Thomas>   http://autobuild.buildroot.org/results/9c4a9897dda1b99cc7a57af605301b53ed32b95d/build-end.log

Committed, thanks.
diff mbox

Patch

diff --git a/package/unionfs/unionfs-fuse-no-cxx-needed.patch b/package/unionfs/unionfs-fuse-no-cxx-needed.patch
new file mode 100644
index 0000000..56f7e24
--- /dev/null
+++ b/package/unionfs/unionfs-fuse-no-cxx-needed.patch
@@ -0,0 +1,19 @@ 
+By default, CMake assumes a project uses the C and C++ languages, so
+it checks for both the C and the C++ compiler to exist.
+
+However, unionfs-fuse is written purely in C, so checking for a C++
+compiler is useless, and even prevents unionfs-fuse from building
+properly on targets for which no C++ compiler is available.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-project(unionfs-fuse)
++project(unionfs-fuse C)
+ 
+ cmake_minimum_required(VERSION 2.0)
+ INCLUDE (CheckIncludeFiles)